xgnokii fails to start

Bug #122072 reported by Jarno Suni on 2007-06-25
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnokii (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnokii

I start xgnokii in terminal, I get the following

(xgnokii:5830): Gtk-WARNING **: horizontal scrolling not implemented

(xgnokii:5830): Gtk-WARNING **: horizontal scrolling not implemented
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Illegal seek
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Illegal seek
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Illegal seek
Telephone interface init failed: Command failed.
Quitting.
Failed to open the phone. Quitting.

OS is Feisty.
Gnokii version 0.6.14-3.

Pawel Kot (gnokii) wrote :

Please report it with your gnokii config file, phone model and connection type. It seems that your hardware (probably serial cable) is not well supported by Linux kernel or you misconfigured gnokii.

Jarno Suni (jarnos) wrote :

I am very newbie with Gnokii. I have not configured it yet. Anyway I have Nokia 3120 & CA-42 cable. The cable was not connected when I started xgnokii. I found /etc/gnokiirc but I suppose it is the default one, see the attachment.

BTW in the same case, but in Dapper, gnokii version 0.6.12-0ubuntu3, xgnokii starts, but I can not close it normally.

Marco Rodrigues (gothicx) wrote :

Hi! Can you test if this still happens with Gutsy version ? Thanks

Changed in gnokii:
assignee: nobody → gothicx
importance: Undecided → Low
status: New → Incomplete
Jarno Suni (jarnos) wrote :

OK. Here's what I get when the phone is not connected:

$ xgnokii
LOG: debug mask is 0x1
Config read from file /home/jarnos/.gnokiirc.

(xgnokii:6661): Gtk-WARNING **: horizontal scrolling not implemented

(xgnokii:6661): Gtk-WARNING **: horizontal scrolling not implemented
phone instance config:
model: 3120
port_device: /dev/ttyUSB0
connection_type: 2
init_length: 0
serial_baudrate: 19200
serial_write_usleep: -1
hardware_handshake: 0
require_dcd: 0
smsc_timeout: 100
connect_script:
disconnect_script:
rfcomm_cn: 1
sm_retry: off
Connecting
Serial device: opening device /dev/ttyUSB0
Gnokii serial_open: open: No such file or directory
Couldn't open FBUS device: No such file or directory
Error in link initialisation: 1
Serial device: opening device /dev/ttyUSB0
Gnokii serial_open: open: No such file or directory
Couldn't open FBUS device: No such file or directory
Error in link initialisation: 1
Error in link initialisation: 1
Telephone interface init failed: Command failed.
Quitting.
Failed to open the phone. Quitting.

Here's what I get when I start xgnokii, when the phone is connected:

$ xgnokii
LOG: debug mask is 0x1
Config read from file /home/jarnos/.gnokiirc.

(xgnokii:6934): Gtk-WARNING **: horizontal scrolling not implemented

(xgnokii:6934): Gtk-WARNING **: horizontal scrolling not implemented
Lockfile /var/lock/LCK..ttyUSB0 is stale. Overriding it..
phone instance config:
model: 3120
port_device: /dev/ttyUSB0
connection_type: 2
init_length: 0
serial_baudrate: 19200
serial_write_usleep: -1
hardware_handshake: 0
require_dcd: 0
smsc_timeout: 100
connect_script:
disconnect_script:
rfcomm_cn: 1
sm_retry: off
Connecting
Serial device: opening device /dev/ttyUSB0
Serial device: setting RTS to low and DTR to low
Serial device: setting RTS to high and DTR to high
Serial device: setting speed to 19200
Switching to FBUS mode

Here xgokii freezes.

I remember they said in gnokii irc channel that xgnokii may ruin any Nokia Series 40 first generation phone's firmware and they recommend to use gnokii, instead. Maybe I should study how to use the command line interface. (If I remember right, they have some special repository where you can find newer version of the software. I tried it in Feisty earlier, and it warned me about the possible damage with my phone.)

Marco Rodrigues (gothicx) wrote :

Do you still use Feisty ? Try to upgrade to Gutsy...

Jarno Suni (jarnos) wrote :

But I use Gutsy already.

Changed in gnokii:
assignee: gothicx → nobody
Pawel Kot (gnokii) wrote :

This should be fixed within 0.6.23 (and later) upstream version.

Jarno Suni (jarnos) wrote :

Hardy has only 0.6.22.dfsg-3 :( But I suppose xgnokii wouldn't work with my phone anyway. I have been advised to use gnokii and I am going to try once I learn how to use it.

Jayson Rowe (jayson.rowe) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnokii:
status: Incomplete → Invalid
lirel (m8r-lcodw5) wrote :

xgnokii should at least give a graphical feedback that something is wrong. even if no phone is found.
for me it quits quietly when started from menu.
i'm using a 12d1:140c Huawei Technologies Co., Ltd 3g pen adapter.
network-manager in combination with usb-modeswitch succeeds to connect to the internet.

Changed in gnokii (Ubuntu):
status: Invalid → New
lirel (m8r-lcodw5) wrote :

I'm using xgnokii 0.6.28.dfsg-1 with ubuntu lucid x86_64.
the phone spawns ttyUSB0 to ttyUSB3 using the kernels option driver.
xgnokii complains about the not excisting config-file when run from terminal:
Couldn't read /home/administrator/.gnokiirc config file.

I am using licid x86_64
and here is the bit of .xsession-errors when I start xgnokii and I have hardly seen just a blink..
-----------------------
Couldn't read /home/yasir/.gnokiirc config file.
Couldn't read /home/yasir/.gnokiirc config file.

(xgnokii:5468): Gtk-WARNING **: horizontal scrolling not implemented

(xgnokii:5468): Gtk-WARNING **: horizontal scrolling not implemented
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Input/output error
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Input/output error
Gnokii serial_open: tcgetattr: Input/output error
Couldn't open FBUS device: Input/output error
Telephone interface init failed: Command failed.
Quitting.
Failed to open the phone. Quitting.
-------------------------------------------------------

Jan Staal (info-janstaal) wrote :

I'm having the same problem on Lucid. When trying to start, the logo appears for a split second and then nothing happens.

dforsi (daniele-forsi) wrote :

I hope that the following fixes will be useful to future users.

xgnokii 0.6.29 doesn't silently exit when using the default sample configuration:
http://git.savannah.gnu.org/cgit/gnokii.git/commit/?id=835e79

Mention that xgnokii uses the settings in the [global] section of the configuration file of gnokii
http://git.savannah.gnu.org/cgit/gnokii.git/commit/?id=61bd0b2

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnokii (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments