Ubuntu

Please merge gnochm-0.9.11 from Debian unstable

Reported by Artem Popov on 2008-05-26
4
Affects Status Importance Assigned to Milestone
gnochm (Ubuntu)
Wishlist
Unassigned

Bug Description

This is in Debian now and can be merged:

http://packages.debian.org/sid/gnochm

Related branches

Daniel Holbach (dholbach) wrote :

Did you review all the changes in ./debian/ and made sure they can really be dropped?

daniel@bert:~$ diff -ruN gnochm-0.9.{9,11}/debian | diffstat
 changelog | 73
 control | 10
 copyright | 2
 dirs | 1
 gnochm.menu | 2
 patches/00_relibtoolize_noguesssub.patch |11304 -------------------------------
 patches/02_fix_parent_bug.patch | 11
 patches/03_change-desktop-file.patch | 4
 patches/20_updatepo.patch | 22
 rules | 3
 10 files changed, 52 insertions(+), 11380 deletions(-)
daniel@bert:~$

https://wiki.ubuntu.com/SyncRequestProcess

Changed in gnochm:
status: New → Incomplete
Artem Popov (artfwo) wrote :

* 02_fix_parent_bug.patch (LP: #127864)
  As said in a comment to the bug, upstream 0.9.11 does not have this problem.

* Fix python-gtkhtml2 missing dependency (LP: #123582).
  This patch should be merged.

* debian/patches/00_relibtoolize_noguesssub.patch:
  Fixed upstream, dropped in Debian.

* debian/patches/05_manpages_warning.patch:
  Manpage removed upstream, patch dropped in Debian

* debian/patches/20_updatepo.patch:
  Fixed upstream, removed in Debian.

Changed in gnochm:
status: Incomplete → New
Daniel Holbach (dholbach) wrote :

When you say it should be merged, does that mean we should hold off doing the sync?

Artem Popov (artfwo) wrote :

Well, I don't quite understand the difference between a merge and a sync. But I wanted to note, that all Ubuntu patches except python-gtkhtml2 dependency difference may be safely dropped.

And the package can be adapted for Ubuntu with little to no effort. Shall I attach a debdiff against the Debian version?

Артём Попов wrote:
> Well, I don't quite understand the difference between a merge and a
> sync.

A sync imports the package from Debian exactly as it is, removing any Ubuntu
changes to it. A merge is a resynchronize with Debian, updating the package to
the new Debian version but keeping the (still needed) Ubuntu changes.

> But I wanted to note, that all Ubuntu patches except python-
> gtkhtml2 dependency difference may be safely dropped.

So this is a merge as there's still a patch to keep

> And the package can be adapted for Ubuntu with little to no effort.
> Shall I attach a debdiff against the Debian version?

Yes, please.

Artem Popov (artfwo) wrote :

Thanks for clarifying this!

Here's a debdiff against current Debian version (0.9.11-1).

description: updated
Emilio Pozuelo Monfort (pochu) wrote :

You shouldn't remove the previous Ubuntu changelog entries (0.9.9-0ubuntu1, ubuntu2, ubuntu3). Otherwise looks fine.

Do you want to make a good debdiff as to learn the process? If you do, I'll upload it.

Artem Popov (artfwo) wrote :

Well yes, I'm learning. Here's a better debdiff against Debian (did an update-maintainer for this as well). But there's a little problem with the original Debian package in rules:

clean::
    rm po/*.gmo

Fails when building source for the second time from a working directory. Changing rm to rm -f makes everything work again.

Emilio Pozuelo Monfort (pochu) wrote :

Uploaded, thanks!

Changed in gnochm:
importance: Undecided → Wishlist
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnochm - 0.9.11-1ubuntu1

---------------
gnochm (0.9.11-1ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #234928).
  * Remaining Ubuntu changes:
    - debian/control: Add dependency for python-gtkhtml2 (LP: #123582)
    - debian/control: Modify Maintainer value to match the
      DebianMaintainerField specification.
  * debian/patches/02_fix_parent_bug.patch:
    - Dropped, the problem is fixed upstream.

 -- Aerteieem PEopeove <email address hidden> Wed, 28 May 2008 09:16:06 +0700

Changed in gnochm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers