Deprecated klash kde3 binaries removed and not replaced with gnash-kde4

Bug #318849 reported by lunch
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Fix Released
Undecided
Sindhudweep Sarkar
Nominated for Intrepid by lunch
Nominated for Jaunty by lunch

Bug Description

Binary package hint: klash

The installation of klash (Version: 0.8.4-0ubuntu1) will reveal that the package doesn't contain any binary (it should contain /usr/bin/klash).

Here is what you get after listing the package:
# dpkg -L klash
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/klash
/usr/share/doc/klash/changelog.gz
/usr/share/doc/klash/copyright
/usr/share/doc/klash/changelog.Debian.gz

This used to work in Hardy (stopped in Intrepid). I added a regression tag...

Related branches

description: updated
Peter Antoniac (pan1nx)
Changed in gnash:
status: New → Confirmed
Revision history for this message
Sindhudweep Sarkar (sindhudweep-sarkar) wrote :

@war10ck:
can you test packages in my ppa to see if they fix your issue?

summary: - Installation of klash revealed that the package was not build properly
- (doesn't contain any binaries)
+ Deprecated klash kde3 binaries removed and not replaced with gnash-kde4
Revision history for this message
Tomasz Czapiewski (xeros) wrote :

@Sindhudweep Sarkar:
Packages in yours ppa don't fix this issue.
Just take a look at konqueror-plugin-gnash and klash packages - they have just docs, no binaries inside.
According to 'configure' script gnash has to be configured with "--enable-gui=kde4 --enable-kparts4" options for Klash build and Konqueror plugin support.

Revision history for this message
Tomasz Czapiewski (xeros) wrote :

Maybe debian/* files in this archive will help to build and package it with both GTK and KDE4 support.

http://www.getgnash.org/packages/snapshots/ubuntu/8.10/gnash_trunk20090225.tar.gz

Revision history for this message
Tomasz Czapiewski (xeros) wrote :

@Sindhudweep Sarkar:
Yours 0.8.5-0ubuntu1~ppa2 packages are older for apt/dpkg than those in standard ubuntu repositories. Now I've installed them with dpkg and I saw there is Klash compiled (& seams to be working) now but there's no Konqueror plugin compiled yet.
Please take a look at kde4 services files here:
http://www.getgnash.org/packages/snapshots/ubuntu/8.10/konqueror-plugin-gnash_trunk20090225_i386.deb
But one suggestion: /usr/share/kde4/apps/klash/pluginsinfo might contain:

-- snip --
number=1

[0]
description=Shockwave Flash 10.0.0.544
file=libklashpart.so
mime=application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player
name=Shockwave Flash
-- snip --

or something simmilar (I've used last flash version from wikipedia) to help flash support on sites which need flash > 7.0

Revision history for this message
Sindhudweep Sarkar (sindhudweep-sarkar) wrote : Re: [Bug 318849] Re: Deprecated klash kde3 binaries removed and not replaced with gnash-kde4

The konqueror plugin is a _seperate_ packaging issue, and I will be
dealing with that later.

This is what you should see in the package

./
usr/
usr/bin/
usr/bin/kde4-gnash
usr/bin/gnash
usr/share/
usr/share/doc/
usr/share/doc/klash/
usr/share/doc/klash/changelog.gz
usr/share/doc/klash/changelog.Debian.gz
usr/share/doc/klash/copyright
usr/share/pixmaps/
usr/share/pixmaps/klash.xpm
usr/share/applications/
usr/share/applications/klash.desktop

unless I am terribly mistaken, kde4-gnash is there. please test.

On Mon, Apr 6, 2009 at 7:04 AM, Tomasz Czapiewski <email address hidden> wrote:
> Maybe debian/* files in this archive will help to build and package it
> with both GTK and KDE4 support.
>
> http://www.getgnash.org/packages/snapshots/ubuntu/8.10/gnash_trunk20090225.tar.gz
>
> --
> Deprecated klash kde3 binaries removed and not replaced with gnash-kde4
> https://bugs.launchpad.net/bugs/318849
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Sindhudweep Sarkar (sindhudweep-sarkar) wrote :

On Mon, Apr 6, 2009 at 7:50 AM, Tomasz Czapiewski <email address hidden> wrote:
> @Sindhudweep Sarkar:
> Yours 0.8.5-0ubuntu1~ppa2 packages are older for apt/dpkg than those in standard ubuntu repositories. Now I've installed them with dpkg and I saw there is Klash compiled (& seams to be working) now but there's no Konqueror plugin compiled yet.

Hmm maybe i made a versioning mistake. I assumed 0.8.5-0ubuntu1 would
be superceeded by 0.8.5-0ubuntu1~ppa2. Can you suggest a fix for this?
Glad to know Klash seems to be working.

> Please take a look at kde4 services files here:
> http://www.getgnash.org/packages/snapshots/ubuntu/8.10/konqueror-plugin-gnash_trunk20090225_i386.deb
> But one suggestion: /usr/share/kde4/apps/klash/pluginsinfo might contain:
>
> -- snip --
> number=1
>
> [0]
> description=Shockwave Flash 10.0.0.544
> file=libklashpart.so
> mime=application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player
> name=Shockwave Flash
> -- snip --
>
> or something simmilar (I've used last flash version from wikipedia) to
> help flash support on sites which need flash > 7.0
>
> --
> Deprecated klash kde3 binaries removed and not replaced with gnash-kde4
> https://bugs.launchpad.net/bugs/318849
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Tomasz Czapiewski (xeros) wrote :

Maybe 0.8.5-0ubuntu2~ppa2 as package version? Then new version in ubuntu repositories like 0.8.5-0ubuntu2 and up should superceed it on upgrade.
I can now confirm that klash works properly with flash content on some sites I've tested (launched by "kde4-gnash http://website/flash_content.swf" in console - urls and content parameters extracted from web sites source) and indeed "description=Shockwave Flash 10.0.0.544" would help a lot - there are many sites with excessive dependency on flash 9 or 10 even with simple flash content which flash compatibile player compatibile with 6 or 7 can process without problems.

Revision history for this message
knue (sf-knue) wrote :

When does this get in the ubuntu repos? I'd like to use klash with kubuntu 9.04

Revision history for this message
Sindhudweep Sarkar (sindhudweep-sarkar) wrote :

I have to incorporate some suggestions from Tomasz and talk to
upstream about a question I have. Following that I'll have to get some
review time from the package maintainer, and I'm guessing he's
extremely busy right now given how late it is in the release cycle.

On Mon, Apr 13, 2009 at 7:03 PM, knue <email address hidden> wrote:
> When does this get in the ubuntu repos? I'd like to use klash with
> kubuntu 9.04
>
> --
> Deprecated klash kde3 binaries removed and not replaced with gnash-kde4
> https://bugs.launchpad.net/bugs/318849
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Alexander Sack (asac) wrote :

kde isnt supported anymore; nobody stepped up to add packaging support for kde4.

Changed in gnash (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Alexander Sack (asac) wrote :

of course, open for contributions.

Changed in gnash (Ubuntu):
status: Won't Fix → Confirmed
Changed in gnash (Ubuntu):
assignee: nobody → Sindhudweep Sarkar (sindhudweep-sarkar)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.7-0ubuntu1

---------------
gnash (0.8.7-0ubuntu1) lucid; urgency=low

  * new upstream release 0.8.7 (LP: #522254)
    - modified debian/gnash-common.install to ship new library libgnashagg.so.*
    - modified .bzr-builddeb/default.conf to point to new upstream location.
  * enable decoding of speex encoded audio
    - modified debian/control.
  * fix LP: #318849 - Deprecated klash kde3 binaries removed and not
    replaced with gnash-kde4.
    - modified debian/klash.desktop to point to kde4-gnash binary instead of klash.
    - modified debian/klash.install to install files necessary for kde4-gnash.
    - modified debian/rules to enable the kde4 gui.
    - modified debian/control to include kdelibs5-dev
  * fix LP: #322141 - konqueror-plugin-gnash contains no binaries
    - modified debian/konqueror-plugin-gnash.install to install files necessary for the gnash kpart.
    - modified debian/rules to build gnash kpart.
 -- Sindhudweep Narayan Sarkar <email address hidden> Mon, 08 Mar 2010 09:57:54 -0500

Changed in gnash (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers