Ubuntu

Glom 1.8.1 can't delete data from table list view

Reported by Maximiliano on 2008-11-19
2
Affects Status Importance Assigned to Milestone
glom (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: glom

Ubuntu 8.10
Glom 1.8.1

Create a table with fields.
Add data to some fields.
Table have two views, list and details.
In "details" view press "delete button" to erase data field, but in "list" view "delete button" don't work.

Related branches

Murray Cumming (murrayc) wrote :

Confirmed. Whoops. I'll fix it.

Changed in glom:
status: New → Confirmed
Murray Cumming (murrayc) wrote :

Fixed in the svn trunk and 1.8 branches with this commit:

2008-11-24 Murray Cumming <email address hidden>

 * glom/utility_widgets/db_adddel/db_adddel.cc:
 * glom/utility_widgets/db_adddel/db_adddel.h: Removed
 the unused signal_user_requested_delete signal.
 on_MenuPopup_activate_Delete() (also called when the button is pressed):
 Actually call user_requested_delete(), so that the user can delete a
 list row. I forgot to do this when moving the other stuff down into
 DbAddDel.
 Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/glom/+bug/299853
 (elmergato)

Changed in glom:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glom - 1.8.5-0ubuntu1

---------------
glom (1.8.5-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #256701), fixes LP bugs:
    + Clear the text in property dialogs for text items (LP: #309147)
    + Don't crash when showing and then hiding the grid (LP: #303453)
    + Temporarily remember the sort order so it is the same when navigating
      away and back (LP: #303422)
    + Use the list's sort order for the top-level records in the report
      (LP: #303425)
    + Users/Groups: Disable drag-and-drop for the treeview, because it is
      useless and confusing (LP: #299573)
    + Import: Sort the fields list alphabetically (LP: #306593)
    + delete primary key make unusuable the database (LP: #299549)
    + Spanish translate incomplete (LP: #299556)
    + import date format error (LP: #299591)
    + can't delete data from table list view (LP: #299853)
    + Field definition: default value not saved (LP: #299896)
    + reports crashing (LP: #300054)
    + Year error with date fields (LP: #300057)
    + list view: 2 records added instead of 1 (LP: #300819)
  * debian/control: Refreshed dependencies for libglom-dev.
  * debian/control: Updated build-deps to match configure checks. goocavnasmm
    build-dep bumped to version without .la files.
  * debian/rules: Don't delete the directory containing the templates.
  * debian/control, debian/rules, debian/glom-doc.*: Split out
    arch-independent manual and examples into separate package glom-doc, which
    is now recommended by glom (glom will still work if they're not available)
  * debian/copyright: Rewritten to new machine-readable format.

 -- Iain Lane <email address hidden> Sun, 11 Jan 2009 17:12:01 +0000

Changed in glom:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers