gnome-settings-daemon crashed with SIGSEGV in g_variant_unref()

Bug #804946 reported by Pedro Villavicencio on 2011-07-02
This bug affects 236 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Critical
glib2.0 (Ubuntu)
Critical
dobey
Oneiric
Critical
dobey

Bug Description

crashed while logging in.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.1.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic i686
Architecture: i386
Date: Sat Jul 2 19:25:09 2011
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/false
 PATH=(custom, no user)
SegvAnalysis:
 Segfault happened at: 0xe43c73 <g_variant_unref+35>: lock xadd %eax,0x14(%esi)
 PC (0x00e43c73) ok
 source "%eax" ok
 destination "0x14(%esi)" (0x00000014) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 g_variant_unref (value=0x0) at /build/buildd/glib2.0-2.29.8/./glib/gvariant-core.c:617
 g_settings_get_boolean (settings=0x0, key=0x810e222 "enable") at /build/buildd/glib2.0-2.29.8/./gio/gsettings.c:1955
 ?? () from /usr/lib/gnome-settings-daemon-3.0/liba11y-keyboard.so
 g_cclosure_marshal_VOID__STRING (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0, marshal_data=0x0) at /build/buildd/glib2.0-2.29.8/./gobject/gmarshal.c:498
 g_closure_invoke (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771
Title: gnome-settings-daemon crashed with SIGSEGV in g_variant_unref()
UpgradeStatus: Upgraded to oneiric on 2011-06-15 (17 days ago)
UserGroups:

Related branches

Pedro Villavicencio (pedro) wrote :

StacktraceTop:
 g_variant_unref (value=0x0) at /build/buildd/glib2.0-2.29.8/./glib/gvariant-core.c:617
 g_settings_get_boolean (settings=0x0, key=0x810e222 "enable") at /build/buildd/glib2.0-2.29.8/./gio/gsettings.c:1955
 maybe_show_status_icon (manager=0x97275e8) at gsd-a11y-keyboard-manager.c:445
 g_cclosure_marshal_VOID__STRING (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0, marshal_data=0x0) at /build/buildd/glib2.0-2.29.8/./gobject/gmarshal.c:498
 g_closure_invoke (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
matti salminen (salmiset) wrote :

On first reboot right after on-line upgrade on Jul 11 from Natty to Oneiric.

Changed in gnome-settings-daemon (Ubuntu):
status: New → In Progress
Rodrigo Moya (rodrigo-moya) wrote :

I haven't been able to replicate, but I think I have a fix, so can anyone attach his/her ~/.xsession-errors just after g-s-d crashes, please?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.1.3-0ubuntu5

---------------
gnome-settings-daemon (3.1.3-0ubuntu5) oneiric; urgency=low

  * debian/patches/01_git_shorter_syndaemon_delay.patch:
    - Remove this patch, it fixes the annoyance for some users and breaks it
      for others
  * debian/patches/17_react_when_streams_removed.patch:
    - Remove patch not being applied and already upstream
  * debian/patches/01_git_a11y_keyboard_cleanup.patch:
    - Do proper cleanup when the plugin is stopped (LP: #804946)
  * debian/patches/06_use_application_indicator.patch:
    - Rebased
 -- Rodrigo Moya <email address hidden> Tue, 12 Jul 2011 13:04:51 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
Jorge Godoy (jgodoy) wrote :

I still see the issue with 3.1.3-0ubuntu7.

Jeroen Roovers (jer-gentoo) wrote :

Yes, so bug #814635 is not a duplicate of this bug.

Sebastien Bacher (seb128) wrote :

Rodrigo, it seems some users still get that issue?

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Triaged
Rodrigo Moya (rodrigo-moya) wrote :

Ok, so can anyone still experiencing this paste their ~/.xsession-errors file?

matti salminen (salmiset) wrote :

Here you go. It's rather large so I have attached it in a file xsession-errors.txt

Sebastien Bacher (seb128) wrote :

Hey Pedro, could you upstream that one?

Changed in gnome-settings-daemon:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → New
Changed in gnome-settings-daemon:
status: New → Invalid
Changed in gnome-settings-daemon:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → New
Rodrigo Moya (rodrigo-moya) wrote :

This should hopefully be fixed by the latest libglib upload (2.29.90), so can people please install that and check if it still crashes?

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Incomplete

I haven't seen it in a while,
but it was really bad to my CPU,
potentially overheating, and making
using the machine a royal pain (ITA)
and not killable as off some gdm or other
process, so if it returns,
I'll scream bloody murder again ;-/
but until then all is right, relatively
right in the world... ;-/

On Wed, Sep 14, 2011 at 7:29 AM, Rodrigo Moya
<email address hidden> wrote:
> This should hopefully be fixed by the latest libglib upload (2.29.90),
> so can people please install that and check if it still crashes?
>
> ** Changed in: gnome-settings-daemon (Ubuntu)
>       Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (819972).
> https://bugs.launchpad.net/bugs/804946
>
> Title:
>  gnome-settings-daemon crashed with SIGSEGV in g_variant_unref()
>
> Status in Gnome Settings Daemon:
>  New
> Status in “gnome-settings-daemon” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  crashed while logging in.
>
>  ProblemType: Crash
>  DistroRelease: Ubuntu 11.10
>  Package: gnome-settings-daemon 3.1.2-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
>  Uname: Linux 3.0-2-generic i686
>  Architecture: i386
>  Date: Sat Jul  2 19:25:09 2011
>  ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
>  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
>  ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
>  ProcEnviron:
>   LANG=es_ES.UTF-8
>   SHELL=/bin/false
>   PATH=(custom, no user)
>  SegvAnalysis:
>   Segfault happened at: 0xe43c73 <g_variant_unref+35>: lock xadd %eax,0x14(%esi)
>   PC (0x00e43c73) ok
>   source "%eax" ok
>   destination "0x14(%esi)" (0x00000014) not located in a known VMA region (needed writable region)!
>   Stack memory exhausted (SP below stack segment)
>  SegvReason: writing NULL VMA
>  Signal: 11
>  SourcePackage: gnome-settings-daemon
>  StacktraceTop:
>   g_variant_unref (value=0x0) at /build/buildd/glib2.0-2.29.8/./glib/gvariant-core.c:617
>   g_settings_get_boolean (settings=0x0, key=0x810e222 "enable") at /build/buildd/glib2.0-2.29.8/./gio/gsettings.c:1955
>   ?? () from /usr/lib/gnome-settings-daemon-3.0/liba11y-keyboard.so
>   g_cclosure_marshal_VOID__STRING (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0, marshal_data=0x0) at /build/buildd/glib2.0-2.29.8/./gobject/gmarshal.c:498
>   g_closure_invoke (closure=0x9794b20, return_value=0x0, n_param_values=2, param_values=0x97e2540, invocation_hint=0xb5afc5c0) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771
>  Title: gnome-settings-daemon crashed with SIGSEGV in g_variant_unref()
>  UpgradeStatus: Upgraded to oneiric on 2011-06-15 (17 days ago)
>  UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-settings-daemon/+bug/804946/+subscriptions
>

--
Jerry W

Rodrigo Moya (rodrigo-moya) wrote :

Anyone else with the latest glib?

Changed in gnome-settings-daemon:
status: New → Fix Released
Martin Pitt (pitti) on 2011-09-18
affects: gnome-settings-daemon → glib
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
status: Incomplete → Fix Committed
Rodrigo Moya (rodrigo-moya) wrote :

This should be fixed in libglib2.0-0 2.29.92, so closing. Please reopen if it happens again after having upgraded

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
dobey (dobey) wrote :

Link the right upstream bug for this crash.

Changed in glib:
importance: Critical → Unknown
status: Fix Released → Unknown
affects: gnome-settings-daemon (Ubuntu Oneiric) → glib2.0 (Ubuntu Oneiric)
Changed in glib2.0 (Ubuntu Oneiric):
assignee: Rodrigo Moya (rodrigo-moya) → Rodney Dawes (dobey)
importance: High → Critical
status: Fix Released → Confirmed
Changed in glib:
importance: Unknown → Critical
status: Unknown → New
tags: added: iso-testing
Changed in glib2.0 (Ubuntu Oneiric):
status: Confirmed → Triaged
u-foka (ufooka) wrote :

Hy there!

Bug 865115 was appeared the same time as this bug, can it be related?

Changed in glib:
status: New → Fix Released
tags: added: rls-mgr-o-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.30.0-0ubuntu4

---------------
glib2.0 (2.30.0-0ubuntu4) oneiric; urgency=low

  [ Rodney Dawes ]
  * debian/patches/10_gvariant_check_null.patch:
    - Check that value is NULL before continuing (LP: #804946)

  [ Michael Terry ]
  * debian/libglib2.0-0.postrm.in:
    - Only clear the gsettings schema cache on purge (this also helps us
      deal with the above bug LP: #804946)
 -- Michael Terry <email address hidden> Thu, 06 Oct 2011 10:05:02 -0400

Changed in glib2.0 (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.