GLib-GIO:ERROR:/build/buildd/glib2.0-2.26.1/gio/gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL), when running as root

Bug #694279 reported by Max Bowsher on 2010-12-25
20
This bug affects 5 people
Affects Status Importance Assigned to Milestone
QBzr
Undecided
Unassigned
glib2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

This almost certainly isn't a bug in qbzr directly, but it is stopping me from using qbzr as I would wish to....

Sometimes I want to run 'bzr qlog' on my /etc/ directory, which is managed by etckeeper/bzr.

This used to work in some previous Ubuntu release, but in maverick, it dies as follows:

root@chimaera:/etc# bzr qlog
**
GLib-GIO:ERROR:/build/buildd/glib2.0-2.26.1/gio/gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted

It's possible to work around this by running 'dbus-launch bzr qlog', but this is a little obscure, and should not be needed.

Barry Smith (bnsmith003) wrote :

No, this is not just attributable to QBZR (need to look up what QBZR is).

I was in bash (Terminal) trying to open gedit on a text file, and got same exact message--

**
GLib-GIO:ERROR:/build/buildd/glib2.0-2.26.1/gio/gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
**

slowtrain (pmuhl830) wrote :

I get the following apparently related bug when I switch to root and run gedit pg_hba.conf. I get a series of the following errors, the bug reporting system kicks in but hangs, and my computer hanged once. No idea what this is, but it is disturbing that my terminal can crash.

Lib-GIO:ERROR:/build/buildd/glib2.0-2.26.1/gio/gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)

Max Bowsher (maxb) wrote :

I've opened a bugtask on ubuntu/glib2.0 and invalidated the qbzr bugtask.

On reflection, I think libgio is doing quite a bad thing by asserting just because it can't make a dbus connection.

Changed in qbzr:
status: New → Invalid
Changed in glib2.0 (Ubuntu):
status: New → Confirmed
aslam karachiwala (akwala) wrote :

Bump...

GLib-GIO:ERROR:/build/buildd/glib2.0-2.28.6/./gio/gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)

Looks like it may be fixed... https://bugzilla.gnome.org/show_bug.cgi?id=635694

...for now, I'm using this workaround:
> unset DBUS_SESSION_BUS_ADDRESS

EYESARK (eyesark) wrote :

i had the same error while trying to open gedit on linux mint.

just exit from the root access and try doing the same in the normal account(non-elevated) user.

that solved my problem

#happymintuser

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.