Comment 0 for bug 1281580

Dear Developers,

I using Ubuntu 14.04 development release with GNOME Shell 3.10, and because my wife using too this system, I defined with some settings in a gschema.override file.
Everithing is working right, except custom keybindings related settings applying.
I added following lines my gsettings.override file:
[org.gnome.settings-daemon.plugins.media-keys]
www='<Super><Alt>w'
email='<Super>e'
custom-keybindings = ['/org/gnome/settings-daemon/plugins/media-keys/custom-keybinding/custom0']

[org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/]
name = 'Launch Gedit'
command = 'gedit'
binding = '<Super>g'

My gsettings.override file I putted the /usr/share/glib-2.0/schemas directory. After I added this lines, I ran glib-compile-schemas /usr/share/glib2.0/schemas command, not presented any error messages.
Testing purpose I created a new user, logout, and login the new created username. Optimal case the custom keybinding need applying automaticaly, but this is not happened, other defined keybindings applied right.
In gnome-control-center keyboard preference pane, keybindings tab the custom shortcuts containing table is empty, containing one row with empty columns.

If I ran gsettings list-recursively org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ command, the name, command and binding key pairs get empty '' values.

If I manual ran following commands, the custom keybinding is created right:
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ name "Launch Gedit"
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ command "gedit"
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ binding "<Super>g"

I doing anything wrong when I want adding the custom keybindings related part my schema file, or glib-compile-schemas utility realy not applying this part from the schema file?

Attila

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libglib2.0-bin 2.39.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic i686
ApportVersion: 2.13.2-0ubuntu4
Architecture: i386
CurrentDesktop: GNOME
Date: Tue Feb 18 13:58:37 2014
InstallationDate: Installed on 2013-12-13 (67 days ago)
InstallationMedia: BeLin 3.02 i386
SourcePackage: glib2.0
UpgradeStatus: No upgrade log present (probably fresh install)