gksu's and gksudo's modal password prompt prevents OnBoard's virtual keyboard input, causing accessibility issues

Bug #421660 reported by gabrielbenjamin on 2009-08-30
94
This bug affects 29 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Unassigned
gksu (Ubuntu)
Medium
Unassigned
Raring
Medium
Unassigned
ubuntu-defaults-nexus7 (Ubuntu)
High
Unassigned
Raring
High
Unassigned
xdiagnose (Ubuntu)
High
Unassigned
Raring
High
Unassigned

Bug Description

I'm loath to report this as a bug, since it is functioning as designed, but I can't really find a better place to submit my complaint. I'm running 9.04 Netbook Remix, and if I run a GUI application and do something requiring sudo privileges, I receive a password prompt that blocks access to any other windows on the screen. Fine and good, but because of a disability, my only means of keyboard input is the OnBoard on-screen keyboard. My only recourse for such basic tasks as installing updates and adding packages is to pull out the terminal, hope I can find the pertinent command, and sudo it so I can give my password via terminal. This rather negates the convenience of doing these things from the GUI.

Naturally, the expected behavior is that I be able to use OnBoard to enter my password into the prompt.

Any other user who uses an on-screen keyboard or other GUI-based application for keyboard input will be susceptible to this issue. I imagine there are a fair number.

Related branches

tags: added: usability
tags: added: ubuntu-unr
Nicola Ferralis (feranick) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is in addition to a possible bug, also an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers.
I also added it to the One hundred Paper cuts project, of which you can read more here:

https://launchpad.net/hundredpapercuts
https://wiki.ubuntu.com/PaperCut

Thanks for taking the time to share your opinion!

Changed in hundredpapercuts:
status: New → Confirmed
Vish (vish) wrote :

Software center is slowly replacing all the features which are involved in installing and updating packages.
And It uses Policy-kit for the password prompts , which is not modal. Once all the features are completed , we should be able to avoid such accessibility issues

affects: ubuntu → software-center (Ubuntu)
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- The scope of this bug is much larger to be considered a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Michael Vogt (mvo) on 2010-02-05
affects: software-center (Ubuntu) → gksu (Ubuntu)
nUboon2Age (nuboon2age) on 2010-06-01
summary: - Modal password prompts cause accessibility issues
+ gksu's modal password prompts prevents onboard keyboard input, causing
+ accessibility issues
Changed in gksu (Ubuntu):
status: Triaged → Confirmed
nUboon2Age (nuboon2age) on 2010-06-01
summary: - gksu's modal password prompts prevents onboard keyboard input, causing
- accessibility issues
+ gksu's modal password prompt prevents OnBoard's virtual keyboard input,
+ causing accessibility issues
tags: removed: ubuntu-unr

This now affects the Nexus7 tablet.

Changed in ubuntu-nexus7:
status: New → Confirmed
importance: Undecided → High
Matt Fischer (mfisch) wrote :
summary: - gksu's modal password prompt prevents OnBoard's virtual keyboard input,
- causing accessibility issues
+ gksu's and gksudo's modal password prompt prevents OnBoard's virtual
+ keyboard input, causing accessibility issues
marmuta (marmuta) wrote :

Since no one has mentioned it yet, gksu's grab can be turned off:
$ gconftool-2 --set /apps/gksu/disable-grab --type boolean true

or for a little gui run
$ gksu-properties
and select Grab mode: disable

You should then be able to type passwords with Onboard.

Certainly that's a workaround; I'm glad you mentioned it. I found out after
submitting this bug that prompts can be made not to grab via one of the
options in the Assistive Technologies section of Ubuntu Preferences (the
one below "Enable assistive technologies"). My only thought is that if
OnBoard is supposed to be a genuine keyboard substitute, it seems like an
overly broad solution--either gksu grabs focus from everything, including
OnBoard, or from nothing at. I wonder if it's possible to choose some
applications that are excluded from gksu's grab behavior? Seems like the
most satisfactory fix for the bug to implement that, and put OnBoard on
that list by default. I guess that makes this a feature request?

On Mon, Nov 19, 2012 at 12:07 PM, marmuta <email address hidden> wrote:

> Since no one has mentioned it yet, gksu's grab can be turned off:
> $ gconftool-2 --set /apps/gksu/disable-grab --type boolean true
>
> or for a little gui run
> $ gksu-properties
> and select Grab mode: disable
>
> You should then be able to type passwords with Onboard.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/421660
>
> Title:
> gksu's and gksudo's modal password prompt prevents OnBoard's virtual
> keyboard input, causing accessibility issues
>
> Status in One Hundred Paper Cuts:
> Invalid
> Status in Ubuntu on the Nexus 7:
> Confirmed
> Status in “gksu” package in Ubuntu:
> Confirmed
>
> Bug description:
> I'm loath to report this as a bug, since it is functioning as
> designed, but I can't really find a better place to submit my
> complaint. I'm running 9.04 Netbook Remix, and if I run a GUI
> application and do something requiring sudo privileges, I receive a
> password prompt that blocks access to any other windows on the screen.
> Fine and good, but because of a disability, my only means of keyboard
> input is the OnBoard on-screen keyboard. My only recourse for such
> basic tasks as installing updates and adding packages is to pull out
> the terminal, hope I can find the pertinent command, and sudo it so I
> can give my password via terminal. This rather negates the convenience
> of doing these things from the GUI.
>
> Naturally, the expected behavior is that I be able to use OnBoard to
> enter my password into the prompt.
>
> Any other user who uses an on-screen keyboard or other GUI-based
> application for keyboard input will be susceptible to this issue. I
> imagine there are a fair number.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/421660/+subscriptions
>

--

-Ben

marmuta (marmuta) wrote :

Well, we'd love to add this as a feature, but I'm not aware of anything that would allow us to generally exempt Onboard from pointer grabs. If this exists, I'd be interested to learn about it.

Back in GTK2 times Onboard used to have a toggle for "Password dialogs as normal windows", which basically toggled the disable-grab key. This fell by the wayside with the switch to GTK3 and gsettings. We could possibly bring it back, though going by the age of this bug and duplicates, I'm not sure if we should. Is this still an issue today?

As of 10.04, yes. I'll report back after I try 12.04.

On Tue, Nov 20, 2012 at 10:15 AM, marmuta <email address hidden> wrote:

> Well, we'd love to add this as a feature, but I'm not aware of anything
> that would allow us to generally exempt Onboard from pointer grabs. If
> this exists, I'd be interested to learn about it.
>
> Back in GTK2 times Onboard used to have a toggle for "Password dialogs
> as normal windows", which basically toggled the disable-grab key. This
> fell by the wayside with the switch to GTK3 and gsettings. We could
> possibly bring it back, though going by the age of this bug and
> duplicates, I'm not sure if we should. Is this still an issue today?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/421660
>
> Title:
> gksu's and gksudo's modal password prompt prevents OnBoard's virtual
> keyboard input, causing accessibility issues
>
> Status in One Hundred Paper Cuts:
> Invalid
> Status in Ubuntu on the Nexus 7:
> Confirmed
> Status in “gksu” package in Ubuntu:
> Confirmed
>
> Bug description:
> I'm loath to report this as a bug, since it is functioning as
> designed, but I can't really find a better place to submit my
> complaint. I'm running 9.04 Netbook Remix, and if I run a GUI
> application and do something requiring sudo privileges, I receive a
> password prompt that blocks access to any other windows on the screen.
> Fine and good, but because of a disability, my only means of keyboard
> input is the OnBoard on-screen keyboard. My only recourse for such
> basic tasks as installing updates and adding packages is to pull out
> the terminal, hope I can find the pertinent command, and sudo it so I
> can give my password via terminal. This rather negates the convenience
> of doing these things from the GUI.
>
> Naturally, the expected behavior is that I be able to use OnBoard to
> enter my password into the prompt.
>
> Any other user who uses an on-screen keyboard or other GUI-based
> application for keyboard input will be susceptible to this issue. I
> imagine there are a fair number.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/421660/+subscriptions
>

--

-Ben

Oliver Grawert (ogra) on 2012-11-27
Changed in ubuntu-defaults-nexus7 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Oliver Grawert (ogra) wrote :

for fixing the remianing issues in raring (where the plan is to get rid of gksu in favour of using pkexec everywhere), it would be good to know when exactly users get gksu prompts.
we need to fix the apps using it to instead use pkexec.
people seeing this issue on the nexus7, please tell us where/when exactly gksu pops up

Changed in ubuntu-nexus7:
status: Confirmed → Incomplete
Changed in ubuntu-defaults-nexus7 (Ubuntu):
status: Confirmed → Incomplete
qkall (aqpagan) wrote :

i found a little work around for this... if you touch/hold your finger somewhere else on the screen you can usually (not always which i don't understand) then type with another touch input.

just in case i'm not being clear - touch screen with left hand then right hand type.

Chris Wilson (notgary) on 2013-01-02
no longer affects: hundredpapercuts
jura (zinlun) on 2013-01-06
Changed in ubuntu-nexus7:
status: Incomplete → New
Changed in gksu (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-defaults-nexus7 (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New
Vojtech Bocek (vbocek) wrote :

A while after boot and every now and than something crashes (I think it is cups) and then "System error occured" window appears, I think you call it whoopsie. When I click the "report" button, it asks for password using gksudo, and I can't enter anything.

Oliver Grawert (ogra) on 2013-01-10
Changed in gksu (Ubuntu):
status: Fix Released → Confirmed
Mitchell Turcot (mrturcot) wrote :

Keyboard issues with ubuntu 13.04 on Nexus 7 16gb wifi
I have stumbled upon a temp fix that worked for me;

when the keyboard comes up click the small 123 button on the keyboard should be bottom right
then far left, click the red button with wrench and screwdriver
this will bring up a menu for the keyboard settings
click the last option "advanced"
then "touch input" should default to multi-touch
change this to single-touch

REBOOT

should be good to go!

16gb wifi aka grouper
Running MultiROM v3
Stock 4.2
cm 10.1
ubuntu 13.04

marmuta (marmuta) wrote :

@Mitchell, would you mind to explain what kind of keyboard issues you experienced before turning off multi-touch?

Steve Langasek (vorlon) wrote :

gksu is called by update-notifier for any apport crashes of system processes. Opening an update-notifier task.

Changed in update-notifier (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
importance: Critical → High
Oliver Grawert (ogra) on 2013-01-28
Changed in xdiagnose (Ubuntu Raring):
importance: Undecided → High
Adolfo Jayme (fitojb) wrote :

The update-notifier part of this bug is being tracked in LP: #1098235.

no longer affects: update-notifier (Ubuntu Raring)
no longer affects: update-notifier (Ubuntu)
Changed in ubuntu-nexus7:
status: New → Confirmed
Oliver Grawert (ogra) wrote :

The nexus7 issue is fixed (update-notifier does not pop up gksu anymore but uses pkexec which is usable with onboard).

While gksu is still broken in this regard (so leaving that bug task open) and xdiagnose still uses it (leaving that open as well) you will not get into a situation on the nexus7 where xdiagnose runs (and even if ... you wouldnt have any input method at all)

For the nexus7 i consider this issue solved (we will solve it harder by dropping gksu from the default install though)

Changed in ubuntu-defaults-nexus7 (Ubuntu Raring):
status: New → Invalid
Changed in ubuntu-nexus7:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 3.4.3

---------------
xdiagnose (3.4.3) raring; urgency=low

  [ Bryce Harrington ]
  * apport/source_xorg.py:
    + Fix assertion in apport when assigning a None value for the
      xserver.configfile parameter. This may not be defined if there is no
      xorg.conf (a common situation).
    + Fix HookError when specifying a gpu hang is 'infrequent'
    + Drop the post-release dialog recommending technical support
      (LP: #1080233, #1005573)
    + Add capturing of gsettings options for unredirected fullscreen windows
  * debian/xdiagnose.links:
    + Add lts-quantal X.org packages

  [ Michael Terry ]
  * Switch from gksu to pkexec
    (LP: #421660)
 -- Bryce Harrington <email address hidden> Wed, 13 Feb 2013 18:38:28 -0800

Changed in xdiagnose (Ubuntu Raring):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in gksu (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers