Ubuntu

"Starting Root Terminal" displayed more than 10 sec after terminal started

Reported by Roman Polach on 2007-06-15
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Low
Unassigned

Bug Description

When I run Applications -> System Tools -> Root terminal,
the terminal starts almost immediately but there is displayed one more item in Window List Applet: "Starting Root Terminal"
and it stays displayed for more than 10 seconds after terminal actually started.

Note: I do not see this problem if I start "gksudo gnome-terminal" by myself..

It could be related to bug https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/19494 but that is not related to gnome terminal
and it is marked as fixed...

Justin Payne (neolithium82) wrote :

Hi,
Thanks for taking the time to report this bug. While the but that is mentioned in your report is fixed, I would like to know if this is still a problem regarding the launch of Root Terminal. If so, do you find that the problem still happens when you launch this command from a terminal:
gksu /usr/bin/x-terminal-emulator

If so, can you please post any messages that happen within the terminal window you launch it from, as well as a backtrace of anything as well (https://wiki.ubuntu.com/Backtrace)

Changed from Xterminal as it seems to relate to gksu more than the terminal program.

Regards,
Justin

Changed in xterminal:
assignee: nobody → jbeerwart
Roman Polach (rpolach) wrote :

I still have this problem when opening "Root Terminal" by menu,
although running "gksu /usr/bin/x-terminal-emulator" directly is ok
-- that's strange, because this is exactly the same command as of that menu launcher.

Roman Polach (rpolach) on 2007-06-29
Changed in gksu:
status: Incomplete → New
Justin Payne (neolithium82) wrote :

Hi rpolach,
Thanks for the additional information. This seems as though, in that case it's not a gksu issue. Are you using any other themes with your installation, and what specific version of Ubuntu do you have installed?

Regards,
Justin

EDIT - Returning to proper status - incomplete & adjusting package to Main Menu pending information.

Changed in gksu:
status: New → Incomplete
Roman Polach (rpolach) wrote :

I use Feisty with latest updates and the default theme. Nothing special as I know..

Colin Watson (cjwatson) wrote :

main-menu is not what you think it is - it's an installer component and has nothing to do with the desktop. I'm guessing you meant gnome-panel or similar.

Sebastien Bacher (seb128) wrote :

The menu item comes from gksu and should not use StartupNotify=true

Changed in gnome-panel:
importance: Undecided → Low
status: Incomplete → Triaged
Changed in gksu:
assignee: jbeerwart → nobody
Roman Polach (rpolach) wrote :

Problem still present in a fresh Gutsy installation.

Roman Polach (rpolach) wrote :

Problem still present in Intrepid

mortenvp (mortenvp) wrote :

Problem still present in Jaunty Alpha 4

Bernhard (b.a.koenig) wrote :

Still present in Jaunty beta, e.g.

> gksudo gnome-terminal
Failed to contact the GConf daemon; exiting.%
> gksu /usr/bin/x-terminal-emulator
Failed to contact the GConf daemon; exiting.%

TodTop (topalov1678) wrote :

I have this Problem at first time with Jaunty. On earlier versions of ubuntu gnome it was not a problem to run administrations-terminal.

IanG (ian-usts) wrote :

I have the same problem since Jaunty. Think I've reported the problem via the wrong sub-section (Firefox 3.0)

nouser (norbert-fiedler) wrote :

Same problem here with Ubuntu v9.04.

Daniel Letzeisen (dtl131) wrote :

Upstream has marked this as fixed a long time ago, and I can't reproduce it on a modern Ubuntu (12.04). Marking Fix Released, so if anyone still has an issue, please file a new bug.

Changed in gksu (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.