'services' doesn't stop startup-notificiation

Bug #19494 reported by Crispin Flowerday on 2005-08-06
42
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Medium
Michael Vogt

Bug Description

If you start the "Services" part of g-s-t, then the panel says "Starting
Services", but it doesn't dissappear when the actual 'change your running
services' window starts.

(Breezy / g-s-t 1.3.1-0ubuntu1)

Sebastien Bacher (seb128) wrote :

thanks for your bug. Do you still have this issue? That works fine for me.

Well, I can't make it start without going through the "Please enter you
password" dialog, and after that the startup-notification has dissappeared, so
yes, I guess I can't repro this anymore :-)

Hmm, actually, on my laptop, it seems to startup without going asking me for my
password, and there the startup-notification isn't stopped.

Lionel Dricot (ploum) wrote :

In order to not type your password, start anything that asks for the password
before, like synaptic.

Sebastien Bacher (seb128) wrote :

*** Bug 21066 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

In fact that seems to happen for all the apps using gksudo when started without
getting the password dialog. Michael, reassigning to you because you know gksudo
better. Could you give it a try before 5.10, that's confusing for users :)

Actually the problem seems to be that gksu doesnt support startup-notification.

To verify that, I changed "Exec=gedit %U" to "Exec=gksudo gedit %U"
in /usr/share/applications/gedit.desktop and the problem appeared
although gedit has built-in support for startup-notification:
$ ldd /usr/bin/gedit | grep start
  libstartup-notification-1.so.0 => /usr/lib/libstartup-notification-1.so. 0
(0xb72fc000)

So replacing "StartupNotify=true" with "StartupNotify=false"
in /usr/share/applications/_service_that_uses_gksudo.desktop
solved the problem for me.

But this is a dirty fix. The correct fix would be if someone added
support for startup-notification to gksudo...

-Haris

Sebastien Bacher (seb128) wrote :

*** Bug 20912 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

*** Bug 21104 has been marked as a duplicate of this bug. ***

Michael Vogt (mvo) wrote :

This should be fixed when the latest gksu is used and "StartupNotifcation=true" is removed from the desktop files of g-s-t (this is done by gksu internally now).

Cheers,
 Michael

Changed in gksu:
status: Unconfirmed → In Progress
Michael Vogt (mvo) wrote :

Gksu supports startup notification now, I uploaded a new g-s-t (gnome-system-tools_2.14.0-0ubuntu5) start removes startup notification from the desktop file.

Please confirm that the latest uploads for gksu/g-s-t fixes the problem for you

Cheers,
 Michael

Changed in gksu:
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2006-05-11
Changed in gksu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.