gjs-console crashed with signal 5

Bug #1283551 reported by Cristian Aravena Romero on 2014-02-22
This bug affects 309 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
Ubuntu GNOME
Medium
Unassigned
gjs
Fix Released
Medium
gjs (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
gobject-introspection (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

[Impact]
This is #1 crasher for gjs on errors.u.c, with thousands of hits per week.

https://errors.ubuntu.com/bucket/?id=/usr/bin/gjs-console%3A5%3Aobject_instance_finalize%3Afinalize%3Afinalize%3AFinalizeTypedArenas%3AFinalizeArenas

[Testcase]
There is no specific testcase, this crash can be triggered by any function that frees its instance arguments.

[Regression Potential]
This adds a new attribute to g-i, for it to be effective however it requires typelibs to be rebuilt. See Comment #25 below

=== Original Bug Report ===

Connect Bluethooth

ProblemType: CrashDistroRelease: Ubuntu 14.04
Package: gjs 1.39.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Feb 22 17:44:13 2014
ExecutablePath: /usr/bin/gjs-console
InstallationDate: Installed on 2014-01-23 (30 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140122)
ProcCmdline: /usr/bin/gjs-console -I /usr/share/gnome-documents/js -c const\ Main\ =\ imports.main;\ Main.start(); --no-default-windowSignal: 5SourcePackage: gjs
StacktraceTop:
 ?? () from /usr/lib/libgjs.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libmozjs-24.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libmozjs-24.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libmozjs-24.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libmozjs-24.so.0
Title: gjs-console crashed with signal 5
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 object_instance_finalize (fop=<optimized out>, obj=0x7f4cb701ed00) at gi/object.cpp:1364
 finalize (fop=0x7fffc22638b0, this=0x7f4cb701ed00) at /build/buildd/mozjs24-24.2.0/js/src/jsobjinlines.h:213
 finalize<JSObject> (thingSize=48, thingKind=js::gc::FINALIZE_OBJECT2, fop=0x7fffc22638b0, this=0x7f4cb701e000) at /build/buildd/mozjs24-24.2.0/js/src/jsgc.cpp:331
 FinalizeTypedArenas<JSObject> (dest=..., budget=..., thingKind=js::gc::FINALIZE_OBJECT2, src=0x7fffc2263848, fop=0x7fffc22638b0) at /build/buildd/mozjs24-24.2.0/js/src/jsgc.cpp:395
 FinalizeArenas (fop=fop@entry=0x7fffc22638b0, src=src@entry=0x7fffc2263848, dest=..., thingKind=thingKind@entry=js::gc::FINALIZE_OBJECT2, budget=...) at /build/buildd/mozjs24-24.2.0/js/src/jsgc.cpp:432

Changed in gjs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in gjs:
importance: Unknown → Critical
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gjs (Ubuntu):
status: New → Confirmed
iain (l-iain) wrote :

Getting quite a few of these now, two at least a day, complete black screen as X/shell crashes to return with flickering shell/windows and new this week miss-sized resolution. Todays resulted in all the gnome shell 'buttons' being mucked up as well...........

Changed in gjs:
status: New → Invalid
Eric Goulet (eric-m-goulet) wrote :

This happens immediately on boot with Ubuntu GNOME 20140326.1

Bruce Pieterse (octoquad) wrote :

Previous Gnome Bug #724976 was marked as duplicate of #697436

Changed in gjs:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in gjs:
importance: Unknown → High
status: Unknown → Fix Released

got this error when starting up the update application...

Florian Demmer (fdemmer) on 2014-04-17
Changed in gjs:
importance: High → Unknown
status: Fix Released → Unknown
Changed in gjs:
importance: Unknown → Medium
status: Unknown → Fix Released
vicmumo (vmunoz-o) wrote :

Also reproduced with gjs 1.39.91-0ubuntu1 in Ubuntu 3.13.0-24.46-generic kernel

Hello Cristian, or anyone else affected,

Accepted gjs into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gjs/1.40.1-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gjs (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Eric Goulet (eric-m-goulet) wrote :

Adam, I experience this bug, and I'd love to help. Is it possible to do this without receiving other proposed (and possibly unstable?) updates?

Dennj Osele (dennj-osele) wrote :

Sorry, I accidentally clicked "Fix Released".
How to cancel it?

Changed in gjs (Ubuntu Trusty):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2014-05-01
Changed in gjs (Ubuntu Trusty):
status: Fix Released → Fix Committed
Tim Lunn (darkxst) wrote :

This crash was not actually due to the GC re-entrancy issues, so is not actually fixed by the gjs 1.40.1 (although lots of other crashes are still fixed by that upload)

Adding new upstream bug

Changed in gjs:
importance: Medium → Unknown
status: Fix Released → Unknown
tags: added: verification-done
removed: verification-needed
Tim Lunn (darkxst) wrote :

Marking verification-done, since it certainly doesnt make things any worse than current

Changed in gjs:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjs - 1.40.1-0ubuntu0.2

---------------
gjs (1.40.1-0ubuntu0.2) trusty; urgency=medium

  * New upstream release (LP: #1283551, #1283551, #1281391)
    - fixes GC re-entrentrancy issue causing many crashes
  * debian/patches:
    - git_test_fix_args.patch: git patch to fix test failure
    - git_ratelimit_rss_gc.patch: ratelimit GC's to avoid excessive triggering
 -- Tim Lunn <email address hidden> Sun, 27 Apr 2014 09:09:52 +1000

Changed in gjs (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gjs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Scott Kitterman (kitterman) wrote :

Reopening per comment #15.

Changed in gjs (Ubuntu Trusty):
status: Fix Released → Confirmed
tags: removed: verification-done
Tim Lunn (darkxst) on 2014-05-08
Changed in ubuntu-gnome:
milestone: none → trusty.1
status: New → Triaged
Tim Lunn (darkxst) on 2014-05-08
Changed in ubuntu-gnome:
importance: Undecided → Medium
Changed in glib:
importance: Unknown → Medium
status: Unknown → New
DooMMasteR (winrootkit) wrote :

this is pretty annoying.... it happens whenever I open some folder in nautilus

tags: added: apport-collected third-party-packages

ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: GNOME
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2014-05-07 (36 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
Package: gjs
PackageArchitecture: amd64
Tags: trusty third-party-packages
Uname: Linux 3.15.0-031500-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: True

apport information

apport information

C. Brazill-LP (dragonlager) wrote :
Download full text (3.5 KiB)

I get this crash alot almost every third session both with Gnome 3.10 previously and on Gnome 3.12.2 via gnome team staging ppa.

the gjs-console message that it has crashed has happened both with default themes and extensions, and with custom themes (not user themes and I don't have the usr theme extension activated) and extension from the gnome beta website

log out put at the event:

Jun 14 21:19:42 little-feet dnsmasq[1181]: setting upstream servers from DBus
Jun 14 21:19:42 little-feet dnsmasq[1181]: using nameserver 75.75.75.75#53
Jun 14 21:19:42 little-feet dnsmasq[1181]: using nameserver 2001:558:feed::1#53
Jun 14 21:19:42 little-feet dnsmasq[1181]: using nameserver 75.75.76.76#53
Jun 14 21:19:42 little-feet NetworkManager[752]: <info> Activation (wlan0) Stage 5 of 5 (IPv6 Commit) complete.
Jun 14 21:19:46 little-feet ntpdate[8850]: step time server 91.189.89.199 offset 0.642939 sec
Jun 14 21:20:00 little-feet wpa_supplicant[796]: wlan0: CTRL-EVENT-SCAN-STARTED
Jun 14 21:22:09 little-feet kernel: [10844.632280] usb 3-1: new high-speed USB device number 2 using xhci_hcd
Jun 14 21:22:09 little-feet kernel: [10844.651705] usb 3-1: New USB device found, idVendor=04b0, idProduct=033b
Jun 14 21:22:09 little-feet kernel: [10844.651717] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 14 21:22:09 little-feet kernel: [10844.651724] usb 3-1: Product: NIKON DSC COOLPIX S3500-PTP
Jun 14 21:22:09 little-feet kernel: [10844.651729] usb 3-1: Manufacturer: NIKON
Jun 14 21:22:09 little-feet kernel: [10844.651734] usb 3-1: SerialNumber: 000030233928
Jun 14 21:22:10 little-feet mtp-probe: checking bus 3, device 2: "/sys/devices/pci0000:00/0000:00:1c.5/0000:04:00.0/usb3/3-1"
Jun 14 21:22:10 little-feet mtp-probe: bus: 3, device: 2 was not an MTP device
Jun 14 21:22:10 little-feet colord: Device added: sysfs-(null)
Jun 14 21:24:13 little-feet dbus[425]: [system] Activating service name='org.freedesktop.hostname1' (using servicehelper)
Jun 14 21:24:13 little-feet dbus[425]: [system] Successfully activated service 'org.freedesktop.hostname1'
Jun 14 21:24:51 little-feet kernel: [11006.198983] traps: gjs-console[9202] trap int3 ip:7fcf92b56c13 sp:7fff1ea55a90 error:0
Jun 14 21:25:10 little-feet whoopsie[1096]: message repeated 96 times: [ online]
Jun 14 21:25:18 little-feet whoopsie[1096]: Parsing /var/crash/_usr_bin_gjs-console.1000.crash.
Jun 14 21:25:18 little-feet whoopsie[1096]: Uploading /var/crash/_usr_bin_gjs-console.1000.crash.
Jun 14 21:25:19 little-feet whoopsie[1096]: Sent; server replied with: No error
Jun 14 21:25:19 little-feet whoopsie[1096]: Response code: 500
Jun 14 21:25:19 little-feet whoopsie[1096]: Server replied with:
Jun 14 21:25:19 little-feet whoopsie[1096]: <html>#012<head><title>Oops! - ['OOPS-3d9f782f4a4aa92ca584af7f878412b6']</title></head>#012<body>#012<h1>Oops!</h1>#012<p>Something broke while generating the page.#012Please try again in a few minutes, and if the problem persists file#012a bug or contact customer support. Please quote OOPS-ID#012<strong>['OOPS-3d9f782f4a4aa92ca584af7f878412b6']</strong>#012</p></body></html>
Jun 14 21:25:19 little-feet whoopsie[1096]: Could not upload; processing later...

Read more...

Changed in gjs:
status: New → Fix Released
Tim Lunn (darkxst) wrote :

From desktop-devel-list[1]:
Hello all,

I just landed https://bugzilla.gnome.org/show_bug.cgi?id=729662, which
introduces a new attribute in gobject-introspection typelibs that is
critical for correct memory management in language bindings.
While the bug should not affect many functions (only those that
unref/free their instance arguments), and primarily we saw crashes in
gjs caused by Gio, it is hard to determine if a library is affected or
not automatically, and therefore it would be best if all typelibs
would be rebuilt with the new gobject-introspection, now or as soon as
a release is available.
This in particular to avoid reports against gjs or pygobject that
would be hard to debug for developers under different distros or using
jhbuild packages with the fix.

Cheers

Giovanni
https://mail.gnome.org/archives/desktop-devel-list/2014-July/msg00003.html

Changed in glib:
status: New → Fix Released
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :

Both debdiffs needed for trusty are now attached. the utopic ones will soon follow. I have NOT tested these, so could someone please do that.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gobject-introspection (Ubuntu Trusty):
status: New → Confirmed
Changed in gobject-introspection (Ubuntu):
status: New → Confirmed
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :

All the above patches have been successfully built at https://launchpad.net/~noskcaj/+archive/build

tags: added: patch
description: updated
Changed in gobject-introspection (Ubuntu):
importance: Undecided → Medium
Changed in gjs (Ubuntu Trusty):
status: Confirmed → Triaged
Changed in gobject-introspection (Ubuntu):
status: Confirmed → Triaged
Changed in gjs (Ubuntu Trusty):
importance: Undecided → Medium
Changed in gjs (Ubuntu):
status: Confirmed → Triaged
Changed in gobject-introspection (Ubuntu Trusty):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: utopic

Bug present in:
Package: gjs 1.41.3-0ubuntu1

Bug #1345731

Tim Lunn (darkxst) wrote :

Cristian,
fix has not been uploaded yet, and even then it could take a while to clear up, since many typelibs need rebuilding but its hard to know which ones!

Martin Pitt (pitti) on 2014-08-01
Changed in gobject-introspection (Ubuntu):
status: Triaged → Fix Committed
Changed in gjs (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

SRUs uploaded as well. Unsubscribing sponsors, please re-subscribe when there's anything further to sponsor (like typelib rebuilds). Thanks!

Changed in gjs (Ubuntu Trusty):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Oh, and please add SRU information to the description (test case etc.)

Changed in gobject-introspection (Ubuntu Trusty):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gobject-introspection - 1.40.0-2ubuntu2

---------------
gobject-introspection (1.40.0-2ubuntu2) utopic; urgency=medium

  * Add git_ownership_transfer.patch. LP: #1283551
    - Adds a new symbol, update symbols file accordingly
 -- Jackson Doak <email address hidden> Sat, 05 Jul 2014 07:52:01 +1000

Changed in gobject-introspection (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjs - 1.41.3-0ubuntu2

---------------
gjs (1.41.3-0ubuntu2) utopic; urgency=medium

  * Add git_respect_ownership_transfer.patch. LP: #1283551
    - Bump gobject-introspection b-dep to still build
 -- Jackson Doak <email address hidden> Sat, 05 Jul 2014 07:49:55 +1000

Changed in gjs (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2014-08-02
description: updated
description: updated
description: updated

Hello Cristian, or anyone else affected,

Accepted gobject-introspection into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gobject-introspection/1.40.0-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gobject-introspection (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gjs (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Cristian, or anyone else affected,

Accepted gjs into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gjs/1.40.1-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Hello, I'm working with utopic.

Tim Lunn (darkxst) wrote :

Gave this a good test on my last remaining trusty machine, and didn't hit the crash. Not seeing any crashes on errors.u.c either ;0

tags: added: verification-done
removed: verification-needed

I had at least two crashes since I updated to 1.40.1-0ubuntu0.3. Haven't rebooted the PC since the update though...

Tim Lunn (darkxst) wrote :

Thomas, are you sure it is the same crash? The "signal 5" is fairly generic and can be caused by different crashes as well. The only way to tell is to look at the retrace.

Just crashed again.

I don't know how many different bugs there are, my crash has the same command line like the OP. Here's the _usr_bin_gjs-console.1000.crash

http://paste.ubuntu.com/8088031/

Tim Lunn (darkxst) wrote :

Thomas, see https://wiki.ubuntu.com/DebuggingProgramCrash

Need a stacktrace with symbols to be of any use, and you should probably file a new bug!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjs - 1.40.1-0ubuntu0.3

---------------
gjs (1.40.1-0ubuntu0.3) trusty; urgency=medium

  * Add git_respect_ownership_transfer.patch. LP: #1283551
 -- Jackson Doak <email address hidden> Fri, 04 Jul 2014 09:27:58 +1000

Changed in gjs (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gobject-introspection - 1.40.0-1ubuntu0.2

---------------
gobject-introspection (1.40.0-1ubuntu0.2) trusty; urgency=medium

  * Add git_ownership_transfer.patch. LP: #1283551
    - Adds a new symbol, update symbols file accordingly
 -- Jackson Doak <email address hidden> Fri, 04 Jul 2014 09:53:18 +1000

Changed in gobject-introspection (Ubuntu Trusty):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2015-03-11
Changed in ubuntu-gnome:
milestone: trusty.1 → trusty.3
Eric Goulet (eric-m-goulet) wrote :

I just had this one pop up again for the first time since the fix was released.
Using 14.04.2 w/HWE and GNOME 3.12.2 via PPA.

naryfa (naryfa) wrote :

Can anybody give instructions on how to apply that fix or install it? I see a bunch of patches, but no instructions on how to place them anywhere. I'm on Ubuntu Gnome 14.04 and today is 04/05/15. Any help would be appreciated.

cronnosli (cronnosli) wrote :

Can anyone tell me how a fix released could still present if we update our computers on weekly basis?

Tim Lunn (darkxst) wrote :

Please file new bugs if you are still seeing crashes, this bug was fixed 6 months ago. "gjs-console crashed with signal 5" is a very generic message, so without current backtraces, not much can be done to track it down.

Changed in ubuntu-gnome:
status: Triaged → Fix Released
milestone: trusty.3 → trusty.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.