Please merge gimp 2.4.5-1 (main) from Debian unstable (main)

Bug #197708 reported by Pedro Fragoso on 2008-03-02
16
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gimp

NEWS:

This is the stable branch of GIMP. No new features are being added
here, just bug-fixes.

Changes in GIMP 2.4.5
=====================

- fixed a regression introduced by the brush cursor optimization (bug #514309)
- fixed bug in transform tool preview (bug #340965)
- fixed PSD export of images with layer masks
- fixed base64 encoding routine of the Mail plug-in
- use the correct background color when creating a new image (bug #514082)
- explicitly link libgimpthumb with GLib (bug #515566)
- improved selection of the font sample string (bug #514021)
- unified handling of "Enter" and "Space" keysyms (bug #516544)
- fixed bug in the Glossy script when used with a pattern (bug #517285)
- correctly record dimensions in Exif data when saving as JPEG (bug #517077)
- fixed sensitivity of plug-in menu items (bug #517683)
- fixed potential crashes in Wind, Warp, Small Tiles and Apply Canvas
  plug-ins (bug #516369)
- added default keyboard shortcut for "Paste As New Image" (Ctrl-Shift-V)
- added default keyboard shortcut for "Copy Visible" (Ctrl-Shift-C)
- fixed missing preview update in Curves tool (bug #518012)
- fixed a bug in the Frosty Logo script (bug #472316)
- fixed backward transformations using the PDB (bug #518910)
- translation fixes and updates (de, eu, eo, fr, he, hu, it, ja, ko)

gimp (2.4.5-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable.
  * Ubuntu remaining changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch: Distro changes.
    - Weave i18n magic in the rules file.
    - Remove the doc directory symlink in the preinst, and replace it with a
      directory.
    - Added NEWS, README and README.Debian to gimp.docs.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Pedro Fragoso <email address hidden> Sat, 01 Mar 2008 22:42:39 +0000

Along with upstream bugfix, the re-add of 03_gimp.desktop.in.in.patch that was missing on the previous merge fixes lp: #189758, #162301

Related branches

Pedro Fragoso (ember) wrote :
Pedro Fragoso (ember) wrote :
Pedro Fragoso (ember) wrote :
Pedro Fragoso (ember) wrote :
Changed in gimp:
importance: Undecided → Low
Patrice Vetsel (vetsel-patrice) wrote :

I don't understand why the priority was set to "Low". Ubuntu Hardy 8.04 is an LTS, Gimp 2.4.5 is a bug-fixes only version.

Is it not the priority for an LTS version to have stable packages with fewer bugs ?

Martin Pitt (pitti) wrote :

This is not a FFe since there are no new features to approve. This is an exemplary case of an upstream version update which is appropriate and wanted at this stage of the release (and why we abolished UVF). Please go ahead and upload.

Changed in gimp:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.4.5-1ubuntu1

---------------
gimp (2.4.5-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #197708)
  * Ubuntu remaining changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch: Distro changes.
    - Weave i18n magic in the rules file.
    - Remove the doc directory symlink in the preinst, and replace it with a
      directory.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec
  * Re-adds missing 03_gimp.desktop.in.in.patch. (LP: #189758)
  * Most of the work done by Pedro Fragoso.

gimp (2.4.5-1) unstable; urgency=low

  * New upstream release
    - Should fix weird behavior when entering a hex color (Closes: #435124)

 -- Steve Kowalik <email address hidden> Fri, 07 Mar 2008 14:25:30 +1100

Changed in gimp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers