Ubuntu

gimp 2.4 *final* in gutsy

Reported by Dread Knight on 2007-10-27
40
Affects Status Importance Assigned to Milestone
gimp (Baltix)
High
Mantas Kriaučiūnas
gimp (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: gimp

Please update gutsy's repository with the final version of gimp 2.4.

THank you for your bug report. I'm marking this as triaged.

Changed in gimp:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Triaged

If this is done, it'll be through a backport.

Or, sorry, a SRU.

FlamM (florent-ingwiller) wrote :

According to http://developer.gimp.org/NEWS , gimp 2.4.1 is ready. No new features are being added
here, just bug-fixes.

Meh, backport. Don't see why the one in main shouldn't be updated. No dependency changes.

Scott Beamer (angrykeyboarder) wrote :

2.4.1 is now in Debian sid

Scott Beamer (angrykeyboarder) wrote :

"If this is done, it'll be through a backport."

But the version in Gutsy isn't even a final version. It's not a *release* it's a *release "candidate"*

Scott Beamer (angrykeyboarder) wrote :

But wishlist?

keepertoad (keepertoad) wrote :

Seems to me this should be more important than "wishlist".

+1 keepertoad.

It should be brought up to 2.4.1 and updated for as long as the dependencies behave themselves.

FlamM (florent-ingwiller) wrote :

Even 2.4.2 has been released on 2007-11-21 and is already in debian sid.

Jesper de Jong (jespdj) wrote :

Please update GIMP for Gutsy to version 2.4.2.

2.4.0rc3 is a *release candidate*, not a real release.
A number of annoying bugs have been fixed since 2.4.0rc3, including some potential crashes.
Those fixes are enough reason to update the Gutsy package.

See this for fixed bugs since 2.4.0 final release:
http://developer.gimp.org/NEWS-2.4

Tim McCormack (phyzome) wrote :

Not only that, it's a "Release Conadidate". Kinda unprofessional.

Derek (bugs-m8y) wrote :

Agreed. Or at least backport all crashers and functionality flaws.
Appears to be at least 7 crashers mentioned in release notes, maybe more.
This isn't surprising, since as a release candidate suddenly gains a larger audience, is necessary to release bugfix versions.

That doesn't help the unprofessional splash, but what can you do...

Kent Paul Dolan (xanthian) wrote :

Notice that this bug has a sibling:

https://bugs.launchpad.net/gutsy-backports/+bug/164795

xanthian.

Daniel Hahler (blueyed) wrote :

I've asked on #ubuntu-devel about whether we should provide the stable release through -updates or -backports.
The consensus has been that there should be a list of high-impact (SRU-able) bugs and only those should then get addressed.
"Having a release candidate is not professional" is apparently no argument really.

So, if you want to see a bugfix update for Gutsy, you might want to get involved in triaging the gimp bugs..

Bruce Cowan provides a backport already in his PPA: https://edge.launchpad.net/~bruce89/+archive
See also https://wiki.ubuntu.com/SRU

Changed in gimp:
status: New → Invalid
Mantas Kriaučiūnas (mantas) wrote :

Please don't close Baltix distro bugs, assigned to Baltix by main Baltix developer !

Changed in gimp:
assignee: nobody → mantas
importance: Undecided → High
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

GIMP 2.4 ( 2.4.2-1ubuntu2) is already available in Hardy, marking this bug as fixed.

Changed in gimp:
status: Triaged → Fix Released
John Wilund (orlando-runbox) wrote :

Please have a look at: https://bugs.launchpad.net/ubuntu/+bug/176185

What should I do to have gimp 2.4.2 downloadable via Synaptic?

Steve Kowalik (stevenk) on 2007-12-17
Changed in gimp:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

2.4.2 is in hardy.

Changed in gimp:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

 gimp (2.4.2-0ubuntu0.7.10) gutsy-proposed; urgency=low
 .
   * Update to Gimp's 2.4.2 release, as opposed to keeping 2.4.0rc3 in Gutsy,
     on the off chance that this fixes some bugs. (LP: #157642)
   * Bump shlibs, just in case.

Please test and give feedback here.

Changed in gimp:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Please note that, in order to get this into -updates, the Technical Board needs to approve this at an https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions .

John Wilund (orlando-runbox) wrote :

All I want is to have the latest gimp version downloadable with Synaptic. How can I make that a reality? Now it points to a release candidate....

John Wilund (orlando-runbox) wrote :
Gert Kulyk (gkulyk) wrote :

It is released in gutsy-proposed. It took some time because of a broken source-package, a recent upload fixed this. To get it, you'll have to enable gutsy-proposed repository in your sources.list.

I tested gimp from gutsy-proposed and evrything works fine for me.

dAniel hAhler spake thusly:
> I've asked on #ubuntu-devel about whether we should provide the stable release through -updates or -backports.
> The consensus has been that there should be a list of high-impact (SRU-able) bugs and only those should then get addressed.
> "Having a release candidate is not professional" is apparently no argument really.

That's *not* what he said. It's not a "release candidate", it's a
"release conadidate". Please re--read. What do you suppose the devs
would think of a "Release Conadidate"? I think it's rather
unprofessional (not unlike "dAniel hAhler" vs "Daniel Hahler".....).

--
             Scott
http://angrykeyboarder.com
I've never used an OS I didn't (dis)like.
©2007 angrykeyboarder™ & Elmer Fudd. All Wites Wesewved

Mantas Kriaučiūnas (mantas) wrote :

GIMP 2.4.2 final was included in Baltix GNU/Linux 3.1

Changed in gimp:
status: Confirmed → Fix Released
Bruce Cowan (bruce89) on 2008-10-19
Changed in gimp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers