Some characters replaced by others when converting PDF to PostScript

Bug #898532 reported by Till Kamppeter on 2011-12-01
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
Medium
ghostscript (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Originally reported by LStranger (andrej-rep) on bug 879977, but as the fix of that bug does not cover this problem, I am opening a separate bug.

The attached file, printed from LibreOffice in Oneiric prints with all 'к' replaced with 'а'. I also attach the PDF data which LibreOffice sends and this data is OK.

One can see that the problem is caused by Ghostscript converting the PDF data into PostScript, simply by running it through Ghostscript's PDF-to-PostScript converter script:

pdf2ps pdf2ps-character-problem.pdf

and displaying the resulting file:

gs pdf2ps-character-problem.ps

Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :

Reported bug to Ghostscript upstream as http://bugs.ghostscript.com/show_bug.cgi?id=692711.

Changed in gs-gpl:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-2ubuntu6

---------------
ghostscript (9.04~dfsg-2ubuntu6) precise; urgency=low

  * debian/patches/020111209-5359a2d-do-not-use-hexadecimal-names-for-type42-charstrings-and-encoding.patch:
    Do not use hexadecimal names for type42 Charstrings and Encoding. This fixes
    substitution of certain characters by others when converting PDF to
    PostScript with the "ps2write" output device (LP: #898532, upstream bug
    #692711)
  * debian/patches/020111125-979f218-ps2write-fix-conversion-of-escaped-string-to-hex-string.patch:
    ps2write: Fix conversion of escaped string to Hex string (LP: #902145,
    upstream bug #692612).
 -- Till Kamppeter <email address hidden> Fri, 9 Dec 2011 13:45:59 +0100

Changed in ghostscript (Ubuntu):
status: Confirmed → Fix Released
Changed in ghostscript (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → High
milestone: none → oneiric-updates
Till Kamppeter (till-kamppeter) wrote :

Corrected Oneiric package of Ghostscript to fix this bug and bug 902145 uploaded to -proposed. As soon as the upload gets approved a separate comment will get posted here with instructions for testing the new package. Please test it and report back here, so that we can make it an official update for Oneiric.

Hello Till, or anyone else affected,

Accepted ghostscript into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Till Kamppeter (till-kamppeter) wrote :

LStranger, karaluh, Tom, can you test the proposed package for Oneiric as described in the previous comment (#6) and report back here? Thanks.

Changed in gs-gpl:
status: Confirmed → Fix Released
Tom Louwrier (tom-louwrier) wrote :

Hi Till,

Got the updates from Proposed this morning and installed them.
Right now I can not reproduce the missing characters any more, there are no small 'empty squares' in my documents.
Great, thanx!

However documents that are set up for landscape will now have the content set at 90 degrees to the paper, no matter what output setting I choose in the printing menu. Should I open a new bug report for that?

cheers
Tom

Till Kamppeter (till-kamppeter) wrote :

Tom, thank you very much. So your font problem seems to be fixed with the update.

The landscape document problem seems to be independent of that, so please report a separate bug.

tags: added: verification-done
removed: verification-needed
LStranger (andrej-rep) wrote :

Updated to Proposed one. As for now everything seems working well. Thank you.

karaluh (karaluh) wrote :

Works for me also. Thank you.

LStranger, karaluh, thank you very much for testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-0ubuntu11.4

---------------
ghostscript (9.04~dfsg-0ubuntu11.4) oneiric-proposed; urgency=low

  * debian/patches/020111209-5359a2d-do-not-use-hexadecimal-names-for-type42-charstrings-and-encoding.patch:
    Do not use hexadecimal names for type42 Charstrings and Encoding. This fixes
    substitution of certain characters by others when converting PDF to
    PostScript with the "ps2write" output device (LP: #898532, upstream bug
    #692711)
  * debian/patches/020111125-979f218-ps2write-fix-conversion-of-escaped-string-to-hex-string.patch:
    ps2write: Fix conversion of escaped string to Hex string (LP: #902145,
    upstream bug #692612).
 -- Till Kamppeter <email address hidden> Fri, 9 Dec 2011 13:45:59 +0100

Changed in ghostscript (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.