Segmentation fault

Bug #1172571 reported by Dan Ringwalt on 2013-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GS-GPL
Unknown
Unknown
ghostscript (Ubuntu)
Medium
Unassigned

Bug Description

I noticed a segmentation fault when running Ghostscript on a large PDF. The PDF can be downloaded from here: http://petrucci.mus.auth.gr/imglnks/usimg/a/ab/IMSLP55701-PMLP05948-WTC1-Mugellini-no_1-12.pdf

The command line options I am using are:

gs -dBATCH -dNOPAUSE -o 'out%d.png' -sDEVICE=pngmono -r100 IMSLP55701-PMLP05948-WTC1-Mugellini-no_1-12.pdf

and it seems to fail on page 19. The first 18 files are created successfully.

I am using Ubuntu 12.04.1 LTS and ghostscript version "9.05~dfsg-0ubuntu4.2". I've tested on both x86_64 and i386.

Dan Ringwalt (dringw) wrote :

I made a PDF only containing the page which causes the problem, and this PDF also causes the segmentation fault when running e.g.:

gs -dBATCH -dNOPAUSE -o page.png -sDEVICE=pngmono page.pdf

I have also ran same command on same PDF and its creating problem on page 19. Otherwise I tried an IBM Redbook http://www.redbooks.ibm.com/redbooks/pdfs/sg247738.pdf which is of 5.8MB and 318 pages and it worked fine.

Changed in ghostscript (Ubuntu):
status: New → Confirmed
tags: added: ghostscript
tags: added: pdf
Till Kamppeter (till-kamppeter) wrote :

Reported upstream as

http://bugs.ghostscript.com/show_bug.cgi?id=693934

Thank you very much for the bug report.

Please follow the upstream bug report and answer questions of the Ghostscript developers there. Thanks.

Changed in ghostscript (Ubuntu):
importance: Undecided → Medium

Tried to get output of Valgrind but it crashed on Page 7 :)

Dan Ringwalt (dringw) wrote :

Thanks Till, the patch there seems to fix the problem!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.