20080225 Live CD Function keys behave unexpectedly

Bug #195564 reported by Brian Murray on 2008-02-25
2
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Colin Watson
gfxboot-theme-ubuntu (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: casper

I was testing the Ubuntu daily amd64 Live CD from 20080225 and discovered the following:

Pressing F10 asks me if I want to "Halt the system now?" which was not listed as doing anything.

Odd information is presented after performing the following:
1) Highlight "Try Ubuntu..."
2) Press F6
3) Press F7
4) Press F1
5) Observe a "popup" that covers the Ubuntu logo and looks like a table with data and prog column headers.
6) Pressing escape then takes you to a mostly blank screen with just "boot:"
7) In this menu system it is recommended to boot with "rescue" to rescue an existing system however, the Live CD normally says to just boot to the Live environment.

These bug reports may not be related but I though they probably were so submitted it as one. If not let me know.

Colin Watson (cjwatson) wrote :

The major bug here is point 5, which is what a gfxboot crash looks like. I've reproduced this and will fix it.

The other issues you raise here are:

  * F10 presents undocumented power off dialog. I don't think this is a bug; it's just a feature there isn't room to document.
  * Escape from crash dialog takes you to (non-gfxboot) syslinux prompt. This is intentional; there needs to be a fallback way to boot the system somehow if gfxboot blows up.
  * F4 at syslinux prompt documents rescue mode even on the live CD. This is a bug and I'll open a separate task on debian-installer for it.

Colin Watson (cjwatson) on 2008-02-26
Changed in gfxboot-theme-ubuntu:
assignee: nobody → kamion
status: New → Fix Committed
Colin Watson (cjwatson) on 2008-02-26
Changed in debian-installer:
assignee: nobody → kamion
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gfxboot-theme-ubuntu - 0.5.5

---------------
gfxboot-theme-ubuntu (0.5.5) hardy; urgency=low

  * Fix crash when trying to display context-sensitive help, not that we
    have any at the moment (LP: #195564).

 -- Colin Watson <email address hidden> Tue, 26 Feb 2008 12:10:04 +0000

Changed in gfxboot-theme-ubuntu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20070308ubuntu30

---------------
debian-installer (20070308ubuntu30) hardy; urgency=low

  * Remove powerpc/cell subarchitecture altogether; support for these
    systems is now integrated into powerpc64.
  * Make ubuntu-modules mandatory on powerpc again; it was only made
    optional for cell.
  * Update help text translations from Launchpad.
  * Copy the live CD F4 help text from gfxboot into syslinux display format
    (LP: #195564).
  * Move to 2.6.24-10 kernels.

 -- Colin Watson <email address hidden> Tue, 26 Feb 2008 18:15:40 +0000

Changed in debian-installer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers