[Precise] Cannot install wine on AMD64 Ubuntu

Bug #975967 reported by Swâmi Petaramesh on 2012-04-07
126
This bug affects 29 people
Affects Status Importance Assigned to Milestone
gettext (Ubuntu)
Undecided
Unassigned

Bug Description

It's currently impossible to install wine on a fresh Precise Beta AMD64 install (+ all updates).

Wine 1.4 apparently has a dependancy to gettext-base:i386

gettext-base:i386 is incompatible with gettext-base and asks for its removal

removing gettext-base would basically break the damn whole system...

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: wine (not installed)
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia zfs zcommon znvpair zavl zunicode
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CheckboxSubmission: 46fb4d85e0c1991660d481d0bb0eb4b1
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Sat Apr 7 15:52:35 2012
EcryptfsInUse: Yes
SourcePackage: wine1.4
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine1.4 (Ubuntu):
status: New → Confirmed
Scott Ritchie (scottritchie) wrote :

The issue is because the i386 and amd64 versions of gettext in the archive are currently mismatched, either due to a build failure or simply because one built faster than the other. It should resolve itself with a new gettext upload or by simply waiting for the build daemons to catch up.

affects: wine1.4 (Ubuntu) → gettext (Ubuntu)

I could finally install wine 1.4 using the software center, where aptitude failed.

In the end I find myself with the following gettext installed:

gettext-base
libgettextpo0
libgettextpo0:i386
liblocale-gettext-perl

Franko Burolo (fburolo) wrote :

@Swami: How exactly did you do it? For me, Software Center still tries to uninstall the same 4 packages as apt-get does... and aptitude is not much smarter, neither... :-/

@Franko... Weeeelll... I did it just using the software center the normal way to install Wine ;-))

I found out that aptitude fails doing it, but either apt-get or the software center do work fine.

Franko Burolo (fburolo) wrote :

But not here... I am usually using apt-get to install software, only occasionally aptitude (I like the way it tries to handle situations and its "show" funcion shows more detail than apt-cache), and very rarely USC.
Now I tried to install Wine in precise with ALL OF THEM, and I always get the SAME RESULT -- it wants to unistall debhelper, gettext, intltool-debian and po-debconf...
So I don't really think this is only an aptitude related problem.

I found a way to install wine via Synaptic:

Before you begin, make sure all wine* and wine-gecko* packages are removed (I'm not sure if that's necessary, but that was my starting point in trying to work around this problem).

First, select to install the "wine" package. It will warn you that it's going to mark debhelper (etc) for removal. Go ahead and let it mark them.

Next, go to Custom Filters > Marked Changes, and for each thing it wanted to remove (red), right click the package and choose "Unmark".

Finally, choose "Apply" and it should complete successfully.

Good luck!

O. Emmerson (oemmerson) wrote :

I can confirm that installing wine with aptitude on Ubuntu 12.10 does not work right out (asks me to make decisions about packages (gettext) that I don't feel comfortable making.)

But using just plain apt works fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments