debootstrap does not install apt with --variant=buildd for intrepid chroot

Bug #254042 reported by Jamie Strandboge on 2008-08-01
4
Affects Status Importance Assigned to Milestone
germinate (Ubuntu)
High
Colin Watson
Intrepid
High
Colin Watson

Bug Description

Binary package hint: debootstrap

When setting up my build environment on intrepid, I found that apt does not get installed when using:

$ sudo debootstrap --variant=buildd --arch i386 intrepid ./intrepid http://127.0.0.1/ubuntu/

It works fine when not using '--variant=buildd', and also works fine using '--variant=buildd' with dapper-hardy and sid.

Jamie Strandboge (jdstrand) wrote :

In an intrepid VM, I ran:

$ apt-cache dumpavail | grep-dctrl -F Build-Essential -s Package yes
Package: binutils
Package: build-essential
Package: bzip2
Package: cpio
Package: dpkg-dev
Package: g++
Package: g++-4.3
Package: gcc
Package: gcc-4.3
Package: ifupdown
Package: libc6-dev
Package: libgdbm3
Package: libgomp1
Package: libstdc++6-4.3-dev
Package: libtimedate-perl
Package: linux-libc-dev
Package: make
Package: net-tools
Package: netbase
Package: patch
Package: perl
Package: perl-modules

which is why apt was not installed (debootstrap looks at Build-Essential when using --variant=buildd).

Daniel Moerner (dmoerner) wrote :

This is confirmed using archive.ubuntu.com/ubuntu, so the problem is not with your local machine (obviously). debootstrap --variant=buildd only looks at priority required plus Build-Essential. The problem is that apt is in priority important:

dmoerner@kronos:~$ aptitude search ~prequired | grep apt
dmoerner@kronos:~$ aptitude search ~pimportant | grep apt
i A apt - Advanced front-end for dpkg
i A apt-utils - APT utility programs

I did not mark this as a confirmed bug because this appears to be intentional behavior, so I think this might be a feature rather than a bug.

Jamie Strandboge (jdstrand) wrote :

I would be surprised if this is the intended behavior, as it breaks sbuild (and presumably pbuilder) and makes --variant=buildd somewhat useless, AFAICT as I can't actually start to build anything in these chroots, without having to do extra work in the chroot. Perhaps I am missing something though...

Jamie Strandboge (jdstrand) wrote :

Additionally, I don't see anything in the apt changelog mentinoing it needing to be important, and http://people.ubuntu.com/~ubuntu-archive/seeds/platform.intrepid/build-essential has apt listed as needing to be build-essential.

kundai (kundai-andrew) wrote :

I can also confirm the bug.

Changed in debootstrap:
status: New → Confirmed
Daniel Moerner (dmoerner) wrote :

I don't understand why this bug exists. If you compare a diff of the two (you do gutsy as both intrepid and hardy buildd are symlinks to gutsy) you don't see any difference:

dmr@skynet:~/Documents/Work/debootstrap$ diff debootstrap-1.0.10/scripts/ubuntu/gutsy debootstrap-1.0.8/scripts/ubuntu/gutsy
45c45
< chown 0:0 "$TARGET/etc/fstab"; chmod 644 "$TARGET/etc/fstab"
---
> chown 0.0 "$TARGET/etc/fstab"; chmod 644 "$TARGET/etc/fstab"

Daniel Moerner (dmoerner) wrote :

Or rather, not that I don't understand why this bug exists, but I doubt now that it is a bug in debootstrap.

Daniel Moerner (dmoerner) wrote :

I don't see this in apt either:

dmr@skynet:~/Documents/Work/debootstrap/apt-0.7.9ubuntu17$ find . -exec grep -i build-essential {} + | grep -v "/doc/" > ../hardy-be.grep

dmr@skynet:~/Documents/Work/debootstrap/apt-0.7.14ubuntu5$ find . -exec grep -i build-essential {} + | grep -v "/doc/" > ../intrepid-be.grep

dmr@skynet:~/Documents/Work/debootstrap$ diff intrepid-be.grep hardy-be.grep

dmr@skynet:~/Documents/Work/debootstrap$

Any ideas?

Colin Watson (cjwatson) wrote :

This bug is a bit twisty. What's happened is that germinate now expands Recommends as well as Depends when expanding seeds; this causes apt to be pulled into required from germinate's point of view, which means that as far as it's concerned it no longer needs to be listed as build-essential. However, the archive admin team hasn't yet actually promoted apt and its dependencies to Priority: required.

At the moment I'm not sure whether germinate should stop expanding Recommends in the required (and maybe even minimal) seeds since debootstrap doesn't do that, or whether debootstrap should start expanding Recommends. I'm inclined towards the former.

Colin Watson (cjwatson) on 2008-08-19
Changed in germinate:
importance: Undecided → High
assignee: nobody → kamion
milestone: none → intrepid-alpha-5
Colin Watson (cjwatson) wrote :

revno: 1234
committer: Colin Watson <email address hidden>
branch nick: platform.intrepid
timestamp: Mon 2008-09-01 01:38:39 +0100
message:
  disable following of Recommends for required seed (LP: #254042)

This will only become effective once our sysadmins install germinate 1.7 on drescher; I'll file a ticket for that separately.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package germinate - 1.7

---------------
germinate (1.7) unstable; urgency=low

  * Add support for setting per-seed features, so that following Recommends
    can be disabled for some seeds but not others (LP: #254042).

 -- Colin Watson <email address hidden> Mon, 01 Sep 2008 01:43:22 +0100

Changed in germinate:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

germinate 1.7 was installed on drescher a few days ago, so this bug is now fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers