Ubuntu

genshi version 0.6-2 FTBFS on i386 in precise

Reported by Andreas Moog on 2012-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gentoo Linux
Fix Released
Medium
genshi (Debian)
Fix Released
Unknown
genshi (Fedora)
Unknown
Unknown
genshi (Ubuntu)
High
Ubuntu Server Team
Precise
High
Ubuntu Server Team
Quantal
High
Ubuntu Server Team

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

plaintext (genshi.util)
Doctest: genshi.util.plaintext ... ok
stripentities (genshi.util)
Doctest: genshi.util.stripentities ... ok
striptags (genshi.util)
Doctest: genshi.util.striptags ... ok
test_getitem (genshi.tests.util.LRUCacheTestCase) ... ok
test_setitem (genshi.tests.util.LRUCacheTestCase) ... ok

======================================================================
FAIL: test_sanitize_remove_src_javascript (genshi.filters.tests.html.HTMLSanitizerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/build/buildd/genshi-0.6/genshi/filters/tests/html.py", line 442, in test_sanitize_remove_src_javascript
    '<IMG SRC=`javascript:alert("RSnake says, \'foo\'")`>')
AssertionError: ParseError not raised

----------------------------------------------------------------------
Ran 828 tests in 2.212s

FAILED (failures=1)
make: *** [binary-install/python-genshi] Error 1
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary gave error exit status 2
******************************************************************************
Build finished at 20120201-2239
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3146802/+files/buildlog_ubuntu-precise-i386.genshi_0.6-2_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Andreas Moog (amoog) on 2012-02-18
Changed in genshi (Ubuntu):
importance: Undecided → High
Changed in genshi (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) on 2012-02-22
Changed in genshi (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Changed in genshi (Debian):
status: Unknown → New
Stefano Rivera (stefanor) wrote :

Both test failures are caused by recent changesin HTMLParser in cpython 2.7. Forwarded both issues upstream, expecting them to release point release fixing them, soon.

http://genshi.edgewall.org/ticket/500
http://genshi.edgewall.org/ticket/501

Changed in genshi (Debian):
status: New → Confirmed
Martin Pitt (pitti) on 2012-03-02
Changed in genshi (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Micah Gersten (micahg) on 2012-03-04
Changed in genshi (Ubuntu Precise):
status: Confirmed → Triaged
tags: added: rls-mgr-p-tracking
Changed in genshi (Ubuntu Precise):
assignee: nobody → Ubuntu Server Team (ubuntu-server)
Martin Pitt (pitti) on 2012-03-26
Changed in genshi (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
James Page (james-page) on 2012-05-31
Changed in genshi (Ubuntu):
milestone: ubuntu-12.04 → quantal-alpha-1
Changed in genshi (Ubuntu Precise):
milestone: ubuntu-12.04 → ubuntu-12.04.1
Changed in genshi (Ubuntu):
milestone: quantal-alpha-1 → quantal-alpha-2
Changed in genshi (Ubuntu):
milestone: quantal-alpha-2 → quantal-alpha-3
James Page (james-page) on 2012-08-09
Changed in genshi (Ubuntu Precise):
milestone: ubuntu-12.04.1 → precise-updates
Download full text (5.4 KiB)

test_getitem (genshi.tests.util.LRUCacheTestCase) ... ok
test_setitem (genshi.tests.util.LRUCacheTestCase) ... ok

======================================================================
FAIL: test_sanitize_remove_script_elem (genshi.filters.tests.html.HTMLSanitizerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/genshi-0.6/work/Genshi-0.6/genshi/filters/tests/html.py", line 368, in test_sanitize_remove_script_elem
    self.assertRaises(ParseError, HTML, '<SCR\0IPT>alert("foo")</SCR\0IPT>')
AssertionError: ParseError not raised

======================================================================
FAIL: test_sanitize_remove_src_javascript (genshi.filters.tests.html.HTMLSanitizerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/genshi-0.6/work/Genshi-0.6/genshi/filters/tests/html.py", line 442, in test_sanitize_remove_src_javascript
    '<IMG SRC=`javascript:alert("RSnake says, \'foo\'")`>')
AssertionError: ParseError not raised

----------------------------------------------------------------------
Ran 828 tests in 1.430s

FAILED (failures=2)
 * ERROR: dev-python/genshi-0.6 failed (test phase):
 * Testing failed with CPython 2.7 in distutils_testing() function

Portage 2.1.11.11 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.5.2-vs2.3.4.1 x86_64)
=================================================================
System uname: Linux-3.5.2-vs2.3.4.1-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
Timestamp of tree: Unknown
app-shells/bash: 4.2_p37
dev-lang/python: 2.7.3-r2, 3.2.3-r1
dev-util/pkgconfig: 0.27
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.10.5
sys-apps/sandbox: 2.6
sys-devel/autoconf: 2.69
sys-devel/automake: 1.12.3
sys-devel/binutils: 2.22.90
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc: 2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="POSIX"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --time...

Read more...

Changed in genshi (Ubuntu Quantal):
milestone: quantal-alpha-3 → ubuntu-12.10-beta-2
Antonio Rosales (a.rosales) wrote :

Looks like the bug is still pending a resolution (see comment #1) from upstream. I put a comment in the upstream bugs to check on the status of a resolution.

Changed in gentoo:
importance: Unknown → Medium
Colin Watson (cjwatson) on 2012-10-02
Changed in genshi (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-2 → ubuntu-12.10

Did a local test build, and the package in unapproved appears to indeed fix this. Approved through the queue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package genshi - 0.6-2ubuntu1

---------------
genshi (0.6-2ubuntu1) quantal; urgency=low

  * genshi/filters/tests/html.py: Adjust some tests which used to fail
    before changes in upstream Python 2.7.3. These now succeed. While
    this change is appropriate for the FTBFS in Ubuntu 12.04 which has
    Python 2.7.3, they may not be appropriate as a general fix, so keep an
    eye on the upstream bug reports. (LP: #935516)
  * debian/rules: As suggested in the linked Debian bug, use `set -e` on
    the test invocation line to force the build to fail when tests fail.
 -- Barry Warsaw <email address hidden> Tue, 02 Oct 2012 16:48:23 -0400

Changed in genshi (Ubuntu Quantal):
status: Triaged → Fix Released

Fixed by patches prepared upstream;
http://genshi.edgewall.org/ticket/500 & /501

The patch to HTMLParser for issue 13987 that landed in the cpython 2.7 branch breaks tests test_sanitize_remove_script_elem & test_sanitize_remove_src_javascript

dev-python/genshi $ USE_PYTHON="2.5 2.6 2.7 2.7-pypy-1.9" ebuild genshi-0.6.ebuild clean test

 * Testing of dev-python/genshi-0.6 with CPython 2.5...
----------------------------------------------------------------------
Ran 830 tests in 1.793s

OK
 * Testing of dev-python/genshi-0.6 with CPython 2.6...
----------------------------------------------------------------------
Ran 830 tests in 1.670s

OK
 * Testing of dev-python/genshi-0.6 with PyPy 1.9 (Python 2.7)...
----------------------------------------------------------------------
Ran 828 tests in 4.563s

OK

# The html_test.patch is needed only for python2.7 for now, breaks all other versions. The html.py needs
# adjusting only to pass the tests for 2.7. Other ABIs still need the original filters/tests/html.py,
# hence this long winded juggling appears the only method to set a viable genshi/filters/tests/html.py
# for each python version. The test needed patching, instead they changed the genshi/filters/tests/html.py

Anyone can reduce this feel free, but I don't seen upstream changing the test since they've instead made a fix to the html.py used in tests

Changed in gentoo:
status: Unknown → Fix Released
Changed in genshi (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.