gedit crashes browsing fileselector ssh locations

Bug #236953 reported by _oOMOo_ on 2008-06-02
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Medium
gedit (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

When using gedit to browse a mounted sftp location for a file to open, or when browsing the sftp location to save a file, gedit will crash when using the breadcrumb (history) buttons to navigate.

How to replicate:

1) Add a bookmark to an ssh location which contains a couple of layers of directories
2) Open gedit and choose "File>Open..."
3) Click on the new bookmark and navigate down a directory tree a couple of levels
4) Use the breadcrumb buttons to go back to the top level of the bookmark
5) If gedit hasn't already crashed just navigate back and forth a couple of times using the buttons, it invariably does.

This also happens on "Save" and "Save As.." which can lead to losing work.

Updated 7th Sept 2008 to clarify and include steps to reproduce.

Sebastien Bacher (seb128) wrote :

what ubuntu version are you using?

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
_oOMOo_ (hermann-blaxhall) wrote :

8.04 fully up-to-date. I've done some more investigation and tried browsing different sftp servers and only one of them causes the crash - and even then only on one folder, called "web". This folder also happens to be the root of a bookmark I've set up - not sure if that has anything to do with it.

Sebastien Bacher (seb128) wrote :

could you use gdb and get a crash stacktrace?

_oOMOo_ (hermann-blaxhall) wrote :

Hi, I'm not totally sure what you mean but this is the gdb output when I try to replicate the crash - gedit doesn't actually crash so much as just hang when running it under gdb:

** (gedit:10379): WARNING **: Operation not supported by backend
[New Thread 0x42a5a950 (LWP 10433)]
[New Thread 0x42259950 (LWP 10434)]
[Thread 0x42259950 (LWP 10434) exited]
[Thread 0x41791950 (LWP 10425) exited]

** (gedit:10379): WARNING **: Operation not supported by backend
gedit: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fde09cae7a0 (LWP 10379)]
0x00007fde05f18095 in raise () from /lib/libc.so.6

Hope this is useful, happy to try more, just not that familiar with gdb (yet!)

Sebastien Bacher (seb128) wrote :

you can read http://wiki.ubuntu.com/DebuggingProgramCrash on how to get a stacktrace

_oOMOo_ (hermann-blaxhall) wrote :

Thanks for the link - I've attached the gdb output.

Sebastien Bacher (seb128) wrote :

could you run the "env" command and attach the log to a comment?

_oOMOo_ (hermann-blaxhall) wrote :
Sebastien Bacher (seb128) wrote :

nothing special there, the gdb log has a "GVFS-ERROR **: DBus failed with out of memory error" which weird and no debug informations, could you install libglib2.0-0-dbgsym libgtk2.0-0-dbgsym gvfs-dbgsym and get a new stracktrace? it's likely not a gedit but an xorg or gvfs or dbus issue though

_oOMOo_ (hermann-blaxhall) wrote :

I've installed the packages you mention - this is the new gdb output.

Sebastien Bacher (seb128) wrote :

what theme do you use? does changing make a difference? could you install libx11-6-dbg libcairo2-dbgsym libxrender1-dbgsym and get a new stacktrace?

_oOMOo_ (hermann-blaxhall) wrote :

I'm using emerald / clearlooks. I just created a new user account and left all the themes etc. as default, added the bookmark and I can replicate the same behaviour. I also added the bookmark to my desktop machine (I first noticed it on my laptop) and the behaviour is the same. Both use the nvidia driver.

I haven't had a chance to get the trace using the above packages - some updates recently required the removal of gvfs-dbgsym, but I'll post it here as soon as I have.

_oOMOo_ (hermann-blaxhall) wrote :

Sorry for the delay in getting this trace. Just to confirm the behaviour exists in a clean install of Intrepid alpha also. This the trace from my Hardy installation as before but with the extra packages as requested:

Sebastien Bacher (seb128) wrote :

the bug is not a gedit one, not sure what is creating the issue but that's likely the theme, the video driver or cairo, reassigning to cairo

Changed in gedit:
assignee: desktop-bugs → nobody
status: Incomplete → New

Same problem here, while browsing a ssh share in my local network, happening in gedit and revelation password manager, mostly when I click on the path toolbar of the file chooser to return to a previous path. Getting the same output:

** (revelation:14775): WARNING **: Operation not supported by backend
python: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Aborted

I've tested it on:
Asus EEE running Ubuntu 8.04, updated and using the Intel driver, with clearlooks theme.
Desktop Core 2 Duo running Ubuntu 8.04, updated and using the proprietary nvidia driver, with ubuntu default theme (brand new user to make the test).

Both using the default ubuntu theme.

Very annonying bug and easy to reproduce. Just clicking on the history toolbar I'm able to crash it consistently.

Well, actually that was the error I got from Revelation. From gedit, it was exactly the one reported previously in this bug:

gedit: ../../src/xcb_lock.c:33: _XCBUnlockDisplay: Assertion `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.

Sebastien Bacher (seb128) wrote :

could you run "env" on a command line and attach the log to the bug?

Attaching the env command output

Sebastien Bacher (seb128) wrote :

the environment has nothing special, not sure what create the issue but nobody else get it so you should better open the bug upstream directly

_oOMOo_ (hermann-blaxhall) wrote :

What do you mean nobody else gets it?? I reported the bug and I still get it, it is easily reproduced on all my machines and is present in an up to date version of Intrepid.

Sebastien Bacher (seb128) wrote :

that's the only bug about the issue and the description is not really clear

description: updated
Changed in cairo:
status: New → Confirmed
GlenJohnson (glen-johnson) wrote :

This bug effects me also. I've lost my work so many times -- it would *really* be nice if someone was able to fix this. I don't use the navigation any more, in gedit, because of this -- rather I paste the full path of the file after clicking on the sftp location.

Sebastien Bacher (seb128) wrote :

confirming, that seems to be a gedit bug, sent upstream on http://bugzilla.gnome.org/show_bug.cgi?id=551337

Changed in cairo:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Changed in gedit:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gedit:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

would be nice to fix in hardy too

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.23.92-0ubuntu1

---------------
gedit (2.23.92-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Bugfixes related to the gio port (lp: #236953, #262007)

 -- Sebastien Bacher <email address hidden> Mon, 08 Sep 2008 21:33:44 +0200

Changed in gedit:
status: Fix Committed → Fix Released
_oOMOo_ (hermann-blaxhall) wrote :

Thanks, it's great that this bug has been fixed it was a real nuisance. FTP editing is not now Read Only either, a very useful improvement.

_oOMOo_ (hermann-blaxhall) wrote :

Is there any way this can be fixed in Hardy? The functionality is Intrepid is an enormous improvement, but in Hardy gedit still crashes when browsing mounted locations.

th (daimoni) wrote :

"fix released", yet I don't see any fix for this in Hardy.

So where is the fix? (This bug is getting really annoying and affecting my work).

Sebastien Bacher (seb128) wrote :

did you look at the launchpad page before commenting? if you do you will notice that the hardy task is not closed yet, the bug has been fixed in intrepid though

th (daimoni) wrote :

ah okay, sorry - i assumed this won't get fixed in hardy since it's fixed in intrepid :)

th (daimoni) wrote :

Still no fix released for Hardy?

th (daimoni) wrote :

Half year later - no fix for hardy...

Sebastien Bacher (seb128) wrote :

those comments are not useful, there is a small team working on over an hundred components for several ubuntu version, you are welcome to give an hand to the team to resolve this workload issue, note that the change is not trivial to backport but the workaround could maybe be used there

Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gedit:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Any testers on hardy?

Steve Beattie (sbeattie) wrote :

I was able to reproduce the gedit crash with the version of gedit in hardy-updates, 2.22.3-0ubuntu1, and was unable to reproduce the error with the version in hardy-proposed, 2.22.3-0ubuntu2, after spending several minutes navigating around using the breadcrumb buttons. Cursory usage of opening, editing, and saving files didn't show any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.22.3-0ubuntu2

---------------
gedit (2.22.3-0ubuntu2) hardy-proposed; urgency=low

  * debian/patches/91_workaround_ssh_crasher.patch:
    - workaround a crasher when ssh locations (lp: #236953)

 -- Sebastien Bacher <email address hidden> Fri, 23 Jan 2009 19:09:05 +0100

Changed in gedit:
status: Fix Committed → Fix Released
Changed in gedit:
importance: Unknown → Medium
Changed in gedit:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.