Ubuntu login screen sometimes doesn't appear on a single GPU Nvidia system (and setting WaylandEnable=false fixes it)

Bug #1798790 reported by Efthimios Chaskaris on 2018-10-19
372
This bug affects 75 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Unknown
gdm3 (Ubuntu)
High
Iain Lane
Eoan
High
Iain Lane
gnome-session (Ubuntu)
Undecided
Iain Lane
Eoan
Undecided
Iain Lane
gnome-shell (Ubuntu)
Undecided
Iain Lane
Eoan
Undecided
Iain Lane

Bug Description

https://gitlab.gnome.org/GNOME/gdm/issues/483
formerly https://gitlab.gnome.org/GNOME/gdm/issues/435

---

The boot process hangs with the last message being "started bpfilter". There is unusual Network activity during that time. The light of the WiFi adapter is blinking a lot.

I am not sure the problem is with the gdm3 package. As a matter of fact, I would remove it and let someone more experienced to set it. I'm afraid I might break something, though.

The specific steps or actions you took that caused you to encounter the problem: 1. Boot Ubuntu 18.10 with the Nvidia proprietary drivers
installed.

The behavior you expected: I expected Ubuntu 18.10 to boot normally.

The behavior you actually encountered: The computer gets stuck in a command-like environment with the last message being "started bpfilter". You can't type any commands.

I have found that uninstalling the Nvidia proprietary drivers by going into recovery mode fixes the issue.

Booting with the earlier kernel doesn't fix the issue. Installing the earlier v.340 driver also doesn't fix the issue.

This (https://askubuntu.com/questions/1032639/ubuntu-18-04-stuck-in-boot-after-starting-gnome-display-manager-on-intel-graphic) seems relevant. This is where I found the "solution".

affects: xorg-server (Ubuntu) → gdm3 (Ubuntu)
description: updated
summary: - Ubuntu 18.10 hangs at "started bpfilter"
+ Ubuntu 18.10 hangs at "started bpfilter" - "Started Gnome Desktop
+ Manager" during boot
description: updated

Same issue. Going to recovery mode and then restarting seems to have solved it for now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed

Simply going into recovery mode and then restarting didn't fix it for me. Continuing into normal boot also didn't fix the issue.

description: updated
description: updated
Jason Fox (kb3lms) wrote :

As mentioned in the above askubuntu posting, removing the nvidia driver got me past the problem.

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in gdm3 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

Can the importance also be higher? Gaming is impossible with the Nouveau drivers. Thank you. I might provide a video reproducing the problem later as well.

description: updated
description: updated
description: updated
Changed in gdm3 (Ubuntu):
importance: Low → High
Sebastien Bacher (seb128) wrote :

Sorry but I don't understand the description, ""Started bpfilter" is located just under "Started Gnome Desktop Manager"." what does that mean? Where is that displayed? Why is it an issue to have "Started bpfilter" displayed under "Started Gnome Desktop Manager"?

Daniel van Vugt (vanvugt) wrote :

Sounds like the real issue is that the login screen is not appearing.

Please run these commands and attach the output files from each:

  1. lspci -k > lspcik.txt
  2. dpkg -l > dpkgl.txt
  3. dmesg > dmesg.txt
  4. journalctl -b > journal.txt

Changed in mutter (Ubuntu):
status: New → Incomplete

These commands were run in a normal boot of Ubuntu, without the Nvidia drivers.

@seb128 I'm just trying to explain where the two messages are in relation to each other in this command-like environment you are stuck in. Having one line before the other is not an issue.

Oops, sorry. That is the log from when it was working. We need a log from when it is broken, so please...

1. Reinstall the Nvidia driver to reproduce the problem.

2. After you have reproduced the problem and the machine fails to boot, force a reboot and enter recovery mode.

3. Run this command to collect the log from the previous (failed) boot:

  journalctl -b-1 > prev_boot.txt

and send that to us.

tags: added: cosmic nouveau
summary: - Ubuntu 18.10 hangs at "started bpfilter" - "Started Gnome Desktop
- Manager" during boot
+ [nouveau] Ubuntu 18.10 hangs at "started bpfilter" - "Started Gnome
+ Desktop Manager" during boot
Sebastien Bacher (seb128) wrote :

@Efthimios, well, your description still doesn't make sense, it should start with a statement of the problem, like "after installating the nvidia driver my computer doesn't reach the login screen but is stucked on a screen with those messages" if that's what is happening?

""Started bpfilter" is located just under "Started Gnome Desktop Manager" doesn't state what the problem is in any understandable way...

summary: - [nouveau] Ubuntu 18.10 hangs at "started bpfilter" - "Started Gnome
- Desktop Manager" during boot
+ Ubuntu 18.10 login screen never appears when using the Nvidia driver

@seb128 Sorry, I will remove it.

description: updated
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Thanks. I think I can see the problem now.

The first thing that happens is that gdm3 tries to start a Wayland login screen ('gnome-shell' process) and fails because the Nvidia driver doesn't support KMS:

Oct 23 11:59:14 efthimios-GA-78LMT-USB3 gnome-shell[1688]: meta_kms_resources_init failed: Calling drmModeGetResources() failed, assuming we have no outputs
Oct 23 11:59:14 efthimios-GA-78LMT-USB3 gnome-shell[1688]: Failed to create backend: No GPUs with outputs found

That is not a bug. What it should do next (and does on my machine) is then try again to start the login screen using X instead. However I can't see that in your log. You might have something odd installed or preventing the fallback from working.

Please:

1. Report the bug to the gdm developers here:

   https://gitlab.gnome.org/GNOME/gdm/issues

   and then tell us the new bug ID.

2. Try this as a workaround: edit /etc/gdm3/custom.conf and uncomment the line:

   #WaylandEnable=false

The bug ID is 435.

The workaround worked.

description: updated
Changed in gdm3 (Ubuntu):
status: Incomplete → New
Changed in mutter (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Nikola Chikos (lostpin) wrote :

Just to say that I've tested the '#WaylandEnable=false' method (I was having the same problem with the nVidia drivers) and it works great!

Edit the file /etc/gdm3/custom.conf it also worked for me.
If someone had tried installing lighdm you can go back to gdm by doing
sudo service lightdm stop
sudo reboot

tags: added: nvidia
removed: nouveau
Changed in mutter (Ubuntu):
importance: Undecided → High
Mateusz Mikuła (mati865) wrote :

Another workaround is adding `nvidia-drm.modeset=1` to the kernel command line.

Adam Niedling (krychek) wrote :

I'm having the same issue. The login screen appears after I press ctrl+alt+f2 and then ctrl+alt+f1.

Matheus Reich (matheusr98) wrote :

The following workaround worked for me, no problems now (140.107 - Ubuntu 18.10):

2. Try this as a workaround: edit /etc/gdm3/custom.conf and uncomment the line:

   #WaylandEnable=false

Daniel van Vugt (vanvugt) wrote :

The same workaround seems to be working for bug 1796614. Although that is about nouveau and this is about the proprietary Nvidia driver. Not sure if we can or should merge them.

Cripton (cripton) wrote :

The same workaround of commenting Wayland worked for me, also, before reading this, i got it to work doing this procedure:

1 choose recovery mode
2 enable network
3 continue normal boot

The other workaround works better, but maybe this help to find the solution.

rtimai (rtimai) wrote :

GDM3 fails to start, stalled at 'started bpfilter' on my HP laptop (model hp15-ay016nr) which runs Intel graphics, no nVidia hardware or drivers. So, this is not strictly an nVidia issue, which began after a Sat 8 December upgrade.

Booting previous kernels did not fix the problem. Disabling Wayland in /etc/gdm3/custom.conf also had no effect.

I'm having a terrible time gathering system information because I can only log in to Gnome Shell as a Live Session User from the Ubuntu 18.10 Live Install USB drive -- or as root in Recovery Mode -- which results in limited access to user files and info on the installed system. Attempting to view many directories gets Access Denied You Don't Have Permissions. I even have trouble viewing my backup folders on my external USB drive, and I'm afraid I may lose access to them if I revert to 18.04 LTS, or install an alternate distro to replace the current Ubuntu 18.10. I'm not familiar with recent file system security "enhancements," but I think there have been changes with unanticipated consequences.

I'm posting this as a temporary Live Session User off a Cosmic installation USB drive. None of my online account info is saved, and I have to search my pword/unname each time I visit any web site, it's a huge pain.
I have been hampered in researching this, but I have seen the same symptoms reported by Arch Linux users as well.

BTW, Cripton's tip above to enable networking did allow me to run 'apt update' in recovery mode to confirm no pending upgrades (so, no fixes pending.) But, unfortunately Resuming a normal boot did not result in gdm3 successfully starting for me.

rtimai (rtimai) wrote :

SOLVED (MAYBE)

For me, it's not nVidia, it's not WaylandEnable. It may be the "Started bpfilter" message, which I earlier thought was nothing. I don't know beans about this, but I checked, and bpfilter is a recent replacement for iptables in many Linux distros, and it's handled in the linux kernel. Casting about for perhaps an alternate to gnome display manager 3, I found that SLiM had high user ratings, and one of the suggested advantages was it didn't require systemd (the system startup daemon, which historically has had a running conflict with kernel developers, maybe bpfilter.) On the gamble that this bootup hang might be caused by a kernel-systemd conflict, I enabled networking in recovery mode and ran 'apt install slim' to install alternate display manager SLiM. the installation prompted me to choose SLiM or GDM as the default, I chose SLiM, and was able to boot Cosmic finally. If I run into any issues further on, I'll post here.

If you already have an alternate display manager installed, you can switch with "sudo dpkg-reconfigure gdm" and select the alt dm.

Anyway, this might be a last, desperate workaround for the "bpfilter hang," if all the other solutions didn't work for you.

rtimai (rtimai) wrote :

I forgot to include introductory links to this complicated issue. My crude understanding is that systemd handles system initialization, calling bpfilter (replacing iptables) which is handled by the linux kernel.

https://thenewstack.io/systemd-vs-linux-kernel/

https://www.linux.com/news/why-kernel-community-replacing-iptables-bpf

SLiM, btw, while it works, is Debian-branded. I'm still trying to figure out how to remove the amateurish Debian swirl background.

Daniel van Vugt (vanvugt) wrote :

Please don't comment on this bug unless the workaround in comment #19 works for you. If it doesn't work for you then you need to log a new bug of your own.

summary: Ubuntu 18.10 login screen never appears when using the Nvidia driver
+ (and setting WaylandEnable=false fixes it)

Daniel, sorry, you're right, I'm not describing a problem on an nVidia-based system. Will open a new bug.

summary: - Ubuntu 18.10 login screen never appears when using the Nvidia driver
- (and setting WaylandEnable=false fixes it)
+ Ubuntu login screen never appears when using the Nvidia driver (and
+ setting WaylandEnable=false fixes it)

Wayland is not fully functional or compatible with Ubuntu 18.10 yet.
So why use wayland in a full new distribution, and cause problems?
It wasted 8 hours of my time to find the solution.
Just because of 1 line in a gdm3 conf file.
1 wrong line in a config line, and Ubuntu fails.
Ubuntu needs essential conf and system protection, so that 1 little change cannot derail the entire
OS, or deleting or installing cannot remove essential files necessary to run the OS.
After this many years Ubuntu is still incredibly easy to break.
Essential, necessary configs and system files that run the basic OS should be read only!

This is not a problem of Wayland or Ubuntu but of Gnome and the Nvidia driver.
In fact Fedora 29 has the same problem, only it has to come out a month later they deactivate the proprietary driver and force to use Noveau.

ROODE (saaeed-es20) wrote :

The uncommenting this line doesn't work for me:
#WaylandEnable=false

Daniel van Vugt (vanvugt) wrote :

Then you are commenting on the wrong bug. Please open a new one instead.

Ian Warren (ausbunny) wrote :

Uncommenting this line worked for me. This bug occurred after a fresh install of 18.10.

VINCENT FONG (vwpfong) wrote :

I also have the same problem.

The uncommenting this line doesn't work for me:
#WaylandEnable=false

so I reinstalled the whole distro and wiped the harddisk.

Daniel van Vugt (vanvugt) wrote :

Vincent, you are commenting on the wrong bug. Please open a new one instead.

tags: added: disco
Janghou (janghou) wrote :

bug also in 19.04, just updated from 18.10

WaylandEnable=false workaround also works for 19.04

Nvidia 340 and 390 drivers still having issues with 19.04 but does not seem to be the cause of the gdm problem.

Zygmunt Krynicki (zyga) wrote :

I can reproduce this issue on my 19.04 system using GTX 650. If anyone needs debug information or to try a new package I'm happy to offer my help.

Zygmunt Krynicki (zyga) wrote :

I've added some extra debugging information to an upstream bug https://gitlab.gnome.org/GNOME/gdm/issues/435#note_499818

description: updated
Zygmunt Krynicki (zyga) wrote :

I've opened a fresh bug since the one referenced above was closed. https://gitlab.gnome.org/GNOME/gdm/issues/483

tags: added: rls-ee-incoming
Changed in gdm:
status: Unknown → New
Will Cooke (willcooke) on 2019-04-30
tags: removed: rls-ee-incoming
Changed in gdm3 (Ubuntu Eoan):
assignee: nobody → Iain Lane (laney)
Changed in mutter (Ubuntu Eoan):
assignee: nobody → Iain Lane (laney)

Workaround in #19 working for me so far on Ubuntu 19.04. Have done a reboot test and a powerup test so far.

Something I noticed earlier when the machine was stuck is that the machine was able to get to the point where I could ssh to it after the GUI hadn't started. The command below did bring up the GUI for me:
$ sudo systemctl restart gdm3
or even
$ /etc/init.d/gdm3 restart

Not a better workaround, but may save from rebooting while you make the change for #19.

$ cat /etc/issue.net
Ubuntu 19.04
$ uname -a
Linux ubuntu-am 5.0.0-15-generic #16-Ubuntu SMP Mon May 6 17:41:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Here is my syslog, I do notice some activity from 'meta_kms_resources_init', mentioned in #19, in there..

Thanks for all you do!

Gert Kruger (hgkrug1) wrote :

I experienced the same problem when I tried to install Ubuntu 19.04 with the initial option to install third party drivers. After installation and the first reboot, the system will not start up. I will see if I can reproduce this and post the log report.

I have a Dell Vostro 3670 PC with the following deatils:

Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz;
Motherboard: Dell Ince OV8F20;
12 GB RAM;
NVIDIA Corporation GP107 [GeForce GTX 1050] [10de:1c81] (rev a1) (prog-if 00 [VGA controller]);

Daniel van Vugt (vanvugt) wrote :

We probably don't need any more logs thanks. A fix is already being discussed here:

  https://gitlab.gnome.org/GNOME/gdm/merge_requests/67

Changed in gdm:
status: New → Fix Released
Iain Lane (laney) wrote :

The GDM side is committed for 3.33, but the way we've implemented this needs support from gnome-shell and a declaraion in the session file (which comes from gnome-session). WIP:

https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/570

Changed in mutter (Ubuntu Eoan):
status: Confirmed → Invalid
Changed in gdm3 (Ubuntu Eoan):
status: Confirmed → In Progress
Changed in gnome-session (Ubuntu Eoan):
status: New → In Progress
Changed in gnome-shell (Ubuntu Eoan):
status: New → In Progress
Changed in gnome-session (Ubuntu Eoan):
assignee: nobody → Iain Lane (laney)
Changed in gnome-shell (Ubuntu Eoan):
assignee: nobody → Iain Lane (laney)
Carlos Jaramillo (cjaramillo) wrote :

In case it helps. The bp_filter issue only affects me when booting without connected to power. In other words, the screen gets stuck on this only when booting with the battery alone.

I'm using a DELL Precision 7730 with an NVIDIA Quadro P4200, with Ubuntu 18.04 and NVIDIA driver 430.

Igor Yakushin (ivy2) wrote :

I have Dell 7530 with Nvidia Quadro P3200 (nvidia driver 418.74), running Ubuntu 18.04 (with all the latest updates) and I observe the same thing: with power cable it boots fine and without it gets stuck on "bpfilter started".

WaylandEnable=false
was already uncommented in /etc/gdm3/custom.conf.

peterzay (peterzay) wrote :

With WaylandEnable=false active in /etc/gdm3/custom.conf, the system monitor does not launch.

Is there a workaround for that?

peterzay (peterzay) wrote :

For info only:

There are ripple effects from this bug. See Bug #1825544 for a user switching problem.

Daniel van Vugt (vanvugt) wrote :

I had thought bug 1825544 was intentional, but I was wrong. I was confusing it with the absence of guest mode, which is intentional.

Eli Linares (real-act) wrote :

When I do the setting WaylandEnable=false fix the system becomes unstable and I get constant lockups and freezes unfortunately.

Daniel van Vugt (vanvugt) wrote :

Eli,

That's a different bug. Please open a new bug for that problem.

Daniel van Vugt (vanvugt) wrote :

Also, just a reminder: If anyone is using a multi-GPU desktop machine then please see bug 1705369 instead.

summary: - Ubuntu login screen never appears when using the Nvidia driver (and
- setting WaylandEnable=false fixes it)
+ Ubuntu login screen sometimes doesn't appear on a single GPU Nvidia
+ system (and setting WaylandEnable=false fixes it)
Peter De Sousa (pjds) wrote :

I also have this issue, but I discovered if I pressed Alt+F{N>2} then Alt+F1 gdm boots immediatly.

I opemed a bug here, https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1834568 but I will close it now that I found this one.

I see 'Started bpfilter' at shutdown or restart and it hangs when closing down. I can just power off holding the power button but I know may be causing OS/ HDD issues in not closing down correctly.

tags: removed: cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.33.90-1ubuntu1

---------------
gdm3 (3.33.90-1ubuntu1) eoan; urgency=medium

  * Merge with Debian. Remaining changes:
    + README.Debian: update for correct paths in Ubuntu
    + control.in:
      - Don't recommend desktop-base
      - Depend on bash for config_error_dialog.patch
      - Update Vcs field
    + rules:
      - Don't override default user/group
      - --enable-gdm-xsession to install upstream Xsession script
      - override dh_installinit with --no-start to avoid session being killed
    + rules, README.Debian, gdm3.8.pod:
      Use upstream custom.conf instead of daemon.conf
    + gdm3.{postinst,postrm}: rename user and group back to gdm
    + gdm3.postinst, gdm3.prerm: don't kill gdm on upgrade
    + gdm3.*.pam: Make pam_env read ~/.pam_environment
    + gdm3.install:
      - Stop installing default.desktop. It adds unnecessary clutter
        ("System Default") to the session chooser.
      - Don't install debian/Xsession
    + Add run_xsession.d.patch
    + Add xresources_is_a_dir.patch
      - Fix loading from /etc/X11/Xresources/*
    + Add nvidia_prime.patch:
      - Add hook to run prime-offload (as root) and prime-switch if
        nvidia-prime is installed
    + Add revert_override_LANG_with_accountservices.patch:
      - On Ubuntu accountservices only stores the language and not the
        full locale as needed by LANG.
    + Add dont_set_language_env.patch:
      - Don't run the set_up_session_language() function, since it
        overrides variable values set by ~/.pam_environment
    + Add config_error_dialog.patch:
      - Show warning dialog in case of error in ~/.profile etc. and
        don't let a syntax error make the login fail
    + Add debian/patches/revert_nvidia_wayland_blacklist.patch:
      - Don't blacklist nvidia for wayland
    + Add gdm3.service-wait-for-drm-device-before-trying-to-start-i.patch:
      - Wait for the first valid gdm device on pre-start
    + Add debian/default.pa
      - Disable Bluetooth audio devices in PulseAudio from gdm3.
    + debian/gdm3.install
      - Added details of the default.pa file
    + debian/gdm3.postinst
      - Added installation of default.pa and creation of dir if it doesn't
        exist.
    + debian/greeter.dconf-defaults: Don't set Debian settings in the
      greeter's dconf DB
  * Should fix Wayland to Xorg fallback on slow machines (LP: #1798790)

 -- Iain Lane <email address hidden> Thu, 15 Aug 2019 18:06:24 +0100

Changed in gdm3 (Ubuntu Eoan):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.5 KiB)

This bug was fixed in the package gnome-shell - 3.33.91-1ubuntu1

---------------
gnome-shell (3.33.91-1ubuntu1) eoan; urgency=medium

  [ Didier Roche ]
  * Read mode extension update and load
  * Avoid hardcoding set of ubuntu mode extensions

  [ Marco Trevisan (Treviño) ]
  * Merge with Debian. Remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      - Show monitor scaled cursor when magnifier is enabled
  * ubuntu/block_mode_extension_update.patch:
    - Dropped, as can be handled in a nicer way as per upstream ch...

Read more...

Changed in gnome-shell (Ubuntu Eoan):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.4 KiB)

This bug was fixed in the package gnome-session - 3.33.90-2ubuntu1

---------------
gnome-session (3.33.90-2ubuntu1) eoan; urgency=medium

  * Merge with Debian, remaining changes:
    - debian/control.in:
      + Recommend session-migration
      + Move xwayland dependency to gnome-session and make gnome-session
        Arch: any
      + Split gnome-startup-applications to a separate binary package so
        that it can be uninstalled without breaking the system
      + Add unity-session
    - Split ubuntu-session out of gnome-session.
    - Add upstart user session and systemd user session:
      debian/data, debian/gnome-session-bin.user-session.upstart
    - debian/gnome-session-bin.postinst, debian/gnome-session-bin.prerm:
       Moved registering gnome-session binary as a session manager to
       gnome-session-bin package
    - Add gnome-session-wayland transitional package
    - don't install gnome-mimeapps.list (installed by desktop-file-utils in
      Ubuntu):
      debian/gnome-session-common.dirs, gnome-session-common.install,
      gnome-session-common.maintscript, gnome-session-common.postinst
    - debian/patches/103_kill_the_fail_whale.patch:
      + Kill the Fail Whale as it tends to be more annoying than helpful
    - debian/patches/22_support_autostart_delay.patch:
      + Bugzilla patch to support adding a delay to autostart apps, using
        a "X-GNOME-Autostart-Delay" key in the desktop file
    - debian/patches/50_ubuntu_sessions.patch:
      + Add ubuntu session tweaks
    - debian/patches/51_remove_session_saving_from_gui.patch:
      + Add GNOME_SESSION_SAVE environment variable for people wanting to
        use the save session still, knowing that it can break your system
        if used unwisely
    - debian/patches/53_add_sessionmigration.patch:
      + launch session-migration if present at the start of the session.
        This sync tool runns different session migration scripts that can be
        provided in various desktop packages.
    - debian/patches/95_dbus_request_shutdown.patch:
      + Add "RequestShutdown" and "RequestReboot" DBus methods to allow
        other applications to shutdown or reboot the machine via the session
        manager.
    - debian/patches/ignore_gsettings_region.patch:
      + Ignore the "region" gsettings value - users' setting of LC_*
        variables saved in ~/.pam_environment.
    - debian/patches/revert_remove_gnome_session_properties.patch:
      + Don't merge translations into gnome-session-properties.desktop
    - debian/ubuntu-settings-migrate-to-defaults.18.10.1.py:
      + Migrate users using old default ubuntu-settings to current ones
  * ubuntu-sessions.patch: Refresh

gnome-session (3.33.90-2) experimental; urgency=medium

  * rules, gnome-.desktop.in.in-Pass-systemd.patch: Build with
    -Dsystemd_session=enable. Build gnome-session with
    -Dsystemd_session=enable (instead of =default). This means that sessions
    need to pass `--systemd` to launch using systemd.

gnome-session (3.33.90-1ubuntu1) eoan; urgency=medium

  * Merge with Debian, remaining changes:
    - debian/control.in:
      + Recommend session-migration
      + Move xwayland dependency to ...

Read more...

Changed in gnome-session (Ubuntu Eoan):
status: In Progress → Fix Released
symdeb (symdeb) wrote :

This happened to me after booting up on Sep 10 2019 after Ubuntu ran software updater on Sep 9. 2019. I update whenever there is an update reported by software updater. Tried to restart several times with the same result. System went to text mode and stuck at "starting bpfilter" every time. 100%. Luckily I had a 2nd computer to search for this issue. Uncommenting the Wayland option fix it. I update daily. Why did this happen ? This seems to be a recurring issue.

symdeb (symdeb) wrote :

Ubuntu 19.04
Updates set "for any new version"
Software updates: Just all the defaults
Linux 5.00.027-low latency #28-Ubuntu SMP PREMPT Aug 20 20:33:37 UTC 2019 x86_64 x86_64 GNU/Linux
Additional drivers:
Nvidia GF119, GeForce 610.
NVidia driver meta-package from Nvidia driver-390. proprietary tested).
Monitor Beng 2710BL 2560x1440 using DVD-DL.

Daniel van Vugt (vanvugt) wrote :

This bug is fixed in Ubuntu 19.10. We know it is not fixed in 19.04.

I will try the Wayland parameter option, but for what it's worth, the only way I've been able to recover so far is to boot off a USB thumb drive, mount my actual boot drive, download and run boot-repair. When I reboot, I finally get a grub menu and can institute the usual menu-driven repairs from there. The full boot-repair report can be found at https://paste.ubuntu.com/p/34RRkD365G/.

Daniel van Vugt (vanvugt) wrote :

This bug is closed. If you have any ongoing issue then please open a new bug for it.

Mathew Hodson (mhodson) on 2019-10-19
no longer affects: mutter (Ubuntu)
no longer affects: mutter (Ubuntu Eoan)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.