Xorg crash

Bug #1768906 reported by Cyrus Harmon on 2018-05-03
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Undecided
Unassigned

Bug Description

When attempting to log in to a newly updated bionic beaver via the display manager (I think this is the right term), I immediately see a crash, a return to the user selection/login screen and a no-longer functioning keyboard and mouse. This happens both with the proprietary driver installed drivers and with the apt installed nvidia-driver-396.

some interesting tidbits from the syslog file are:

May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission.
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) NVIDIA(0): Failing initialization of X screen 0
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (II) UnloadModule: "nvidia"
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (II) UnloadSubModule: "wfb"
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (II) UnloadSubModule: "fb"
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) Screen(s) found, but none have a usable configuration.
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE)
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: Fatal server error:
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) no screens found(EE)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7
ProcVersionSignature: Ubuntu 4.15.0-20.21-lowlatency 4.15.17
Uname: Linux 4.15.0-20-lowlatency x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 396.24 Thu Apr 26 00:10:09 PDT 2018
 GCC version: gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Thu May 3 09:28:59 2018
DistUpgraded: 2018-05-02 07:25:10,524 DEBUG failed to SystemUnLock() (E:Not locked)
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus: nvidia, 396.24, 4.15.0-20-lowlatency, x86_64: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. GK104 [GeForce GTX 770] [3842:2774]
MachineType: ASUS All Series
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-lowlatency root=UUID=f308f075-bd97-4230-9d24-3ab727b0036b ro splash quiet nomodeset vt.handoff=1
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: Upgraded to bionic on 2018-05-02 (1 days ago)
dmi.bios.date: 08/15/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1603
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MAXIMUS VI GENE
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1603:bd08/15/2014:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnMAXIMUSVIGENE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: ASUS MB
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc5-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc5-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Thu May 3 09:20:03 2018
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.6-1ubuntu4

Cyrus Harmon (ch-launchpad) wrote :
dino99 (9d9) wrote :

With that card, use nvidia-331 or 346 instead.

Changed in xorg (Ubuntu):
status: New → Incomplete
Cyrus Harmon (ch-launchpad) wrote :

Same thing happens with nvidia-346.

Cyrus Harmon (ch-launchpad) wrote :

Should I set this back to new?

Cyrus Harmon (ch-launchpad) wrote :

Same symptoms with a brand new GTX 1070 ti :(

Changed in xorg (Ubuntu):
status: Incomplete → New
dino99 (9d9) wrote :

Be sure to purge the previous used nvidia driver before testing a new one (settings removal).
Do you get the same issue if 'nouveau' driver is used ? (nvidia purged, and reboot)

Cyrus Harmon (ch-launchpad) wrote :

I'm not exactly clear what you mean by purging and settings removal. I've run uninstall with the proprietary driver (and rebooted) I've used nvidia-driver-396 and apt-cache remove --purge'd that. I've tried to video cards now. In short, I've tried everything I can think of, but still end up with the same problem.

Cyrus Harmon (ch-launchpad) wrote :

This happens with all combination of (bionic-ish) kernels and drivers I've tried so far, including:

Drivers: NVIDIA proprietary installer 396.24, nvidia-driver-396 (396.24-0ubuntu0~gpu18.04.1), nvidia-390 (390.48-0ubuntu3+gpu18.04.2)

kernels: 4.15.0-20-lowlatency, a locally built 4.16.3

cards: GTX 770 and GTX 1070ti

I've tried erasing /etc/X11/xorg.conf, running things with and without nomodeset, etc... all to no avail. Any suggestions for tracking this down further? thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Difference between remove & purge:
- 'remove' uninstall the package, but does not remove the package settings, which can disturb the system and conflict with an other driver choice.
- 'purge' remove both package & its settings; that is way recommended.

About /etc/X11/xorg.conf, this is no more used since a couple releases. so your system should not finf such a path anyway.

Your real problem is not about 'xorg' as you have reported but 'gdm' and/or 'gnome-session'
******************
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission.
May 3 09:20:18 madbox /usr/lib/gdm3/gdm-x-session[2748]: (EE) NVIDIA(0): Failing initialization of X screen 0
******************

Cyrus Harmon (ch-launchpad) wrote :

I am able to reproduce this following a reinstall of 18.04 from the ISO image, but only on the same box. No problems on two other computers. Will try reverting to 17.10 to see if that fixes the problem.

As for the component, can I test with alternative session managers, or is gdm3 the only game in town? thanks!

Cyrus Harmon (ch-launchpad) wrote :

Switching to lightdm instead of gdm3 gets around the problem. Should I change the component to gdm3?

affects: xorg (Ubuntu) → gdm (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

To debug a crash we require a crash report. To do this, please:

1. Apply the workaround from bug 994921.

2. Reproduce the crash.

3. Run: ubuntu-bug /var/crash/YOURFILE.crash

4. Mention here the ID of the new bug create.

Changed in gdm (Ubuntu):
status: Confirmed → Incomplete
affects: gdm (Ubuntu) → gdm3 (Ubuntu)
Cyrus Harmon (ch-launchpad) wrote :

Perhaps the folks from bug 994921 should reconsider the WON'T Fix...

Cyrus Harmon (ch-launchpad) wrote :

Well, I tried the workaround, switched to gdm3 and was able to trigger the problem, but nothing (new) appears in /var/crash.

Cyrus Harmon (ch-launchpad) wrote :

It's not clear that there's an actual crash here, but rather maybe that gdm3 can't acquire modesetting permission and can't find a display to work with. Not sure that's going to trigger an actual crash. Still a bug though!

Daniel van Vugt (vanvugt) wrote :

Doesn't matter. I just noticed you're hitting "no screens found". So we should file this under bug 1543192.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers