gdm does not honor disable_restart_buttons

Bug #494366 reported by NoOne Else on 2009-12-09
12
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdm
Expired
Low
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs
gdm3 (Debian)
Fix Released
Unknown

Bug Description

Binary package hint: gdm

Following http://live.gnome.org/GDM/2.22/Configuration, I run as root on Karmic the command

#> gconftool-2 --type boolean --set /apps/gdm/simple-greeter/disable_restart_buttons 1

which yields

#> gconftool-2 -g /apps/gdm/simple-greeter/disable_restart_buttons
true

However, after restarting gdm or rebooting the machine, the GDM greeter still shows the shutdown, suspend, and hibernate options and they still work.

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 9 09:32:22 2009
DistroRelease: Ubuntu 9.10
Package: gdm 2.28.1-0ubuntu2 [modified: var/lib/gdm/.gconf.defaults/%gconf-tree.xml]
ProcVersionSignature: Ubuntu 2.6.31-16.52-generic
SourcePackage: gdm
Uname: Linux 2.6.31-16-generic x86_64

Sebastien Bacher (seb128) wrote :

thank you for your bug report, did you try to change the key for the gdm user rather?

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Yes, without success.

Logged in as root, I ran

#> sudo -u gdm gconftool-2 --type boolean --set /apps/gdm/simple-greeter/disable_restart_buttons 1
#> sudo -u gdm gconftool-2 -g /apps/gdm/simple-greeter/disable_restart_buttons
true

After restarting gdm or rebooting the machine, the GDM greeter still shows the shutdown, suspend, and hibernate options and they still work.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gdm (Ubuntu):
status: Incomplete → New
Changed in gdm (Ubuntu):
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)

Right-clicking the key, and setting it as default for the sytem fixed the problem for me (see https://bugzilla.gnome.org/show_bug.cgi?id=599762).

After loging ut the button for halt and restart disappeared.

Changed in gdm:
importance: Unknown → Low
status: Unknown → New
gfunkdave (spam-gfunkdave) wrote :

Eshat Cakar's suggestion of right-clicking the key and choosing Set As Default works in Ubuntu 10.04 but not in 10.10. This bug should remain open.

Lenin (gagarin) wrote :

This bug also exists in Debian with the source package gdm3, but the real gdm software version is 2.x (at least for stable to sid, but not experimental)

Changed in gdm3 (Debian):
status: Unknown → New
Changed in gdm3 (Debian):
status: New → Fix Released
Changed in gdm:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.