gdm installation breaks due to gvfs fuse mount for the gdm user

Bug #438561 reported by Max Bowsher on 2009-09-29
134
This bug affects 34 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Chris Coulson
Karmic
Medium
Chris Coulson

Bug Description

Binary package hint: gdm

GDM appears to be trying and failing to contact DBus during its postinst.

ProblemType: Package
Architecture: i386
Date: Tue Sep 29 08:07:59 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: gdm 2.28.0-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: gdm
Title: package gdm 2.28.0-0ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-10-generic i686

Related branches

Max Bowsher (maxb) wrote :
neferty (roman-semko) wrote :

same problem here

neferty (roman-semko) wrote :

When looking at what has caused the problem in the installation log i found this line:

Setting up gdm (2.28.0-0ubuntu8) ...
chown: cannot access '/var/lib/gdm/.gvfs': Permission denied

now doing ls on /var/lib/gdm (only root allowed to read) I get the following:

root@neferty-laptop:/var/lib/gdm# ls -al
ls: cannot access .gvfs: Permission denied
total 76
drwxr-x--- 14 gdm gdm 4096 2009-09-29 08:23 .
drwxr-xr-x 79 root root 4096 2009-09-29 17:20 ..
drwx------ 2 gdm gdm 4096 2009-09-18 09:14 .cache
drwx------ 2 gdm gdm 4096 2009-09-16 12:42 .config
drwx------ 3 gdm gdm 4096 2009-09-16 12:42 .dbus
-rw------- 1 gdm gdm 16 2009-09-17 08:45 .esd_auth
drwxr-xr-x 2 gdm gdm 4096 2009-09-22 07:45 .fontconfig
drwx------ 4 gdm gdm 4096 2009-09-29 17:14 .gconf
drwx------ 2 gdm gdm 4096 2009-09-29 17:14 .gconfd
drwxr-xr-x 2 gdm gdm 4096 2009-09-29 08:23 .gconf.mandatory
-rw-r--r-- 1 gdm gdm 276 2009-09-29 02:31 .gconf.path
d????????? ? ? ? ? ? .gvfs
-rw------- 1 gdm gdm 10512 2009-09-27 14:27 .ICEauthority
drwxr-xr-x 2 gdm gdm 4096 2009-09-27 14:21 .icons
drwx------ 2 gdm gdm 4096 2009-09-27 12:47 .pulse
-rw------- 1 gdm gdm 256 2009-09-16 16:05 .pulse-cookie
drwxr-xr-x 2 gdm gdm 4096 2009-09-27 14:21 .themes
drwx------ 4 gdm gdm 4096 2009-09-27 14:21 .thumbnails

To be noted: a solution might be chowning the .gvfs directory manually to gdm/root, however even as root it doesn't allow to do so. Even to access that directory:

root@neferty-laptop:/var/lib/gdm# chown root:root .gvfs
chown: cannot access `.gvfs': Permission denied

What do the question marks mean anyway? Does anybody know how to get rid of them?:

d????????? ? ? ? ? ? .gvfs

Max Bowsher (maxb) wrote :

Dupe bug 438977 provided the hint to change to a text VT, stop gdm, and retry the installation. I confirm this allows the postinst to complete successfully.

caillean (caillean) wrote :

I filled bug 438977 by mistake, sorry for the duplicate.
But I can confirm that it worked for me to change to a text VT, then stop gdm and retry the upgrade. It worked on both of my computers.

Max Bowsher (maxb) wrote :

Still a problem with the next update to gdm. Please see bug 441015 for my apport attachments for the upgrade from -0ubuntu8 to -0ubuntu11

tags: added: regression-potential
Max Bowsher (maxb) wrote :

I've tagged regression-potential and nominated for karmic, as being unable to update gdm from within X is a regression and a serious problem!

Max Bowsher (maxb) wrote :

I just tried running 'dpkg --configure -a' from a text VT whilst gdm was still running, and it was fine. So it seems to be something about the postinst running inside a gnome-terminal that breaks things.

caillean (caillean) wrote :

I can confirm that the problem during the gdm update still exists.
Switching into tty1, stopping gdm and running the update again did help at all.

col reilly (lupinehorror) wrote :

second time this has happened doing a manual apt-get upgrade

latrom (moertael) wrote :

Max Bowsher wrote 7 hours ago:
I just tried running 'dpkg --configure -a' from a text VT whilst gdm was still running, and it was fine. So it seems to be something about the postinst running inside a gnome-terminal that breaks things.

I can confirm that this works on both of my karmic installations, amd64 and i386.

Juha

Pedro Villavicencio (pedro) wrote :

confirming based on the duplicates and comment there.

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in gdm (Ubuntu):
milestone: none → ubuntu-9.10
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
summary: - package gdm 2.28.0-0ubuntu8 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ gdm installation breaks due to gvfs fuse mount for the gdm user
Changed in gdm (Ubuntu):
importance: Low → Medium
Martin Pitt (pitti) wrote :

Robert, do you have time to look at this? If not, please assign back to me.

Changed in gdm (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

there is bug #441167 which is another issue due to those calls

Sebastien Bacher (seb128) wrote :

chrisccoulson said he has an idea and will work on those changes

Changed in gdm (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → Chris Coulson (chrisccoulson)
caillean (caillean) wrote :

Todays update of gdm(2.28.0-0ubuntu14) again gave the error :

Richte gdm ein (2.28.0-0ubuntu14) ...
Fehler beim Zuweisen des Wertes: Der Konfigurationsserver konnte nicht kontaktiert werden; mögliche Fehlerquellen sind, dass TCP/IP für ORBit nicht aktiviert ist oder auf Grund eines Systemabsturzes alte NFS-Sperren gesetzt sind. Unter http://projects.gnome.org/gconf/ erhalten Sie weitere Informationen (Details – 1: Verbindung zur Sitzung konnte nicht abgerufen werden: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
dpkg: Fehler beim Bearbeiten von gdm (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

running ´dpkg --configure -a´ in tty1 without stopping gdm let the upgrade complete succesfully.

Changed in gdm (Ubuntu Karmic):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu19

---------------
gdm (2.28.0-0ubuntu19) karmic; urgency=low

  * debian/%gconf-tree.xml, debian/gdm.postinst, debian/rules:
    - don't use gconftool to register the default gconf keys but rather
      install a xml files with the values, that will avoid different issues
      due to the su call or the gconf server not being running
      (lp: #441028, #441167)
    - set the gnome-power-manager icon key to never since that's not useful
      on the login screen and the design team recommended to not have it there
  * debian/gdm.postinst:
    - workaround chown breaking due to the .gvfs fuse directory (lp: #438561)
  * debian/patches/25_update_gconf_directories.patch:
    - define a new directory which is used for the default gconf values

 -- Sebastien Bacher <email address hidden> Thu, 15 Oct 2009 12:34:11 +0200

Changed in gdm (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers