Ubuntu

package gdm 2.28.0-0ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Reported by C de-Avillez on 2009-09-29
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: initramfs-tools

dist-upgrade on karmic, got this error. Interesting point, perhaps worthy of a different bug: GDM failed to install, but apport is filing a bug on initramfs-tools.

ProblemType: Package
Architecture: amd64
Date: Mon Sep 28 21:39:00 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: gdm 2.28.0-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: initramfs-tools
Title: package gdm 2.28.0-0ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-11-generic x86_64

C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :

the problem seems to be related to a directory /var/lib/gdm/.gvfs:

root@xango2:/var/lib/gdm# ls -lai
ls: cannot access .gvfs: Permission denied
total 176
1527039 drwxr-x--- 17 gdm gdm 4096 2009-09-29 11:04 .
1523713 drwxr-xr-x 118 root root 4096 2009-09-29 11:07 ..
1573899 drwxr-xr-x 3 root root 4096 2009-09-29 10:59 .cache
1573968 drwx------ 4 root root 4096 2009-09-29 10:59 .config
1523754 -rw------- 1 root root 33 2009-09-29 10:59 .cookie
1573905 drwx------ 3 root root 4096 2009-09-29 10:59 .dbus
1523819 -rw------- 1 root root 16 2009-09-29 10:59 .esd_auth
1523733 -rw-r--r-- 1 root root 63 2009-09-29 10:59 .fehbg
1523757 -rw-r--r-- 1 root root 2366 2009-09-29 10:59 .fehrc
1540358 drwxr-xr-x 2 root root 4096 2009-09-29 10:59 .fontconfig
1573909 drwx------ 4 root root 4096 2009-09-29 10:59 .gconf
1573964 drwx------ 2 root root 4096 2009-09-29 10:59 .gconfd
1574007 drwxr-xr-x 2 root root 4096 2009-09-29 10:59 .gconf.mandatory
1523771 -rw-r--r-- 1 root root 276 2009-09-29 10:59 .gconf.path
1543602 drwx------ 2 root root 4096 2009-09-29 10:59 .gnome2
1543640 drwxr-xr-x 2 root root 4096 2009-09-29 10:59 .gstreamer-0.10
      ? d????????? ? ? ? ? ? .gvfs
1523791 -rw------- 1 root root 79558 2009-09-29 10:59 .ICEauthority
1574009 drwxr-xr-x 2 root root 4096 2009-09-29 10:59 .icons
1543600 drwxr-xr-x 3 root root 4096 2009-09-29 10:59 .local
1573992 drwx------ 2 root root 4096 2009-09-29 10:59 .pulse
1523736 -rw------- 1 root root 256 2009-09-29 10:59 .pulse-cookie
1523720 -rw------- 1 root root 218 2009-09-29 10:59 .recently-used.xbel
1574006 drwxr-xr-x 2 root root 4096 2009-09-29 10:59 .themes
1572888 drwx------ 4 root root 4096 2009-09-29 10:59 .thumbnails
root@xango2:/var/lib/gdm#

How it got there... I do not know.

C de-Avillez (hggdh2) wrote :

Well, with a bit of help from Chris and Sebastien, I found the possible culprit: myself. I must have tried to customise GDM, and this results in a /var/lib/gdm with, er, GDM configuration options.

So. I shot myself. Closing as INVALID, user error.

affects: initramfs-tools (Ubuntu) → gdm (Ubuntu)
Changed in gdm (Ubuntu):
status: New → Invalid
ben (bhaubeck-gmail) wrote :

in my case it happens when i am trying to install it as user root
when upgrading per
"sudo aptitude dist-upgrade" it worked.

Daniel Newman (dmnewman) wrote :

Same bug in my case, but different solution.

The bug appeared when I used "su root" in a terminal, then tried the upgrade using apt-get, synaptic, or dpkg.

However, when I used "sudo dpkg" etc from a user terminal, the installation finished correctly. I didn't need to make any changes to /var/lib/gdm.

dperesse (dperesse) wrote :

Hi
I had the Same bug...

 I was connected with root user (allowroot=true in gdm.conf),
upgrade launched with a : # nohup update-manager -d &

After automatic dpkg at the post installation and a reboot, then ... all upgrade is ok !

I just noticed that in /etc/gdm file gdm.conf was renamed to gdm.conf.dpkg-bak (and -old)
gdm now works without gdm.conf (///=> custom.conf)

ehinmers (hinmerse) wrote :

Same bug in my case, but with "gdm 2.28.0-0ubuntu12".

As other have mentioned, I also performed the apt-get upgrade process as root when this happened.

"dpkg -s gdm" show the status as "install ok installed", but apt.log has the following:

Setting up gdm (2.28.0-0ubuntu12) ...
Installing new version of config file /etc/init/gdm.conf ...
Error setting value: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
dpkg: error processing gdm (--configure):
 subprocess installed post-installation script returned error exit status 1

dn (nobled) on 2009-10-14
Changed in gdm (Ubuntu):
status: Invalid → Confirmed
Shaya Potter (spotter) wrote :

I've been suffering from the same bug for a few weeks. just tried sudo and it configured fine.

probably some weird assumption in the scripts that isn't accurate?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers