Ubuntu

Usplash without progress bar on shutdown.

Reported by exploder on 2008-04-12
40
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Unassigned
Nominated for Hardy by Id2ndR
Nominated for Intrepid by Id2ndR
Nominated for Lucid by Jeetendra Choudhary
Nominated for Maverick by Jeetendra Choudhary

Bug Description

I am running a fully up to date 32 bit version of Hardy, 4/12/08.

When I shut down or restart I get text regarding Network Manager, then the splash appears without a working progress bar.

I can confirm that my screen resolution is correct and that I have the new usplah screen.

On startup the splash and the progress bar work perfectly. I only have the problem with shutdown or restart.

Tom Harris (tom-harris) wrote :

I'm filing this against usplash. Not sure if it's usplash causing the problem but it's the best we can do for now.

exploder (dcosner) wrote :

I discovered that if I change GDM Themes a couple of times that Usplash will work like it is supposed to.

I am wondering if Usplash is being called late, it could be that the network manager errors are asking to be displayed.

This could be a problem with Network Manager or GDM.

exploder (dcosner) wrote :

The problem was with the network-manager package that was updated. Today I tried re-installing network-manager and the problem seems to be resolved. I have asked other user's that were affected by this problem to try re-installing the package and post their results on the development section of the Ubuntu forums.

I will report the results here as this may be just be a flaw in the way the package was updated and may have no effect on a daily build of Hardy.

Zauberlehrling (zauberlehrling) wrote :

I can confirme this.

Changed in usplash:
status: New → Confirmed
Tom Harris (tom-harris) wrote :

Exploder's fix doesn't work for me :(

Tom Harris (tom-harris) wrote :

This only happens for me when using the nvidia driver

Zauberlehrling (zauberlehrling) wrote :

I have still the Bug with Intel-Drivers (X3100) @ Hardy Final!

Please fix this.

exploder (dcosner) wrote :

I installed Hardy final and so far have not had the usplash problem. I noticed that the problem occurred if I closed Evolution and the shut down or restarted. Once the problem has occurred it happens every time the pc is shut down or restarted.

Could Evolution be the cause of this issue?

Tom Harris (tom-harris) wrote :

I doubt it, I've never opened Evolution.

exploder (dcosner) wrote :

I just wondered because I have Hardy loaded on three PC's and the only one that was effected by this problem was the one I was using Evolution on. It could be Network Manager because the first time the bug appeared I was able to reinstall Network Manager to resolve it. Reinstalling Network Manager will not resolve the problem on Hardy final because things were updated.

I am just trying to find out the cause and cure because once the problem appears there is no way to fix it other than reinstalling Hardy.

Tom Harris (tom-harris) wrote :

I reinstalled Hardy and still get this so I'm not sure what the cause is...

exploder (dcosner) wrote :

I also reinstalled on a test machine and had the problem as well. I am sure now that Evolution did not cause the problem, I never used it on the test pc. It must be a problem with Network Manager.

Jonathan Thomas (echidnaman) wrote :

This happens for me with Kubuntu Hardy. I get the same Network manager messages. (And occasionally a Network Manager backtrace)

Id2ndR (id2ndr) wrote :

I tried to remove and reinstall network-manager without improvement.

a$h x (ashxyz) wrote :

This happens on both my ubuntu 8.04 and xubuntu 8.04 installs. It contains the lines dbus init failed, I can confirm it is not related to evolution as I have never used it on either (x)ubuntu. Perhaps it may be related to wireless networking, as looking through my logs I notice network manager has reported an error saying it cannot find any wireless networks. This has been happening no matter what theme I use.

I feel this should be filed against network manager as opposed to usplash as I believe usplash would work correctly if it was not interrupted by the error messages.

exploder (dcosner) wrote :

a$h x, I agree, this does appear to be a Network Manager bug.

Same problem here after a fresh Ubuntu 8.04 install.
And reinstall network-manager doesn't work for me!

  • unnamed Edit (810 bytes, text/html; charset=ISO-8859-1)

Try dowloading the newest upgrade, it helped me.

On Wed, Apr 30, 2008 at 10:44 AM, Johan Van Hellemont <
<email address hidden>> wrote:

> Same problem here after a fresh Ubuntu 8.04 install.
> And reinstall network-manager doesn't work for me!
>
> --
> Usplash problem on shutdown.
> https://bugs.launchpad.net/bugs/216266
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

I have 3 systems that have this bug now. I have every available update, including "proposed" updates. The problem persists.

I fixed this Bug, but I dont know how.

First I installed XFCE4 and xubuntu-desktop, I was testing the xfce-desktop and reboot 4-5 times.
Second I deinstalled XFCE4, xubuntu-desktop and all packages with xfce* in Synaptic.

Now Im using GNome.

Thats all.

exploder (dcosner) wrote :

I applied all of the Hardy updates 05/06/08 and the Network Manager errors are gone and the Usplash is working on shutdown and re-start! I have re-booted the pc several times with no problems.

I do not know the specific package that fixed this, but it is nice to see things are looking good! Hopefully the problem will not return.

Can anyone else confirm this? Also, does anyone know the specific package that resolved this?

I can confirm this (Hardy 64 Bit).

exploder:

I've done all of the updates to Hardy and I can't report the positive outcome that you have. This bug seems rather elusive but not uncommon. I've read multiple threads on ubuntuforums.org which report the same issue.

There's a bunch of people that I would like to upgrade to Hardy but I simply can't because I will get numerous calls about their system being "broken" if they see this crap every time they shutdown their computer.

Even if there was a workaround, I could live with that. But I've tried a few proposed methods to eradicate this issue and nothing has helped.

I found a workaround! (courtesy of prinknash on ubuntuforums)

Follow it word for word (cut the text.. Apply command change.. paste the text.. Apply command change)

1. Go to System - Administration - Login Window.

2. Under 'General', press "Edit commands ...'

3. Select 'Halt command' - in 'Path' box, cut the text in quotes (I.e. "Shut down via gdm") - press "Apply command change" - paste the text back - press 'Apply command change'

4. Select 'Reboot command' and do as for 3. above

Try restarting a couple of times and see if this has fixed the problem.
Apparently this has fixed the problem for numerous people who have the boot splash but no shutdown splash.
Now, could the solution/workaround give us a possible avenue to explore which might lead to a fix?

I think this makes my first presumption correct. The networkmanager bug has nothing to do with this at all. It's GDM not hiding the error.

Darryl Grennan a écrit :
> I found a workaround! (courtesy of prinknash on ubuntuforums)
>
> Follow it word for word (cut the text.. Apply command change.. paste
> the text.. Apply command change)
>
> 1. Go to System - Administration - Login Window.
>
> 2. Under 'General', press "Edit commands ...'
>
> 3. Select 'Halt command' - in 'Path' box, cut the text in quotes (I.e.
> "Shut down via gdm") - press "Apply command change" - paste the text
> back - press 'Apply command change'
>
> 4. Select 'Reboot command' and do as for 3. above
>
> Try restarting a couple of times and see if this has fixed the problem.
> Apparently this has fixed the problem for numerous people who have the boot splash but no shutdown splash.
>

I only tried it one time til now but it works :). I'll do a diff with
the gdm conf file I have on my second computer which have the trouble too.

Tom Harris (tom-harris) wrote :

I didn't even change the config, just opening and closing the options window once fixed it for me. Almost certainly a gdm bug (seems more likely than usplash anyway), remarking as such.

Id2ndR (id2ndr) wrote :

I confirm the fact that opening gdmsetup fix the trouble.

I've done a diff of the old files, and there are 3 empty line removed.

What generates the gdm.conf-custom when installing Ubuntu?

Sebastien Bacher (seb128) wrote :

there is no real reasons why whitespace changes should make a difference there

Changed in gdm:
importance: Undecided → Low
Id2ndR (id2ndr) wrote :

I've done diff on gdm.conf and gdm.conf-custom files only. There is no differences in gdm.conf but there is these empty lines in gdm.conf-custom.
So if someone who still have the bug can try to edit gdm.conf-custom, remove these 3 lines (if they exist) and test it, it whould be helpfull.

I'll also try to revert the diff (adding empty lines) to see if the bug reappears. If it doesn't, there may be others files impacted by the act of running gdmsetup.

Id2ndR (id2ndr) wrote :

I revert the diff (in fact by removing 3 empty lines, no adding these, I was wrong), and usplash bar was still here. So there should be other files impacted.

Id2ndR (id2ndr) wrote :

In fact the bug reappears at next reboot (after removing 3 empty lines).

I tried again by adding 3 empty line between [greeter] and [chooser] in gdm.conf-custom and the bug disappears again. Someone may confirm this behavior.

Sebastien Bacher (seb128) wrote :

could you try if the 2.20.6 update fix the issue?

I have a similar issue. I have a Compaq Presario F730 running with Athlon X2 64-bit with nVidia 6100 graphics, those that need the restricted drivers to run compiz fusion and stuff. When i installed a fresh copy of Ubuntu Hardy (64 bit version) the boot and shutdown usplash were fine. I remember that when i installed restricted drivers for nVidia cards, the "newer", the boot splash was fine, but the shutdown were missing. Instead of it, i got horizontal random lines changing fast, it freaked me out because i thought there was something really wrong with the shutdown. But the machine turned off as expected and i kept cool. The thing is that it is sort of disturbing having all that lines changing fast and randomly. I also changed the boot splash to none, and enabled the verbose mode for booting. It works for booting, like debian etch, but still can't see the text in shuting down... so i think that is some trouble with nNidia drivers and i don't know how much can be done since the drivers are restricted.

Regards,

Santiago Roland.-

Id2ndR (id2ndr) wrote :

I see an other computer with the trouble and gdm 2.20.6.
Adding 3 empty lines fixes the trouble without doing anything else.

Tang (robertmcgreg) wrote :

 Darryl Grennan wrote on 2008-05-12
After completely reinstalling, then opening and closing System/Login Window without success, I finally followed those instructions you discovered. Now my Hardy for AMD 64 shuts down cleanly and fast at least.
Thank you, Darryl

johanden.se (johanden) wrote :

I'm on Kubuntu Hardy fresh install and are experiences the same issue.
I've found a thread that suggested to remove the "- i" parameter in halt -d -f -i $poweroff $hddown . Tried that without any luck.
Issue remains at least for me on Kubunty Hardy (I didn't have this issue on Gutsy).

Here, with Ubuntu 8.04 up to date, problem occours after change gdm theme (gdmsetup). If I reinstall gdm and ubuntu-gdm-themes, the usplash work ok with progress bar e no Network Manager erros on shutdown. This until next theme change.....

exzemat (exzemat) wrote :

(i'm french)
i have the same probleme whith the progress bar at shutdown
i haven't the begins of the progress bar : just the name of services which shutdown as :

          "preload........[OK]"
           "gnome.........[OK]"

no one [failed]
i have disable network manager 2 weeks ago (manual configuration)

i add 3 empty line in
/etc/gdm/gdm.conf-custom after [greeter] and after [chooser]

reboot and now everything is allright

Dr. W.J.W. Hanna (wjwhanna) wrote :

Excemat wrote:

<i add 3 empty line in
/etc/gdm/gdm.conf-custom after [greeter] and after [chooser]

reboot and now everything is allright>

I have tried this but completely without success. in fact, I have tried various combinations of adding and removing three blank lines with the same success - absolutely none! In fact, it seems to me as if there are already far too many blank lines in my gdm.conf-custom file! If there is anyone who would like to look at it and see if he or she can spot an error, here it is (and, Yes, there really are all those blank lines without my doing anything to it!):

[daemon]

AutomaticLogin=<user name>

HaltCommand=/sbin/shutdown -h now "Shut Down via gdm."

RebootCommand=/sbin/shutdown -r now "Reboot via gdm."

AutomaticLoginEnable=true

[security]

[xdmcp]

[gui]

GtkRC=

[greeter]

DefaultFace=

GlobalFaceDir=/usr/share/pixmaps/

GraphicalThemes=Human/:circles/:happygnome

[chooser]

[debug]

[servers]

Dr. W.J.W. Hanna (wjwhanna) wrote :

I see that all the blank lines in my gdm.conf-custom file were removed when this comment was posted. In an attempt to get them right I have now attached the copy of the file as a text document.

Matt Zimmerman (mdz) wrote :

This sounds like gdm is not invoking usplash_down in all cases.

Id2ndR (id2ndr) wrote :

The behavior changed in Intrepid, but it's not good so far.

Now, each time you launch gdmsetup, it will add 3 empty line more into /etc/gdm/gdm.conf-custom beetween current GraphicalTheme directive and [chooser]. Consequently usplash disappear at shutdown when it was OK.

By the way it seams that it needs to have only one empty line between each non empty line to get usplash working correctly in Intrepid.

Id2ndR (id2ndr) wrote :

Sorry for my previous comment : it's not really exact. In fact usplash sometime appears, sometime doesn't, with the same gdm custo conf file.
Bug #264696 takes care of the real problem.

Julian Alarcon (alarconj) wrote :

I'm using Intrepid, with all the updates, and the problem has gone!!!
But, it's better that many of us confirm that.

Id2ndR (id2ndr) wrote :

I confirm the bug is fixed in intrepid, so I'm marking it as this.

Changed in gdm:
status: Confirmed → Fix Released
Dr. W.J.W. Hanna (wjwhanna) wrote :

"I confirm the bug is fixed in intrepid, so I'm marking it as this."

That's all very well, but this bug report was filed concerning Ubuntu 8.04 - Half-baked Heron - so why has a patch not been released to correct it in that release, which, after, is a Long Term Support release? Where is the Long Term Support, if bugs like this only are corrected in a later, Short Term Support, release?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers