ImportError: cannot import name 'ki18n' when launching gdebi-kde

Bug #1304143 reported by Isaac Mercer on 2014-04-08
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdebi (Debian)
Fix Released
Unknown
gdebi (Ubuntu)
High
Unassigned
Trusty
High
Brian Murray

Bug Description

On Ubuntu 14.04 when I launch gdebi-kde I get the following stacktrace message:

Traceback (most recent call last):
  File "/usr/bin/gdebi-kde", line 27, in <module>
    from PyKDE4.kdeui import KApplication, KMessageBox, ki18n
ImportError: cannot import name 'ki18n'

I am using gdebi 0.9.5.2

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue and help making Ubuntu better.

I get the same error message when attempting to start gdebi-kde 0.9.5.3 on Ubuntu Trusty.

Changed in gdebi (Ubuntu):
status: New → Confirmed
tags: added: trusty
Hugo Piquer (hugopiquer) wrote :

Here the same error, i'm using gdebi-kde 0.9.5.3 on Kubuntu Trusty:

File "/usr/bin/gdebi-kde", line 27, in <module>
    from PyKDE4.kdeui import KApplication, KMessageBox, ki18n
ImportError: cannot import name 'ki18n'

I've installed/reinstalled all dependencies (https://launchpad.net/ubuntu/trusty/+source/gdebi), and always the same error.

Hugo Piquer (hugopiquer) wrote :

Problem with python3 internalization.

Patches from Michael Werle to solve the problem here:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743756

Patches tested, no more error messages and gdebi works.

Patches fix:
For gdebi-kde:
* Fix ki18n import: from kdeui to kdecore
* Replace ugettext with gettext
* Pass bytes rather than strings to ki18n

For GDebi/GDebiKDE.py:
*replace QStringList with list
*replace string operations with str

Thanks to Michael Werle.

Luca Falavigna (dktrkranz) wrote :
Changed in gdebi (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Changed in gdebi (Debian):
status: Unknown → Fix Committed
Changed in gdebi (Debian):
status: Fix Committed → Fix Released
Isaac Mercer (nos-developer) wrote :

For Ubuntu Users I have just built some .deb packages. Unfortunitley they are not in a PPA yet

Isaac Mercer (nos-developer) wrote :
Isaac Mercer (nos-developer) wrote :
  • gdebi Edit (38.9 KiB, application/x-debian-package)
Isaac Mercer (nos-developer) wrote :

Here is the source code

The attachment "gdebi-kde" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.4

---------------
gdebi (0.9.5.4) unstable; urgency=low

  [ Michael Vogt ]
  * fix installing of dependency packages when called with sudo
    (LP: #1309387)

  [ Michael Werle ]
  * gdebi-kde, GDebi/GDebiKDE.py:
    - Fix python3 internatlization bugs (Closes: #743756) (LP: #1304143).

  [ Luca Falavigna ]
  * Fix tests at build time (Closes: #743091).

 -- Luca Falavigna <email address hidden> Tue, 22 Apr 2014 10:54:48 +0200

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
Isaac Mercer (nos-developer) wrote :

This package does not seem to be in the Ubuntu repository. Marking as Fix Committed.

Changed in gdebi (Ubuntu):
status: Fix Released → Fix Committed
Luca Falavigna (dktrkranz) wrote :

Actually it is, but in 14.10 only.

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
Isaac Mercer (nos-developer) wrote :

Technically Speaking this bug isn't fixed until it is backported to trusty as I reported it in trusty. I will work on uploading it to a PPA.

Changed in gdebi (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
milestone: none → trusty-updates
Changed in gdebi (Ubuntu Trusty):
status: Triaged → Fix Committed
Brian Murray (brian-murray) wrote :

For the trusty task to be fix committed a package fixing the bug should be available in the -proposed repository for that release. This is not the case for this bug.

Changed in gdebi (Ubuntu Trusty):
status: Fix Committed → In Progress
assignee: nobody → Brian Murray (brian-murray)
Isaac Mercer (nos-developer) wrote :

Thanks for clarifing that Brian

Hello nOSinfinite, or anyone else affected,

Accepted gdebi into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gdebi/0.9.5.3ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gdebi (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
AZ (m-dev) wrote :

gdebi_0.9.5.3ubuntu2_all.deb gdebi-core_0.9.5.3ubuntu2_all.deb gdebi-kde_0.9.5.3ubuntu2_all.deb from trusty-proposed fixed the issue for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.3ubuntu2

---------------
gdebi (0.9.5.3ubuntu2) trusty-proposed; urgency=medium

  [ Michael Werle ]
  * gdebi-kde, GDebi/GDebiKDE.py:
    - Fix python3 internatlization bugs (Closes: #743756) (LP: #1304143).
 -- Brian Murray <email address hidden> Thu, 01 May 2014 09:08:06 -0700

Changed in gdebi (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gdebi has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.