GDebi isn't localized in Ubuntu 14.04: gdebi-core package is missing /usr/share/locale directory

Bug #1288258 reported by Pjotr12345
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Low
Unassigned

Bug Description

When I install GDebi 0.9.3 in a Dutch localized and fully updated Xubuntu 14.04, GDebi is 100 % in English.

But it should be 100 % Dutch, as the Dutch translation for GDebi on Launchpad, was completed over a year ago.

affects: ubuntu → gdebi (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
Revision history for this message
Vlad Orlov (monsta) wrote : Re: GDebi isn't localized in Xubuntu 14.04: gdebi-core package is missing /usr/share/locale directory

It turned out that gdebi-core package is missing /usr/share/locale directory (which was there in Ubuntu 13.10).

summary: - GDebi isn't localized in Xubuntu 14.04
+ GDebi isn't localized in Xubuntu 14.04: gdebi-core package is missing
+ /usr/share/locale directory
summary: - GDebi isn't localized in Xubuntu 14.04: gdebi-core package is missing
+ GDebi isn't localized in Ubuntu 14.04: gdebi-core package is missing
/usr/share/locale directory
Revision history for this message
Vlad Orlov (monsta) wrote :

This must be some issue during the package building here at Canonical.

Because I've downloaded the source, rebuilt it, and /usr/share/locale was there. I've installed the rebuilt packages and voila - I have the localized versions of both gdebi and gdebi-gtk.

Revision history for this message
Yanpas (yanpaso) wrote :

@monsta-mint Yes, problem must be with Canonical. Because similar problem happened for nemo file manager and some other apps too

Vlad Orlov (monsta)
tags: added: l10n trusty
removed: gdebi locale localization translated translation
Revision history for this message
Jung-Kyu Park (bagjunggyu) wrote :

I think , it might be dropped on purpose.
http://packages.ubuntu.com/trusty/all/language-pack-ko-base/filelist

because, Seemingly, Ubuntu want users to use software center instead of other utility like gdebi.
but, we, most of users still need this gdebi.
actullay, it accurred lack of translation file gdebi.mo in other Ubuntu based OSes , Linux MInt , elementary OS.....
and we have met this situation until now.

We need gdebi.mo in language-pack-gnome -##

Revision history for this message
Sebastien Bacher (seb128) wrote :

That gdebi translations are in the base languagepack. Do you have the langpack for the locale you are using installed?

Changed in gdebi (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
Jung-Kyu Park (bagjunggyu) wrote :

Yes , I have already installed language-pack-gnome-ko
actually, gdebi.mo is missed as you can see it in this link
http://packages.ubuntu.com/trusty/all/language-pack-ko-base/filelist

and, also, There is no gdebi.mo file at /usr/share/locale/ko/LC_MESSAGES

Revision history for this message
Jung-Kyu Park (bagjunggyu) wrote :
Changed in gdebi (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Vlad Orlov (monsta) wrote :

Seems to be fine now. Apparently it had been fixed with the updates of all language-pack-xx-base packages to version 1:14.04+20160720. I see gdebi.mo is included there now.

Changed in gdebi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers