The "Access Prompt" randomly pop up!

Bug #1044549 reported by Adrián on 2012-08-31
276
This bug affects 59 people
Affects Status Importance Assigned to Milestone
gcr (Ubuntu)
High
Unassigned

Bug Description

Access Prompt randomly pop up and prompt you for the password. Have you ever when opened Youtube, Facebook, Launchpad account!n And now opened a picture of the computer when pop up"Access Prompt"
I use autologin.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gcr 3.5.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Fri Aug 31 22:33:44 2012
ExecutablePath: /usr/lib/gcr/gcr-prompter
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
SourcePackage: gcr
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors:
 (gnome-settings-daemon:1401): libappindicator-WARNING **: Unable to connect to the Notification Watcher: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.48 was not provided by any .service files
 (gnome-control-center:2016): background-cc-panel-WARNING **: Could not load /usr/share/themes/Adwaita/index.theme: Nincs ilyen fájl vagy könyvtár
 (gnome-control-center:2016): GLib-GIO-CRITICAL **: g_settings_set_value: assertion `G_IS_SETTINGS (settings)' failed
 (gnome-control-center:2016): Gtk-CRITICAL **: gtk_builder_get_object: assertion `GTK_IS_BUILDER (builder)' failed
 (gnome-control-center:2016): Gtk-CRITICAL **: gtk_icon_view_get_selected_items: assertion `GTK_IS_ICON_VIEW (icon_view)' failed

Adrián (jaksi) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcr (Ubuntu):
status: New → Confirmed
sl45sms (sl45sms) wrote :

After upgrade from 12.04 gcr-prompter ask for my email password on every login...

Dawid Wróbel (dawidw) wrote :

It's gotten worse now, it pops up continuously even if you close the dialog and, even worse, it locks the focus so you can't switch to the other window. I had to switch to tty console and kill it from there to be able to regain the control over the desktop.

Also it looks very dodgy when it shows up just like this out of nowhere. It has no explanation whatsoever about the reason for asking the password and which application is the real requester. It's just suspicious.

I also use autologin if that's relevant.

Reece (reece) wrote :

Also affects me. 12.10, upgraded from 12.04.

I'm not using autologin.

I can't tell who's asking or why. (gwibber?)

Rex Mundi (service-redterra) wrote :

Agree with dawidw, it looks very dodgy when it appears with no reference to why or what is requesting the credentials.

Extender (msveshnikov) wrote :

Same here. Please tell me what package to remove to ged rid of it?

Mark Rowan (mark-tamias) wrote :

The prompt appears every time I start Ubuntu 12.10 as well. Leaving it running steals all focus from the desktop, and uses a lot of CPU. I use fprint to log in using a fingerprint reader on my Thinkpad, if that's relevant.

Mark Rowan (mark-tamias) wrote :

Seems to have been reported here as well, specifically in the context of Ubuntu One client: https://bugs.launchpad.net/ubuntuone-client/+bug/1074233

I used Wireshark to find out which website was connected during authentication, it was Google. I have 2-factor authentication turned on, so my "normal" Google password wasn't accepted by the dialog. I generated a new account specific password, which was accepted.

Hope this helps others...

Mark Rowan (mark-tamias) wrote :

Bert: I don't understand how changing a password at Google will solve the problem -- could you explain, please? Are you talking about the sign-ins as part of Desktop Integration (in Online Accounts settings)?

tkoopa (tkoopa) wrote :

Same problem here, it pops up here every five minutes even after having removed/added google account with two factor verification ( 12.10 upgrade from 12.04 ).

Phillip Susi (psusi) wrote :

I have not done anything with google or two factor authentication. This popup keeps happening even when I don't seem to have anything open and it won't accept my password. The fact that it somehow prevents you from typing in another window, especially when you were in the middle of doing that when it poped up is *extremely* annoying, as is the fact that it pops up 3 times each time you try to cancel it before it finally goes away.

Changed in gcr (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Mathieu SENSEI (hyu9a) wrote :

I had the same issue.
I cleared all my Gnome Online Accounts. Pupup was still annoying me every 5 min.
After searching in my home directory, I found this file ~/.config/goa-1.0/accounts.conf still containing my gmail address :

[Account account_0123456789]
Provider=google
Identity=<my_address>@gmail.com
PresentationIdentity=<my_address>@gmail.com
MailEnabled=true
CalendarEnabled=true
ContactsEnabled=true
ChatEnabled=false
DocumentsEnabled=true

Removing this file fixed the problem for me.

Hoping it will help !

Mark Rowan (mark-tamias) wrote :

Thanks Mathieu -- renaming this file appears to have resolved the issue for me as well, without causing any noticeable problems. What is this file for, and why does its presence cause this issue, I wonder?

Dawid Wróbel (dawidw) wrote :

Mathieu, Mark - did you by any chance have Google account configured in previous distribution releases that you upgraded from? It did not provide much integration with the system but I had it configured nonetheless. It could be that the accounts were stored differently previously and this would explain why was the ~/.config/goa-1.0/accounts.conf file still present after deleting all the Google accounts in "Online Accounts" dialog.

Mark Rowan (mark-tamias) wrote :

Dawid -- yes, that could be it. I definitely added my Google account info in Ubuntu 12.04, even though there wasn't much integration.

This problem started for me after upgrading to 12.10. Removing the ~/.config/goa-1.0/accounts.conf file fixed it.

Robert Bruce Park (robru) wrote :

Was experiencing this with raring, and then I just updated to Saucy and got bit by this again... just tried deleting that accounts.conf file, hopefully that stops it...

Silas Arn (silas89) wrote :

I have the same problem. I think, it's only with Google and in my case i think it's because I've activated 2-way-authentification (After Login with Password I recieve a SMS with a Code which I have to enter).

ferrouswheel (joel-pitt) wrote :

Same problem here.

Added Google account in 12.04 even though it was mostly unused. On upgrade I got these annoying and unlabelled (!) requests for a password... I couldn't even determine which account it was for because it only displayed an email address.

The solution here seems to do the trick https://bugs.launchpad.net/ubuntu/+source/gcr/+bug/1044549/comments/14

Giulio Bonanome (gbonanome) wrote :

Same problem here on Ubuntu 13.10.
Also for me renaming the file ~/.config/goa-1.0/accounts.conf solved the problem (see https://bugs.launchpad.net/ubuntu/+source/gcr/+bug/1044549/comments/14).

alcachi (alcachi) wrote :

The accounts.conf file is also used by the new Ubuntu online accounts configuration. The problem seems to be that after an upgrade the old entry from the original Gnome online accounts application is left. The new online accounts utility adds entries after the previous one which is the one causing the problem.

This is the old entry in my case:

[Account account_1388648527]
Provider=google
<email address hidden>
<email address hidden>
MailEnabled=true
CalendarEnabled=true
ContactsEnabled=true
ChatEnabled=true
DocumentsEnabled=true

Just editing the accounts.conf file and removing just this entry solved the problem. If you remove the file you will have to rerun the new online accounts application in order to recreate your new configuration.

Shahar Or (mightyiam) wrote :

Wow, @alcachi. Thanks.

What's the full path to this file, please?

@alcachi: Thanks, it helps. :-)
@Shahar: /home/user/.config/goa-1.0/accounts.config

user: Your username.

Fred Béland (rockonfred) wrote :

If the prompt is caused by a google online account with dual factor authentication and you want to maintain the goa functionality, you can set an App Password in your google account settings and enter it at the prompt. This avoids having to delete the accounts.conf file.

This solution solved my issue on Linux Mint 17.3; my Evolution is set up to use the gnome online accounts for imap functionality.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers