gcompris is not launching through applications menu

Bug #789372 reported by Julien on 2011-05-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gcompris (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

Binary package hint: gcompris

Since I have upgraded from Maverick to Natty, it is not possible to launch gcompris from the applications menu (under gnome) anymore. It works if I run it from the terminal. I can do it but it is a little bit difficult for my daughter...

$ gcompris &
** Message: Binary relocation disabled

** (process:3620): WARNING **: exec_prefix NONE

package_data_dir = /usr/share/gcompris/boards
package_skin_dir = /usr/share/gcompris/boards/skins
package_menu_dir = /usr/share/gcompris/boards
package_locale_dir = /usr/share/locale
package_plugin_dir = /usr/lib/gcompris
package_python_plugin_dir= /usr/share/gcompris/python
Infos:
   Config dir '/home/julien/.config/gcompris'
   Users dir '/home/julien/My GCompris'
   Database '/home/julien/.config/gcompris/gcompris_sqlite.db'

(gcompris:3620): Gtk-CRITICAL **: IA__gtk_window_set_type_hint: assertion `!gtk_widget_get_mapped (GTK_WIDGET (window))' failed

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gcompris 9.3-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sat May 28 00:09:50 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gcompris
UpgradeStatus: Upgraded to natty on 2011-04-30 (27 days ago)

Julien (jcanivet) wrote :
John Kerenyi (jkerenyi123) wrote :

Same for me, except launching from command line has exactly the same effect (i.e. failure to launch). The Gtk error message is the same. My system is a Dell Latitude D600 laptop and I upgraded from 10.10 (gcompris worked) to 11.04 (now not working).

Paul Stewart (paulbrianstewart) wrote :

Hi Julien and John,

What happens if you go to the ubuntu software centre, uninstall the application, reboot and then reinstall?

I have just loaded the app through the ubuntu software centre and it is working for me. I am also using Ubuntu 11.04 64bit version on a HP G62 laptop.

Hope this might help.
Cheers
Paul Stewart

Mantas Kriaučiūnas (mantas) wrote :

New version of GCompris (9.6.1) soon will be packaged in official Baltix GNU/Linux repository:
https://launchpad.net/~baltix-members/+archive
(I'm waiting while bug #832011 will be fixed)
It's interesting if this bug is fixed in new Gcompris 9.6.1 package...

Rolf Leggewie (r0lf) wrote :

does this ever occur in trusty or later?

Changed in gcompris (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: New → Incomplete
Julien (jcanivet) wrote :

No it does not occur in 14.04

Rolf Leggewie (r0lf) on 2017-01-06
Changed in gcompris (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers