does not honor LC_MESSAGES

Bug #1404947 reported by Rolf Leggewie on 2014-12-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcompris
Invalid
Medium
gcompris (Ubuntu)
Low
Unassigned
Nominated for Trusty by Rolf Leggewie

Bug Description

LC_ALL="" LANG=de_DE.UTF-8 LC_MESSAGES=C gcompris

that should run the standard english version of the program interface but in fact the German version is shown. Check "man 7 locale" for the hierarchy of locale-related environment variables.

(Bug forwarded from Launchpad, https://bugs.launchpad.net/bugs/1404947)

LC_ALL="" LANG=de_DE.UTF-8 LC_MESSAGES=C gcompris

that should run the standard english version of the program interface but in fact the German version is shown. Check "man 7 locale" for the hierarchy of locale-related environment variables.

This happens on Ubuntu as well on Debian, both with the packaged versions and freshly compiled sources.

Reproducible: Always

Steps to Reproduce:
1. Start with "LC_ALL="" LANG=de_DE.UTF-8 LC_MESSAGES=C gcompris"

Actual Results:
Starts with german interface

Expected Results:
Starts with english interface

Andreas Moog (ampelbein) wrote :

I can confirm the issue on Debian, even when using the current version freshly compiled. I opened a bug report in the Upstream tracker about it.

Changed in gcompris (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Bruno coudoin (bruno-coudoin) wrote :

In GCompris there is a configuration dialog allowing the user to select a locale. This is usefull to let a user set a target language instead of his desktop one. When GCompris is set as 'use your system locale' then we respect the environment values.

Please check your GCompris configuration and close the bug if it is not set to default.

Changed in gcompris:
importance: Unknown → Medium
status: Unknown → New
Bruno coudoin (bruno-coudoin) wrote :

I just tested again and this is not a bug, it's a feature. When GCompris is set to the system locale it respects the LANG env variable.

I just tested again and this is not a bug, it's a feature. When GCompris is set to the system locale it respects the LANG env variable. And BTW this is releated to the Gtk+ version, not the Qt one.

Rolf Leggewie (r0lf) wrote :

I don't remember changing anything, so possibly gcompris is not set to use system locale by default. I cannot test this right now.

On 05.03.2015 07:21, Bruno coudoin wrote:
> I just tested again and this is not a bug, it's a feature. When GCompris
> is set to the system locale it respects the LANG env variable.

Bruno, you are mistaken.

Yes, gcompris might respect the LANG variable - but then it ignores the
LC_MESSAGES variable. This is the bug, since LC_MESSAGES has higher
priority than LANG. Check "man 7 locale".

'LC_ALL="" LANG=de_DE.UTF-8 LC_MESSAGES=C gcompris' should start in
English, not in German.

Changed in gcompris:
status: New → Invalid
Rolf Leggewie (r0lf) wrote :

Bruno, please reopen the upstream ticket. Thank you.

Bruno coudoin (bruno-coudoin) wrote :

I thing I got the issue now and pushed a fix in master.

Rolf Leggewie (r0lf) wrote :
Rolf Leggewie (r0lf) wrote :
Rolf Leggewie (r0lf) wrote :

I am on a slow and expensive link at the moment and gcompris source is huge, so the following patch is provided untested (like the previous one for vivid)

PS: I like a version of 13.11-1trusty1 as it is concise, informative and will work with the versions present in trusty, utopic and vivid.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcompris - 14.12-1ubuntu1

---------------
gcompris (14.12-1ubuntu1) vivid; urgency=medium

  * patches: backport upstream commit e93dccbd43217 to respect the
    hierarchy of locale variables. LP: #1404947
    Many thanks to Bruno Coudoin from upstream for providing the patch
 -- Rolf Leggewie <email address hidden> Wed, 11 Mar 2015 12:58:42 +0800

Changed in gcompris (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.