Ubuntu

Cannot load AWT toolkit

Reported by Nikolaus Rath on 2007-03-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcj-4.1 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gcj-4.1

[0] nokile:~$ gij-4.1 -jar lib/JFLAP.jar
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at javax.swing.JFrame.<init>(libgcj.so.70)
   at gui.action.NewAction$NewDialog.<init>(NewAction.java:110)
   at gui.action.NewAction.showNew(NewAction.java:79)
   at JFLAP.main(JFLAP.java:115)
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory
   at java.lang.Runtime._load(libgcj.so.70)
   at java.lang.Runtime.loadLibrary(libgcj.so.70)
   at java.lang.System.loadLibrary(libgcj.so.70)
   at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.70)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...7 more

[1] nokile:~$ locate libgtkpeer.so
/usr/lib/classpath/libgtkpeer.so

[0] nokile:~$ dpkg -S libgtkpeer.so
classpath-gtkpeer: /usr/lib/classpath/libgtkpeer.so

[0] nokile:~$ dpkg -s classpath-gtkpeer | grep Status
Status: install ok installed

Matthias Klose (doko) wrote :

known; please install the libgcj7-awt package (which is recommended by gij, gij-4.1 and java-gcj-compat).

Changed in gcj-4.1:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Matthias Klose (doko) wrote :

now fixed in karmic/lucid using the gcj-jre/gcj-4.4-jre package

Changed in gcj-4.1 (Ubuntu):
status: Confirmed → Fix Released
Peter Schüller (schueller-p) wrote :

I wanted to use pdfsam, this installed and caused the same problem.

I then installed classpath-gtkpeer but still the same problem.

Then I manually had to select gcj-jre package.

Is this really solved?

In my opinion classpath-gtkpeer should depend on some feature that is provided by gcj-jre or something like that.

I'm using lucid.

Qoya (qoyajunk) wrote :

Thank you Matthias, worked for me with libgcj12-awt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers