[armel/armhf] file fails to compile (indefinite loop?)

Bug #903347 reported by Matthias Klose on 2011-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro GCC
Won't Fix
Medium
Michael Collison
gcc-4.6 (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
poco (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

the compile doesn't terminate, at least after 800min on a beagle board,

g++ -c -O2 doesn't terminate, -O0 does.

both seen with 4.5 and 4.6 branches

Related branches

Matthias Klose (doko) wrote :
Michael Hope (michaelh1) wrote :

I see similar with gcc-linaro-4.6-2011.11 on a Panda. ~520 MB of memory. I killed it after 50 minutes.

Note that a -O0 build takes 27 s.

Matthias Klose (doko) on 2011-12-12
Changed in poco (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-1
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poco - 1.3.6p1-1ubuntu3

---------------
poco (1.3.6p1-1ubuntu3) precise; urgency=low

  * Build ODBC and MySQL tests with -O0 to work-around GCC issue
    on ARM. LP: #903347.
 -- Matthias Klose <email address hidden> Mon, 12 Dec 2011 23:44:03 +0100

Changed in poco (Ubuntu Precise):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

just a work-around for poco, re-opening the poco task, and removing the milestone

Changed in poco (Ubuntu Precise):
importance: High → Medium
milestone: ubuntu-12.04-beta-1 → none
status: Fix Released → Triaged
tags: added: gcc workaround
Michael Hope (michaelh1) wrote :

Occurs on cross. The backtrace with an x86_64 host against the gcc-linaro-4.6-2011.12 release is:

#0 0x082c21f1 in update_bb_for_insn_chain ()
#1 0x082c2246 in update_bb_for_insn ()
#2 0x082c1b17 in create_basic_block_structure ()
#3 0x082c1c39 in rtl_create_basic_block ()
#4 0x082b3a6b in create_basic_block ()
#5 0x082c23ba in rtl_split_block ()
#6 0x082b342f in split_block ()
#7 0x089f527b in find_bb_boundaries ()
#8 0x089f5878 in find_many_sub_basic_blocks ()
#9 0x082b2026 in gimple_expand_cfg ()
#10 0x0849347a in execute_one_pass ()
#11 0x08493755 in execute_pass_list ()
#12 0x085b7f62 in tree_rest_of_compilation ()
#13 0x0875887e in cgraph_expand_function ()
#14 0x08758a32 in cgraph_expand_all_functions ()
#15 0x087590a7 in cgraph_optimize ()
#16 0x0875735b in cgraph_finalize_compilation_unit ()
#17 0x08176897 in cp_write_global_declarations ()
#18 0x0855e546 in compile_file ()
#19 0x0856043c in do_compile ()
#20 0x08560587 in toplev_main ()
#21 0x08260c66 in main ()

It seems to be stuck in update_bb_for_insn_chain()

Michael Hope (michaelh1) on 2012-01-06
Changed in gcc-linaro:
status: New → Triaged
importance: Undecided → Medium
Julian Taylor (jtaylor) wrote :

seems to be fixed quantals gcc, both poco arm builds succeeded today without the patch

Changed in poco (Ubuntu):
status: Triaged → Fix Released

Will not fix for older releases. Unable to reproduce on linaro 4.8 or 4.9.

Changed in gcc-linaro:
assignee: nobody → Michael Collison (michael-collison)
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers