Sync gcc-3.3 1:3.3.6ds1-20 (universe) from Debian unstable (main)

Bug #598854 reported by Felix Geyer on 2010-06-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gcc-3.3 (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync gcc-3.3 1:3.3.6ds1-20 (universe) from Debian unstable (main)

gcc-3.3 has been reintroduced into Debian and provides the binary package
libstdc++5 which is still needed by some applications.
See bug #431091, bug #441358 and bug #436886.

Felix Geyer (debfx) on 2010-06-26
affects: ubuntu → gcc-3.3 (Ubuntu)
Changed in gcc-3.3 (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
status: New → In Progress
Stefano Rivera (stefanor) wrote :

Sync request ACK'd

Probably also worth backporting to lucid. The kind of people who want this are likely to prefer LTSs.

Changed in gcc-3.3 (Ubuntu):
assignee: Stefano Rivera (stefanor) → nobody
importance: Undecided → Wishlist
status: In Progress → Confirmed
tags: added: sync
Changed in gcc-3.3 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (156.5 KiB)

This bug was fixed in the package gcc-3.3 - 1:3.3.6ds1-20

---------------
gcc-3.3 (1:3.3.6ds1-20) unstable; urgency=low

  * rules.defs: Set GFDL_INVARIANT_FREE unconditionally to `yes'.
    (Closes: #586011)

gcc-3.3 (1:3.3.6ds1-19) unstable; urgency=low

  * New maintainer.
  * Reintroduce the package into Debian unstable to be released with
    Debian squeeze.
  * Build with gcc-4.1 instead of gcc-3.4 because the latter is no longer
    available.
  * Add symbol files as generated by mole for amd64, i386 and powerpc.
  * Drop lpia for missing symbol files.

gcc-3.3 (1:3.3.6ds1-18) unstable; urgency=low

  * Build libstdc++5 on powerpc again, needed by some JVM's.
  * Remove build dependency on expect-tcl8.3 (package is not built anymore
    on hppa). Closes: #472984.

gcc-3.3 (1:3.3.6ds1-17) unstable; urgency=low

  * libstdc++5: Remove dependency on gcc-3.3-base. Closes: #473366.

gcc-3.3 (1:3.3.6ds1-16) unstable; urgency=low

  * Don't build compiler packages from the gcc-3.3 source. The only package
    built is libstdc++5 (amd64, i386).
  * Build-depend on gcc-3.4 instead of gcc-3.3.

gcc-3.3 (1:3.3.6ds1-15) unstable; urgency=medium

  * Fix biarch related build failure on s390.
  * Don't build the gcc-3.3-hppa64 package on hppa.

gcc-3.3 (1:3.3.6ds1-14) unstable; urgency=low

  * Build without GFDL licensed docs. Closes: #193787.
    - debian/*.texi, debian/porting.html: Add dummy documentation.
    - debian/rules.unpack, debian/rules.patch: Update for non-gfdl build.
  * Don't build cpp-3.3-doc, gcc-3.3-doc, packages.
  * Merge from Ubuntu:
    - Backport the biarch-include patches from gcc-3.4,
      adding /usr/include/<target_alias> to the standard include path.
      Fixes build failure on sparc.
    - Remove the multilib part from the multiarch-include patch.
  * libgcc1: Provide libgcc1-TARGET-dcv1 when cross-compiling (Pjotr
    Kourzanov). Closes: #357629.

gcc-3.3 (1:3.3.6-13) unstable; urgency=low

  * Remove packages built from newer GCC versions from the control file.
  * Fix duplicate provides line in control file (closes: #356898).
  * Configure --with-cpu=v8 on sparc.
  * Honour -fPIC on GNU/kFreeBSD (Aurelian Jarno). Closes: #339934.
  * Add big-endian arm (armeb) support (Lennert Buytenhek). Closes: #331220.

gcc-3.3 (1:3.3.6-12) unstable; urgency=low

  * Disable building the gnat-3.3 compiler (Ludvic Brenta).

gcc-3.3 (1:3.3.6-11) unstable; urgency=low

  * Build-depend on expect-tcl8.3 on hppa.

gcc-3.3 (1:3.3.6-10) unstable; urgency=low

  * ppc64 build fixes (Andreas Jochens). Closes: #324243.
    - debian/rules.defs: add 'ppc64' to ada_no_archs (gcc-4.0 has ada
      support on ppc64 but gnat-3.3 does not build with gnat-4.0).
    - debian/rules2: use '--disable-multilib' for 'ppc64'
  * Change section of libstdc++ libs from 'base' to 'libs'.
  * Fix some lintian warnings.

gcc-3.3 (1:3.3.6-9) unstable; urgency=low

  * Use gcc-3.3 as bootstrap compiler, fixes FTBFS on m68k.
  * debian/patches/gcc-mips-update.dpatch: Fix FTBFS on mips,
    backport from the 3.4 branch (Thiemo Seufer).

gcc-3.3 (1:3.3.6-8) unstable; urgency=low

  * Disable building the f77, java, objc, pascal, treelang and ffi packages
    fro...

Changed in gcc-3.3 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers