gcalctool crashed with signal 5 in g_simple_async_result_complete() (corrupted ecb datas on download issues?)

Bug #952744 reported by Vadim Glyshkov on 2012-03-12
108
This bug affects 50 people
Affects Status Importance Assigned to Milestone
gcalctool (Ubuntu)
High
Robert Ancell
Precise
High
Unassigned

Bug Description

Impact:
If the ECB datas downloading is buggy gcalctool exits out

Test Case:
Edit /home/seb128/.cache/gcalctool/eurofxref-daily.xml and corrupt the data, start gcalctool and see if it does exit or not

Regression potential:
Limited, it's changing an error for a warning

Vadim Glyshkov (vadim-nsk) wrote :

StacktraceTop:
 load_ecb_rates (manager=0x263d120) at currency-manager.c:493
 load_rates (manager=0x263d120) at currency-manager.c:548
 load_rates (manager=0x263d120) at currency-manager.c:534
 download_imf_cb (object=0x270e150, result=0x2591c00, user_data=0x263d120) at currency-manager.c:242
 g_simple_async_result_complete (simple=0x2591c00) at /build/buildd/glib2.0-2.31.20/./gio/gsimpleasyncresult.c:744

Changed in gcalctool (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcalctool (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, those issues seem to be due to invalid ecb datas, some duplicates seem to show connection issues as well (i.e gvfs mount to http location failing)

visibility: private → public
Changed in gcalctool (Ubuntu):
importance: Medium → High
assignee: nobody → Robert Ancell (robert-ancell)
summary: gcalctool crashed with signal 5 in g_simple_async_result_complete()
+ (corrupted ecb datas on download issues?)
Steve McGrath (smcgrath23) wrote :

This happened to me when switching quickly to the 'Financial' mode and then to the 'Basic' mode. I haven't looked into it further, but my gut instinct is that I switched away from financial mode before the initial currency information download was finished, and something reacted poorly to the resulting callback.

Changed in gcalctool (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcalctool (Ubuntu Precise):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gcalctool (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → In Progress
description: updated
description: updated

Hello Vadim, or anyone else affected,

Accepted gcalctool into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gcalctool/6.4.1.1-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gcalctool (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

SRU verification for Precise:
I have reproduced the problem with gcalctool 6.4.1.1-0ubuntu2 in precise and have verified that the version of gcalctool 6.4.1.1-0ubuntu3 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 6.4.1.1-0ubuntu3

---------------
gcalctool (6.4.1.1-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_ecb_erroring.patch:
    - don't error out when the ecb datas are invalid (lp: #952744)
 -- Sebastien Bacher <email address hidden> Sat, 28 Jul 2012 18:52:06 +0200

Changed in gcalctool (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gcalctool (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers