empathy crashed with SIGILL

Bug #456530 reported by anewman on 2009-10-20
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gavl (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

Prevents Empathy IM client starting. I presume it is also linked to the bug that prevents Pidgin starting. Bug only arose with recent updates.

ProblemType: Crash
Architecture: i386
Date: Tue Oct 20 18:54:23 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
NonfreeKernelModules: nvidia
Package: empathy 2.28.1-1ubuntu1
ProcCmdline: empathy
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Signal: 4
SourcePackage: empathy
Stacktrace:
 #0 0xb63fa27b in ?? () from /usr/lib/libgavl.so.1
 No symbol table info available.
 #1 0x096b3af0 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? () from /usr/lib/libgavl.so.1
 ?? ()
Title: empathy crashed with SIGILL
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

anewman (alan-an1) wrote :
visibility: private → public

StacktraceTop:gavl_video_scale_table_init (tab=0x96aeaf4, opt=0xbfe736fc,
gavl_video_scale_context_init (ctx=0x96aeaf4,
gavl_video_scaler_init (scaler=0x96aea80,
f0r_construct (width=640, height=480)
?? () from /usr/lib/gstreamer-0.10/libgstfrei0r.so

Changed in empathy (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
VPablo (villumar) wrote :

I think I have this problem as well. I cannot run amsn and totem because a failure in gstreamer... I think. It's possible that this error is for a gstreamer failure?

I'm sorry if I'm saying stupid things but is possible that I have a problem with my HDD and it's possible that all of my errors will be because that.

And sorry for my English.

VPablo (villumar) wrote :

If I run empathy from a terminal I have this:

$ empathy
Error al volver a escanear el registro , child terminated by signal
Run 'empathy --help' to see a full list of available command line options.

(empathy:4188): empathy-WARNING **: Error in empathy init: Error al volver a escanear el registro , child terminated by signal

The same for totem but in amsn:

$ amsn
Could not initialize GStreamer: Error re-scanning registry , child terminated by signal

affects: empathy (Ubuntu) → gavl (Ubuntu)
affects: gavl (Ubuntu) → empathy (Ubuntu)
affects: empathy (Ubuntu) → gavl (Ubuntu)
VPablo (villumar) wrote :

Ok, I have uninstalled frei0r-plugins as said here:
http://groups.google.com/group/linux.debian.bugs.rc/browse_thread/thread/39f1c2e1df532491?pli=1

and amsn and totem works again. Sorry but I had uninstalled empathy.

anewman (alan-an1) wrote :

"VPablo wrote 5 hours ago: #6

Ok, I have uninstalled frei0r-plugins"

Excellent, that seemed to work.

Now I need to fix my updates as I have not had any updates in days so I assume they're broken.

Riccardo Masala (raggioscuro) wrote :

Cannot test empathy, but pidgin works fine in ubuntu 9.04 & 9.10, upgrading gavl to version 1.1.1-2 (which I found in debian sid repository). Without removing anything.

##SQUEEZE (Testing)
deb http://ftp.it.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.it.debian.org/debian/ squeeze main contrib non-free

Package is available here:
http://packages.debian.org/sid/i386/libgavl1/download

ticket on pidgin track:
http://developer.pidgin.im/ticket/10392

Oliver (too-nobby) wrote :

I was getting same errors for pidgin, empathy and totem but only after I updated to the RC. Had no problems in beta. Once I removed frei0r-plugins, all 3 worked again.

This is the errors I had:
nobby@nobby:~$ pidgin
Illegal instruction (core dumped)
nobby@nobby:~$ empathy
Error re-scanning registry , child terminated by signal
Run 'empathy --help' to see a full list of available command line options.

(empathy:6327): empathy-WARNING **: Error in empathy init: Error re-scanning registry , child terminated by signal
nobby@nobby:~$ totem
Error re-scanning registry , child terminated by signal
Run 'totem --help' to see a full list of available command line options.

Changed in gavl (Ubuntu):
status: New → Confirmed
C.H.E.W.S. (tchews) wrote :

Empathy is still broken and open shot depends on frei0r-plugins and thus I can not use the fix of removing it.

VPablo (villumar) wrote :

I have updated KDEnlive to the latest version and it depends on frei0or-plugins so amsn didn't work. I have updated libgavl to the version on Debian repositories and amsn works again.

Please, update gavl to 1.1.1 because Ubuntu's version is buggy.

Thanks.

C.H.E.W.S. (tchews) wrote :

I updated gavl witch had fixed all apps but empathy is still broken. I cannot remove the frei0or-plugins because another package depends on it.

C.H.E.W.S. (tchews) wrote :

Anyone know if they fixed this for the final? Oh and buy the way I plan to use ubuntu and blender as the primary tools for a christian animation studio I am starting. The idea is to make animated movies that are very visually impressive and full of all the entertainment value. Basically christian movies that don't suck. Anything from comedy to action to sci-fi. Any ways got a twitter for it feel free to follow at http://twitter.com/chewsstudio You can email to <email address hidden> with any questions or interest.

Simon Woolf (semw) wrote :

This just happened to me, with pidgin (worked fine yesterday, broken today, weirdly); upgrading gavl fixed it. (Ubuntu 9.10, fully up to date)

Mika Wahlroos (mpw) wrote :

Judging by the Debian bug report ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544734 ) about the same issue, the problem would seem to be in build options rather than code.

The magical thing about the Debian package isn't the 1.1.1 upstream release but the packaging fix incorporated in the latest update to the package in Debian sid.

mlkovacs (michaellkovacs) wrote :

Upgrading gavl to 1.1.1 worked for me on Karmic, Both empathy and pidgin work now, Thanks.

wget http://downloads.sourceforge.net/project/gmerlin/gavl/1.1.1/gavl-1.1.1.tar.gz?use_mirror=iweb
tar -zxvf gavl-1.1.1.tar.gz
sudo apt-get install libsamplerate-dev
cd gavl-1.1.1
./configure
make
sudo checkinstall

when prompted enter 2 and rename the package to libgavl1 and hit enter (not sure if it makes a difference or not but it worked for me)

enjoy

Narcis Garcia (narcisgarcia) wrote :

I solved this problema with an easier way: installing the next Ubuntu version library (Lucid):

http://packages.ubuntu.com/lucid/libgavl1

Alessio Treglia (quadrispro) wrote :

Fixed in Lucid.
Thanks.

Changed in gavl (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.