[Gallery] imported pictures should show in Event for today

Bug #1381583 reported by Bill Filler on 2014-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Canonical Devices Products
Ubuntu UX
High
Jouni Helminen
gallery-app
Fix Released
High
Arthur Mello
gallery-app (Ubuntu)
High
Arthur Mello
gallery-app (Ubuntu RTM)
High
Arthur Mello

Bug Description

When pictures are imported into the gallery, via content-hub, we should always display them in the Event for the current day. Right now, the picture is played in the Event that corresponds to the metadata creation date which is very confusing because after the picture is imported you can't find it easily.

Arthur and I discussed modifiying one of the standard exif tags (like DateTime, but don't modify CreationDate) with the current date of import as the gallery already sorts by a series of tags. Another solution would be to add a custom tag like (importDate) and change the sort to use that if it exists before falling back to other tags.

Related branches

Bill Filler (bfiller) on 2014-10-15
Changed in gallery-app:
importance: Undecided → High
assignee: nobody → Arthur Mello (artmello)
tags: added: rtm14
Bill Filler (bfiller) on 2014-11-06
Changed in gallery-app:
status: New → In Progress
Olli Ries (ories) wrote :

Product Team feedback: shouldn't this apply to pics where there is no meta data, but when there is a creation date, then honor the existing information

Pat McGowan (pat-mcgowan) wrote :

I envision importing pictures from Xmas time, or from my summer vacation, I would want those pics to show when they were taken

Arthur Mello (artmello) wrote :

If the file does not have any metadata info we fallback to the last modified date of the file on the current code.
I agree that would be a good idea to respect the creation date from the metadata for the case we are saving photos from a specific event like Xmas or summer vacation. And for those ones would be no problem since you will probably know in which event the photo was saved.
But that does not fix the issue when, for example, we save a couple of photos received by email that are not from some specific event, i.e. photos from some city. If they have metadata info but was taken on many different dates they will be spread on many different events and the user would have a bad time finding them.

This fix only applies for pictures that come in through content hub. Like
photos you download from the web or attachments that are received in an
email. These photos you typically have no idea when they were created, nor
do you usually care. In the previous impl before this fix these photos get
placed "somewhere" in your event view based on the photo creation date and
the user has no way to find them. The longer term plan might be to put
these photos in a Downloads album or similar but we don't have a design for
that currently.

Photos copied via mtp or viewed from SD card remain sorted by creation
date.

On Friday, November 7, 2014, Arthur Mello <email address hidden>
wrote:

> If the file does not have any metadata info we fallback to the last
> modified date of the file on the current code.
> I agree that would be a good idea to respect the creation date from the
> metadata for the case we are saving photos from a specific event like Xmas
> or summer vacation. And for those ones would be no problem since you will
> probably know in which event the photo was saved.
> But that does not fix the issue when, for example, we save a couple of
> photos received by email that are not from some specific event, i.e. photos
> from some city. If they have metadata info but was taken on many different
> dates they will be spread on many different events and the user would have
> a bad time finding them.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1381583
>
> Title:
> imported pictures should show in Event for today
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gallery-app/+bug/1381583/+subscriptions
>

Given this explanation I would agree this is the right fix

Bill Filler (bfiller) on 2014-11-12
Changed in gallery-app (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in gallery-app (Ubuntu RTM):
status: New → In Progress
importance: Undecided → High
Changed in gallery-app (Ubuntu):
assignee: nobody → Arthur Mello (artmello)
Changed in gallery-app (Ubuntu RTM):
assignee: nobody → Arthur Mello (artmello)
tags: added: ota-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+15.04.20141112-0ubuntu1

---------------
gallery-app (0.0.67+15.04.20141112-0ubuntu1) vivid; urgency=low

  [ Arthur Mello ]
  * Delay the opening photo process until all media files are loaded
    when called by url handler (LP: #1389514)
  * Switch to events view after a media imported (LP: #1382109)
  * Set the TimeDigitized Exif field for the import date on imported
    files (LP: #1381583)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Wed, 12 Nov 2014 22:27:36 +0000

Changed in gallery-app (Ubuntu):
status: In Progress → Fix Released
Arthur Mello (artmello) on 2014-11-19
Changed in gallery-app (Ubuntu RTM):
status: In Progress → Fix Released
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Arthur Mello (artmello) on 2014-11-27
Changed in gallery-app:
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
status: New → Triaged
importance: Undecided → High
Bill Filler (bfiller) on 2014-12-03
Changed in gallery-app (Ubuntu RTM):
status: Fix Released → In Progress
Changed in gallery-app:
status: Fix Released → In Progress
tags: added: ww51
John Lea (johnlea) on 2014-12-05
summary: - imported pictures should show in Event for today
+ [Gallery] imported pictures should show in Event for today
Bill Filler (bfiller) wrote :
Jean-Baptiste Lallement (jibel) wrote :

During the verification of this fix, the gallery-app crashed while importing a picture from flicker [1] . (https://errors.ubuntu.com/oops/11ff2804-8516-11e4-8a59-fa163e5bb1a2)

[1] https://www.flickr.com/photos/chaoticmind75/15844554777/in/set-72157626146319517

Jean-Baptiste Lallement (jibel) wrote :

I tried with gallery-app 2.9.1.1101 and cannot reproduce. It is a regression introduce by gallery-app RTM/1049

Test Case:
1. Go to the photo scope
2. Scroll down and tap on 'Flicker'
3. In the list of photos, tap on the first photo
4. In the photo view, tap on the button 'Show in flicker'
5. In flicker
    5.1 Tap on 'Explore' in the top menu bar
    5.2 Tap on the first photo (it should be the same than previous photo but we want to browse photos from different artists not all from the same artist in case this bug is caused by specific information in the photo)
    5.3 Long press on the photo to display the contextual menu
    5.4 Select 'Save picture'
    5.5 Select Gallery
    5.6 In the 'Download complete' dialog tap open
6. Don't close the gallery and switch back to flicker
7. Switch to next photo by pressing the right edge of the photo in flicker
8. Repeat steps 5.3 to 7 until gallery-app crashes

Expected result
Verify that the photo is saved in the gallery app, and a thumbnail is generated.

Bill Filler (bfiller) wrote :

The crash has been fixed. The issue was that we were crashing on images that did not have valid exif meta-data. We are now checking for that and not crashing.

However we discovered a related bug (not a regression, has always been there), where certain file types are not supported in the gallery, like .gif and .svg. If you try to download a file of this type you will get no error but the photo will not show up in the gallery and there is no warning. This is tracked https://bugs.launchpad.net/gallery-app/+bug/1403205 but is not related to this fix.

Also, so images on flickr are not legally allowed to be downloaded. If you attempt to download them on a desktop browser it will tell you the photographer has disallowed downloading. On Ubuntu Touch in Flick using the steps above, a bogs 1x1 gif is downloaded when you attempt to download a file that is copy protected. Again there is not feedback to the user.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+15.04.20141216~rtm-0ubuntu1

---------------
gallery-app (0.0.67+15.04.20141216~rtm-0ubuntu1) 14.09; urgency=low

  [ Arthur Mello ]
  * Set the TimeDigitized Exif field for the import date on imported
    files. Do that to make sure imported files shows up on the Event for
    imported day (LP: #1381583)
  * Delay the opening photo process until all media files are loaded
    when called by url handler (LP: #1389514)
  * Load the AlbumEditor without the animation to improve the load time
    (LP: #1398419)

  [ Ubuntu daily release ]
  * New rebuild forced

gallery-app (0.0.67+14.10.20141017-0ubuntu1) utopic; urgency=low

  [ Arthur Mello ]
  * Show header by default on an empty album (LP: #1378367)

  [ Ugo Riboni ]
  * Delete the new empty album if the album editor is closed by clicking
    outside of the album cover (LP: #1234128)
  * Adjust the popover position for the cover pattern editor. (LP:
    #1374016)

  [ Sebastien Bacher ]
  * Use a Binding to set the gettext domain, fixes the import mode
    translations (LP: #1378384)
 -- Ubuntu daily release <email address hidden> Tue, 16 Dec 2014 19:38:14 +0000

Changed in gallery-app (Ubuntu RTM):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2014-12-17
Changed in gallery-app:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: Triaged → Fix Released
Bill Filler (bfiller) wrote :

There is still a single case that is not working properly:

1) make sure you have photos in gallery from previous days
2) open gmail and attach a photo from a previous day and send a message to yourself
3) fetch new mail in gmail and open the message with the attachment
4) save the attachment to the gallery

Expected results:
The saved photo should be visible in today's event view

Actual results:
The saved photo is saved in the original date event view

Changed in gallery-app:
status: Fix Released → Confirmed
Changed in gallery-app (Ubuntu):
status: Fix Released → Confirmed
Changed in gallery-app (Ubuntu RTM):
status: Fix Released → Confirmed
Arthur Mello (artmello) on 2015-06-30
Changed in gallery-app:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2015-07-08
Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww28-2015
Changed in gallery-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments