USB audio device is not recognized after startup in 16.04

Bug #1574079 reported by TheBigW on 2016-04-23
144
This bug affects 27 people
Affects Status Importance Assigned to Milestone
fwupd (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Medium
Unassigned

Bug Description

[Impact]
High end USB audio devices don't work properly after fwupd is started from gnome-software.

[Test case]
Login to Ubuntu session and try to use a USB audio device. See if it works properly.

If you are applying this upgrade and testing a regression it's important that the device isn't in a bad state to start. To guarantee this doesn't happen:
1) Apply the update
2) Power off your machine
3) Unplug device
4) Plug in device
5) Power on machine
6) Check if it works.

[Regression Potential]
This affects the DFU provider in Ubuntu. The fix is only made to that part of the fwupd stack.
No firmware for DFU has been published to the LVFS yet, so this shouldn't have any regression risk to Ubuntu.

[Original bug]
Hi @all,

I used the same USB audio device in all previous Ubuntu versions (Focusrite Scarlet 2i2). It is supposed to be class compliant and works an all distros flawless (even RPI2 and OSMC). After upgrading from 15.10 to 16.04 it stopped to work: after start-up it does not show up as an audio device at all (also not recognized by aplay -l). I can workaround this by unplugging it and plugging it in again after Ubuntu booted up (strangely 2 times unplug/re-plug). After 2nd time plugging it in again it shows up and works great without any further issues until next restart.

Maybe worth to note that I recognized today that fwupd uses continuously 100% CPU load, so I just killed it today. My Hardware (Main-board/CPU) is a bit older (Intel E8400), so could probably be some compatibility issue...

regards,
Tobias

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic i686
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: tobias 1553 F...m pulseaudio
 /dev/snd/controlC1: tobias 1553 F.... pulseaudio
 /dev/snd/controlC0: tobias 1553 F.... pulseaudio
 /dev/snd/controlC2: tobias 1553 F.... pulseaudio
CurrentDesktop: Unity
Date: Sat Apr 23 20:09:04 2016
InstallationDate: Installed on 2015-09-19 (217 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
PackageArchitecture: all
SourcePackage: alsa-driver
UpgradeStatus: Upgraded to xenial on 2016-04-22 (0 days ago)
dmi.bios.date: 09/30/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1238
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5B-Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1238:bd09/30/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5B-Deluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

TheBigW (tobiaswenig) wrote :
TheBigW (tobiaswenig) wrote :

I read the description of what fwupd does and if it really is just UEFI BIOS related it won't matter on my older machine I thought and just got rid of it (apt-get purge). What shall I see: after restart my USB audio device worked out of the box - seems this issue is not alsa - related at all.
I updated my 2nd lubuntu machine to 16.10 with another class compliant USB device (RME Fireface UCX) and it worked out of the box.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
pablomme (pablomme) wrote :

I can confirm this fwupd issue for a different USB audio device, a PreSonus AudioBox 1818 VSL.

When I connect the card I get this in /var/log/syslog [1] [2]:

Apr 24 15:41:47 yogamme kernel: [ 34.958299] usbcore: registered new interface driver snd-usb-audio
Apr 24 15:41:47 yogamme org.freedesktop.fwupd[706]: (fwupd:1806): As-CRITICAL **: as_store_get_app_by_provide: assertion 'value != NULL' failed
Apr 24 15:41:47 yogamme systemd-udevd[2129]: Process '/usr/sbin/alsactl -E HOME=/run/alsa restore 2' failed with exit code 99.
Apr 24 15:41:50 yogamme gnome-session[1421]: (gnome-software:1739): Gs-WARNING **: failed to get updates: no results to show
Apr 24 15:41:52 yogamme kernel: [ 39.853364] usb 1-1.2: 2:2: cannot set freq 44100 (v2): err -110
Apr 24 15:41:52 yogamme kernel: [ 39.878675] usb 1-1.2: 2:2: usb_set_interface failed (-71)
Apr 24 15:41:52 yogamme kernel: [ 39.882926] usb 1-1.2: 2:2: usb_set_interface failed (-71)
Apr 24 15:41:52 yogamme kernel: [ 39.887176] usb 1-1.2: 2:2: usb_set_interface failed (-71)
...

Running `alsamixer` and selecting the USB sound card causes alsamixer to abort with a "protocol error".

If I do `sudo killall fwupd` and reconnect the USB sound card, everything works fine. It seems that fwupd is interfering with ALSA gaining control of the sound card.

[1]: My Thinkpad Yoga 14 laptop has USB 3.0 ports, but one can force them to behave as 2.0 ports via a BIOS/UEFI setting. The syslog excerpt is for USB 2.0 mode; in 3.0 mode an additional log message mentioning "URB transfer length is wrong, xHC issue?" appears among the usb_set_interface messages.
[2]: The gnome-software warning *is* related to fwupd - https://github.com/hughsie/fwupd mentions GNOME software as "the only graphical frontend available" for fwupd at present.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Invalid
Changed in fwupd (Ubuntu):
status: New → Confirmed
Changed in fwupd (Ubuntu):
status: Confirmed → Fix Released
pablomme (pablomme) on 2016-04-24
no longer affects: fwupd (Ubuntu)
Changed in fwupd (Ubuntu):
status: New → Confirmed
Changed in fwupd (Ubuntu):
status: Confirmed → Fix Released
Chris (llittlewing-chris) wrote :

Same problem with Audiobox 22 VSL. Unplugged and plugged back in twice and the device is now recognised.

Steve Wolfe (stevenwolfe) wrote :

Same problem with a fully updated install of Ubuntu-GNOME 16.04. This is with a Focusrite iTrack. The first time the device is attached to a USB port it will fail. Unplugging and replugging the device into the same USB port will succeed.

Joseph Viviano (joseps) wrote :

Confirm that this fixed it for me:

killall fwupd

followed by unplugging / replugging my focusrite 2i4 into a USB2.0 port.

Jay Bowles (sukiwilf) wrote :

Can I just add that this affects my Cambridge Audio DAC Magic100 also. I have found that it seems to effect Ubuntu and Ubuntu mate but strangely not Kubuntu. I tried Ubuntu again 3 days ago and this is still a problem. In fact as I get small shocks from the case I'm a little reluctant to pursue this further. I note killing fwupd solves the issue which is interesting as it doesn't seem to work for Kubuntu.... Maybe off by default?

gach87 (gach87) wrote :

I have a fully updated ubuntu 16.04 installation with a Focusrite 2i2 and i still have this problem, i also have a Beringher Guitar Port and that one works fine. Can confirm that killall fwupd makes the interface work

Confirming error on Ubuntu 16.04 and Cambridge Audio DAC Magic Plus. The USB device does not list with lsusb and removing fwupd does no difference. Worked flawlessly with Ubuntu 15.10.

Except from syslog:
kernel: [41856.060179] usb 3-6: 1:1: usb_set_interface failed (-71)

systemd-udevd[18617]: Process '/usr/sbin/alsactl -E HOME=/run/alsa restore 2' failed with exit code 99.
pulseaudio[2325]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
pulseaudio[2325]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="2" name="usb-Cambridge_Audio_Cambridge_Audio_USB_Audio_2.0_0000-00" card_name="alsa_card.usb-Cambridge_Audio_Cambridge_Audio_USB_Audio_2.0_0000-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
pulseaudio[2325]: [pulseaudio] module-udev-detect.c: Tried to configure /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6:1.0/sound/card2 (alsa_card.usb-Cambridge_Audio_Cambridge_Audio_USB_Audio_2.0_0000-00) more often than 5 times in 10s

Jay Bowles (sukiwilf) wrote :

I have reinstalled Ubuntu 16.04 afresh today and after a complete update this is still an issue with my Cambridge Audio USB soundcard. Removing fwupd did do the trick this time. However if I was new to Linux this wouldn't give a good first impression and indeed could have been a deal breaker. I noticed there was an update to fwupd whilst I was updating the system; but as I said this didn't work for me.

Jay Bowles (sukiwilf) wrote :

This fix does not work for Cambridge Audio dac Magic

Jozef Palme (ibeid) wrote :

I have Cambridge audio dacmagic plus and in usb 2.0 mode is not recognized. only in usb 1.0. please please could someone fix it.

whispered (elmarcezen) wrote :

I have a focusrite 2i2 and I'm still experiencing this.

I've even unsintalled fwupd, but the problem persists.

kingfriday (iodiari) wrote :

When is this fix actually going to be present in vanilla Ubuntu 16.04? I have been using the "sudo killall fwupd" method to get audio working but it would be nice to not have to do that everytime I login or update software or resume from sleep.

Jay Bowles (penguinclaw-i) wrote :

My usb audio is no longer working at all with 16.04. I am rolling back to previous LTS as this sucks and has remained as unassigned for a while now. I wonder if it is worth raising a separate bug as the fwupd "fix released" is a misnomer for myself and others.

pablomme (pablomme) on 2016-05-25
no longer affects: fwupd (Ubuntu)
Changed in fwupd (Ubuntu):
status: New → Confirmed
Mario Limonciello (superm1) wrote :

Hi @Jay and @Kingfriday,

If this is continuously reproducible for you, it would be great to get some debug output from fwupd to figure out why this is happening. I unfortunately haven't been able to reproduce it using my USB audio device (Dell TB15 dock).
Can you try to follow these steps to get a debug log?

1) sudo killall fwupd
2) sudo /usr/lib/x86_64-linux-gnu/fwupd/fwupd -v 2>&1 | tee fwupd_debug.log

After you've captured the log, can you please report this to the upstream issue tracker? Ubuntu isn't carrying any patches that should cause this, so it should be reported upstream and fixed there. We can then backport the patch that fixes it to Ubuntu.
https://github.com/hughsie/fwupd/issues

Changed in fwupd (Ubuntu):
importance: Undecided → Medium

Confirmed bug. Audio interface "focusrite solo" isn't found on startup. Have to plug it out and then in again to make it work.

Abkishek,

Can you please try to reproduce it with fwupd running with debug flags as
listed above?

You might have to unplug it, run with debug flags and plug back in.

On Sat, May 28, 2016, 09:50 Abhishek Chaudhary <email address hidden>
wrote:

> Confirmed bug. Audio interface "focusrite solo" isn't found on startup.
> Have to plug it out and then in again to make it work.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1574079/+subscriptions
>

Download full text (4.4 KiB)

This is what I got after running
1) sudo killall fwupd
2) sudo /usr/lib/x86_64-linux-gnu/fwupd/fwupd -v 2>&1 | tee fwupd_debug.log

21:57:58 Verbose debugging enabled (on console 0)
21:57:58 adding plugin /usr/lib/x86_64-linux-gnu/fwupd-plugins-1/libfu_plugin_steelseries.so
21:57:58 adding plugin /usr/lib/x86_64-linux-gnu/fwupd-plugins-1/libfu_plugin_test.so
21:57:58 performing init() on test
21:57:58 Loading fallback values from /etc/fwupd.conf
21:57:58 adding udev device: /sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0
21:57:58 fixing GUID 0x10de:0x1040->693025a1-4a7d-53b8-864e-c7f3e5866ec0
21:57:58 emit added from Udev: ro__sys_devices_pci0000_00_0000_00_02_0_0000_01_00_0
Failed to coldplug: UEFI firmware updating not supported
***
21:57:58 Failed to coldplug: UEFI firmware updating not supported
***
21:57:58 emit added from USB: usb:00:04
21:57:58 emit added from USB: usb:00:03
############################################################################### @0551ms AsStore:load 551ms
############################################################################### @0551ms AsStore:load{per-system} 551ms
# @0005ms AsStore:app-info{/usr/share/app-info/xmls/org.freedesktop.fwupd.xml} 5ms
 # @0022ms AsStore:app-info{/var/lib/app-info/yaml/in.archive.ubuntu.com_ubuntu_dists_xenial_multiverse_dep11_Components-amd64.yml.gz} 11ms
 # @0022ms AsStore:store-from-file 11ms
   ### @0046ms AsStore:app-info{/var/lib/app-info/yaml/in.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_dep11_Components-amd64.yml.gz} 23ms
   ### @0046ms AsStore:store-from-file 23ms
      ########################################################## @0452ms AsStore:app-info{/var/lib/app-info/yaml/in.archive.ubuntu.com_ubuntu_dists_xenial_universe_dep11_Components-amd64.yml.gz} 406ms
      ########################################################## @0452ms AsStore:store-from-file 406ms
                                                                 ############# @0547ms AsStore:app-info{/var/lib/app-info/yaml/in.archive.ubuntu.com_ubuntu_dists_xenial_main_dep11_Components-amd64.yml.gz} 94ms
                                                                 ############# @0547ms AsStore:store-from-file 94ms
                                                                                  ### @0593ms FuMain:coldplug 24ms
                                                                                  ## @0584ms FuMain:coldplug{Udev} 15ms
                                                                                  # @0578ms FuProviderUdev:coldplug{usb} 9ms
                                                                                   # @0584ms FuProviderUdev:coldplug{pci} 5ms
             ...

Read more...

Mario Limonciello (superm1) wrote :

Great thanks, can you please also share sudo lsusb -v output?

Here is the output of sudo lsusb -v

Taras (taras-zakus) wrote :

Hi Mario, I believe the https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/comments/20 debug output is not complete. Please see the log:

...
21:26:16 15 com.hughski.ColorHugALS.firmware ColorHugALS
21:26:30 waiting a small time for other providers
21:26:30 using b69159f2-3778-5728-80d0-01be18b2ea30 for USB\VID_1397&PID_0501
21:26:30 emit added from DFU: usb:00:01:03
21:26:31 no product string descriptor
21:26:33 Called GetUpdates()
(END)

Here I've also tried to connect my USB sound-card BEHRINGER UMC204 at 21:26:30.

Mario Limonciello (superm1) wrote :

Well that's interesting, it looks like your audio device might have a dfu
mode. I wonder if that's the case for the other reporters. Can you please
also share lsusb output? Everyone affected it would be great to share both
of these so that upstream can make sense of common denominations to figure
what's actually going on.

On Sat, May 28, 2016, 13:50 Taras <email address hidden> wrote:

> Hi Mario, I believe the
> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/comments/20
> debug output is not complete. Please see the log:
>
> ...
> 21:26:16 15 com.hughski.ColorHugALS.firmware ColorHugALS
> 21:26:30 waiting a small time for other providers
> 21:26:30 using b69159f2-3778-5728-80d0-01be18b2ea30 for
> USB\VID_1397&PID_0501
> 21:26:30 emit added from DFU: usb:00:01:03
> 21:26:31 no product string descriptor
> 21:26:33 Called GetUpdates()
> (END)
>
> Here I've also tried to connect my USB sound-card BEHRINGER UMC204 at
> 21:26:30.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1574079/+subscriptions
>

TheBigW (tobiaswenig) wrote :

my lsusb output:

Bus 001 Device 003: ID 1235:8006 Focusrite-Novation Focusrite Scarlett 2i2
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:c20d Logitech, Inc. WingMan Attack 2
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

addition: the focusrite 2i2 works great now after removing fwupd. However on my second system with RME Fireface UCX it still happens that it takes 1..2 reboots until the UCX gets recognized. I will post it's lsusb output later once I get to this system.

Here is the lsusb output after login (audio interface is plugged in) ;
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 004 Device 002: ID 258a:0001
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here is the lsusb output after removing and plugging the interface back again ;
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 1235:801c Focusrite-Novation
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 004 Device 002: ID 258a:0001
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

TheBigW (tobiaswenig) wrote :

output form my 2nd machine where occasionally the RME Fireface UCX is not recognized:

Bus 001 Device 004: ID 1058:0730 Western Digital Technologies, Inc. My Passport Essential (WDBACY)
Bus 001 Device 003: ID 0424:3fb9 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

mhh - I did not see it at all it seems, but aplay -l gives me perfectly:

Karte 0: UCX23660989 [Fireface UCX (23660989)], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 1: Intel [HDA Intel], Gerät 0: ALC861-VD Analog [ALC861-VD Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Intel [HDA Intel], Gerät 6: Si3054 Modem [Si3054 Modem]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

and at the moment it works as expected

no longer affects: alsa-driver (Ubuntu)
Mario Limonciello (superm1) wrote :

I've filed this issue upstream. Can affected folks please star subscribe to that issue and provide information as requested by upstream?

https://github.com/hughsie/fwupd/issues/50

Okay, so quite a few different issues here.

* If the audio card doesn't work when fwupd is removed and there is no fwupd process running then it's not a fwupd issue.

* Does everybody who has to replug also have an entry for the soundcard in `dfu-tool list`? If so, please paste the output.

* If you have a fwupd at 100% CPU saturating one core can you please attach gdb to the process (as root), break and get a backtrace please.

* If you get a critical warning from fwuod when running, can you run fwupd as root with `sudo G_DEBUG=fatal-warnings gdb fwupd --verbose` and then grab a backtrace when it breaks.

* The only thing that seems to be common is that all these USB sound cards are expensive :) If all of these things sounds complicated, is there a cheaper version of the devices that reproduces the problem, or is anyone willing to send me an unused device for a week or so for debugging? I run regression tests on a lot of devices before each release and so if there's a cheap device available it would be a good thing to add.

Taras (taras-zakus) wrote :

Hi Richard, I'm glad you have paid attention to this problem.
A few weeks ago I've upgraded my Ubuntu version from 14.04 to 16.04 and faced with this issue. Now every time before connecting my USB sound-card I have to kill the 'fwupd' process.
Here is output from the 'dfu-tool list' command:

 - When 'fwupd' is running:
Found 1397:0501 [v1.0]:
  Status: cannot get device state: transfer failed

 - After killing 'fwupd' and replugging sound-card:
Found 1397:0501 [v1.0]:
 Mode: runtime
 Status: OK
 State: appIDLE
 ID: 0
  Cipher: none
  Region 0x00: Zone:0, Sec#:0, Addr:0x00000000, Size:0x0000, Caps:0x3

The 'fwupd' process itself using 1.2 - 1.8 % of CPU (model name: Intel(R) Core(TM) i3 CPU M370 @2.40GHz).
Also please check the attachments: lsusb (with connected working/not-working sound-card) and fwupd verbose output (started with working sound-card/connecting sound-card when 'fwupd' running) diffs. Hope this will help.

Vlad (vvladxx) wrote :

Faced the same issue with Sony PHA-3 after the update from 14.04 to 16.04. Solved by removing fwupd.
It is also worth to note that my second USB DAC, Dr. DAC Nano, works flawlessly even with fwupd installed. However, Sony PHA-3 does not.

So in normal use the fwupd daemon should consume literally no CPU, except when it's processing requests like GetUpdates or GetDetails. If it's using 1-2% of CPU at runtime then something is going wrong. When that happens I'd love to see a backtrace (it seems --verbose isn't verbose enough...) just to what what thread is spinning and on what. You might have to do a few b, c, break, b, c, break etc to see where it's stuck.

The "cannot get device state: transfer failed" is either because fwupd is processing a transaction at the same time, or because the device has managed to get itself in a messed up state by something probing the DFU capability. It would be interesting to know if killing fwupd, running `dfu-tool watch` and then inserting the device gives the same "doesn't work" symptoms.

The Sony PHA-3 is kinda expensive.

Jay Bowles (penguinclaw-i) wrote :

Thanks Richard for getting involved.

Not sure how much help I can be as although I have this problem with my Cambridge Audio DAC and Ubuntu 10.04, with Kubuntu this is no an issue! I am now using Kubuntu (I actually quite enjoying it now) and I notice that the driver installation app doesn't work at all by default. Indeed it just hangs. So I just installed what I needed manually. The point being, do the developers know something that they haven't passed on to Ubuntu about fwupd?? Will my not having a problem on this flavour be of any help to you debugging for Ubuntu?

Just a thought!

Mario Limonciello (superm1) wrote :

Jay,

Surely you mean 16.04 not 10.04. In Kubuntu even if fwupd is installed it
won't start up on its own.

In Ubuntu it starts up with your session by gnome-software looking for
firmware updates from fwupd.

If you could reproduce by manually running fwupd and attaching a debugger
you may still be able to help assist even if it doesn't happen by default
in Kubuntu since fwupd doesn't automatically spawn.

On Mon, May 30, 2016, 12:20 Jay Bowles <email address hidden> wrote:

> Thanks Richard for getting involved.
>
> Not sure how much help I can be as although I have this problem with my
> Cambridge Audio DAC and Ubuntu 10.04, with Kubuntu this is no an issue!
> I am now using Kubuntu (I actually quite enjoying it now) and I notice
> that the driver installation app doesn't work at all by default. Indeed
> it just hangs. So I just installed what I needed manually. The point
> being, do the developers know something that they haven't passed on to
> Ubuntu about fwupd?? Will my not having a problem on this flavour be of
> any help to you debugging for Ubuntu?
>
> Just a thought!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/+subscriptions
>

Mario Limonciello (superm1) wrote :

Anyone who does have the hardware and skills to be able to reproduce and
attach a debugger you need to install the debug symbols for it to be
useful. By default Ubuntu buildd's strip debug symbols and places them in
ddebs. The automatic crash retrace bot will use these symbols to generate
useful backtraces but for attaching a local debugger you will need them
locally installed.

You can find the debug symbols that match your architecture and version
here. Install all 3 packages that match your architecture and version
(libdfu1, libfwupd1, fwupd).
http://ddebs.ubuntu.com/ubuntu/pool/main/f/fwupd/

On Mon, May 30, 2016, 12:36 Mario Limonciello <email address hidden> wrote:

> Jay,
>
> Surely you mean 16.04 not 10.04. In Kubuntu even if fwupd is installed it
> won't start up on its own.
>
> In Ubuntu it starts up with your session by gnome-software looking for
> firmware updates from fwupd.
>
> If you could reproduce by manually running fwupd and attaching a debugger
> you may still be able to help assist even if it doesn't happen by default
> in Kubuntu since fwupd doesn't automatically spawn.
>
> On Mon, May 30, 2016, 12:20 Jay Bowles <email address hidden> wrote:
>
>> Thanks Richard for getting involved.
>>
>> Not sure how much help I can be as although I have this problem with my
>> Cambridge Audio DAC and Ubuntu 10.04, with Kubuntu this is no an issue!
>> I am now using Kubuntu (I actually quite enjoying it now) and I notice
>> that the driver installation app doesn't work at all by default. Indeed
>> it just hangs. So I just installed what I needed manually. The point
>> being, do the developers know something that they haven't passed on to
>> Ubuntu about fwupd?? Will my not having a problem on this flavour be of
>> any help to you debugging for Ubuntu?
>>
>> Just a thought!
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1574079
>>
>> Title:
>> USB audio device is not recognized after startup in 16.04
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/+subscriptions
>>
>

> even if it doesn't happen by default in Kubuntu

GNOME autostarts gnome-software, which allows you to update applications *and* firmware on devices. The latter contacts fwupd for the list of updates which then itself autostarts the fwupd binary. If you call `fwupdmgr get-devices` manually on kubuntu, then insert the device you'll likely see the same symptoms.

Jay Bowles (penguinclaw-i) wrote :

Ah, I see!! Well they say you learn something new every day and yes 16.04 not 10.04. :)

Not sure I really want to reproduce this on a working system but I will if needed. Having said that I am very green in this whole area... learning a lot though which is good. I'll follow this bug out of pure curiosity.

Mario Limonciello (superm1) wrote :

If you (or anyone else) reproduce it on a "working" Kubuntu system by
running fwupdmgr as Richard mentioned it will only be temporary that it was
reproduced. fwupdmgr uses dbus activation to start fwupd. Typically fwupd
isn't run by default in Kubuntu for reasons Richard described.

When you were to kill the fwupd process or reboot you are back to your
previous behavior.

On Mon, May 30, 2016, 13:05 Jay Bowles <email address hidden> wrote:

> Ah, I see!! Well they say you learn something new every day and yes
> 16.04 not 10.04. :)
>
> Not sure I really want to reproduce this on a working system but I will
> if needed. Having said that I am very green in this whole area...
> learning a lot though which is good. I'll follow this bug out of pure
> curiosity.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/+subscriptions
>

whispered (elmarcezen) wrote :

I will try to give it a go once I get home.
I also switched to Kubuntu to avoid this issue.

Taras (taras-zakus) wrote :

I just played a little with 'gdb'. Please see the attachment. Hope you will find the information useful.
Just noticed the process has seven threads. Is it ok? Or maybe it stuck or something?
BTW, I had to interrupt the process, since it didn't crash when I connected the sound-card.

whispered (elmarcezen) wrote :

Adding more info, I copied what Taras did with gdb, and added the outut of sudo lsusb -v in three situations: "test running, card unplugged", "test running, card plugged in" and "no test, card working".

Hope it helps.

Thanks for looking into this!

So, nothing unexpected in those gdb traces... Perhaps it's peculiar that there are three monitoring threads for libusb, but that's due to a limitation in the fwupd provider structure which shouldn't be a huge problem. To rule out that being the issue, can anyone reproduce the issue after killing fwupd as root, running "sudo dfu-tool watch" and then inserting the hardware. If it's a DFU endpoint issue then that should reproduce the bug, if it's a more general USB issue then the bug should be there also. Thanks.

Vlad (vvladxx) wrote :

> can anyone reproduce the issue after killing fwupd as root, running "sudo dfu-tool watch" and then inserting the hardware

Installed fwupd back into system.
I can reproduce the bug with "sudo dfu-tool watch". After killing everything works again.

Vlad (vvladxx) wrote :

(For clarification)

I did the following steps:

1) Installed fwupd
2) Killed the daemon
3) "sudo dfu-tool watch"
4) Plugged-in the device

There's a test branch which I believe fix this problem in https://github.com/hughsie/fwupd/issues/50#issuecomment-223222483 if anyone can test this.

Mario Limonciello (superm1) wrote :

If it makes it easier, i've backported those two patches into a PPA build on top of what's already in Ubuntu here:
https://launchpad.net/~superm1/+archive/ubuntu/lp1574079

The version with those two patches is 0.7.0-0ubuntu4.2~lp1574079.2.

Richard, I don't think there is anything else strictly needed that wasn't already part of 0.7.0's xenial release.

Seb Brosig sent me a 2i2 device for testing, I can reproduce the bug and now have a USB analyser connected to the device. It'll take a little while to work out, but I'm getting there.

I've pushed a patch to master that seems to fix the issue for me of the 2i2: https://github.com/hughsie/fwupd/commit/d0583ae3403b904658b4ac3c10330287ccbae6c9

Mario Limonciello (superm1) wrote :

I've uploaded that fix to yakkety, and started the SRU process for Xenial.

description: updated
Changed in fwupd (Ubuntu Xenial):
status: New → Fix Committed
status: Fix Committed → In Progress
Changed in fwupd (Ubuntu Yakkety):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwupd - 0.7.0-0ubuntu6

---------------
fwupd (0.7.0-0ubuntu6) yakkety; urgency=medium

  * Fix USB audio devices not working properly (LP: #1574079)

 -- Mario Limonciello <email address hidden> Wed, 08 Jun 2016 21:31:00 -0500

Changed in fwupd (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Hello TheBigW, or anyone else affected,

Accepted fwupd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fwupd/0.7.0-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fwupd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
kingfriday (iodiari) wrote :

I updated fwupd (and later libdfu1 / libfwupd1) to 0.7.0-0ubuntu4.2 this did not resolve the issue for me symptoms are the same as before and same usb error message on startup. For clarification this audio device is a "Native Instruments KOMPLETE Audio 6". Had been away for a few days but can provide any other details as needed.

tags: added: verification-failed
removed: verification-needed
kingfriday (iodiari) wrote :

One other update, I ran reinstall again while still getting errors related to USB when starting up it does seem to be working after a few restarts. Probably someone else should also verify behavior.

tags: added: verification-needed
removed: verification-failed

It's important to killall fwupd manually, or reboot to make sure you get a
fresh fwupd process to verify this fix.

Also the USB device could possibly be in a bad state from the previous
interactions.

If you can upon update:

1) unplug your USB device
2) killall fwupd or reboot
3) plug in device

Hopefully things should be in better shape.

On Fri, Jun 10, 2016, 16:01 kingfriday <email address hidden> wrote:

> One other update, I ran reinstall again while still getting errors
> related to USB when starting up it does seem to be working after a few
> restarts. Probably someone else should also verify behavior.
>
> ** Tags removed: verification-failed
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/+subscriptions
>

kingfriday (iodiari) wrote :

I would suggest following 3 steps in post above, originally I just installed the newer versions and rebooted and it did not work, as mentioned maybe device was in bad state. After unplugging and manually running killall it has worked in all following reboots.

Jozef Palme (ibeid) wrote :

my cambridge audio dacmagic plus is working in usb mode 2.0 (24bit192khz) again after fwupd updating. thank you.

tags: added: verification-done
removed: verification-needed
TinusXcentricus (t-no) wrote :

Focusrite Scarlett Solo USB device here. Doesn't work oob in 16.04.

Following the 3 steps from #54 enables me to select the device in sound settings and make things work. Afer every resume from suspend or reboot, I have to follow this procedure again. So it isn't a permenant fix.

Mario Limonciello (superm1) wrote :

@t-no,

To confirm if this is caused by fwupd or caused by a general suspend bug with that USB device, can you please kill fwupd before suspend?

description: updated
TinusXcentricus (t-no) wrote :

With a working USB sound device, just before suspending execute "sudo killall fwupd", all is well after resuming.

Mario Limonciello (superm1) wrote :

@t-no,

Hmm OK. Can you please add --verbose output to fwupd before your suspend?

1) sudo killall fwupd
2) sudo /usr/lib/x86_64-linux-gnu/fwupd/fwupd -v 2>&1 | tee fwupd_debug.log
3) make sure audio is working properly
4) suspend
5) resume
6) if it's not working still please provide the debug output

TinusXcentricus (t-no) wrote :

After step 1), I have to reconnect my usb device and reselect it in sound settings. After step 2) I don't have sound anymore. What do you need Mario?

TinusXcentricus (t-no) wrote :

If I reconnect device after step 2) it works again.

TinusXcentricus (t-no) wrote :
Download full text (4.4 KiB)

Got sound after resume. Still: here's the output.

11:21:55 Verbose debugging enabled (on console 0)
11:21:55 adding plugin /usr/lib/x86_64-linux-gnu/fwupd-plugins-1/libfu_plugin_steelseries.so
11:21:55 adding plugin /usr/lib/x86_64-linux-gnu/fwupd-plugins-1/libfu_plugin_test.so
11:21:55 performing init() on test
11:21:55 Loading fallback values from /etc/fwupd.conf
11:21:55 adding udev device: /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0
11:21:55 fixing GUID 0x10de:0x1401->73ac5e23-4c05-513b-8626-d1c942d9f73b
11:21:55 emit added from Udev: ro__sys_devices_pci0000_00_0000_00_03_0_0000_03_00_0
11:21:55 using e975765e-c505-5764-8f9d-3881db20dc21 for USB\VID_1235&PID_801C
11:21:55 emit added from DFU: usb:00:01:01
11:21:55 emit added from UEFI: UEFI-7039436b-6acf-433b-86a1-368ec2ef7e1f-dev0
11:21:55 emit added from USB: usb:00:01:02:03
11:21:55 emit added from USB: usb:00:01:02:02
11:21:55 emit added from USB: usb:00:01:01
11:21:55 already added usb:00:01:01 by DFU, ignoring same device from USB
################################################################################ @0460ms AsStore:load 460ms
################################################################################ @0460ms AsStore:load{per-system} 460ms
## @0016ms AsStore:app-info{/var/lib/app-info/yaml/nl.archive.ubuntu.com_ubuntu_dists_xenial_multiverse_dep11_Components-amd64.yml.gz} 13ms
## @0016ms AsStore:store-from-file 13ms
   #################### @0138ms AsStore:app-info{/var/lib/app-info/yaml/nl.archive.ubuntu.com_ubuntu_dists_xenial_main_dep11_Components-amd64.yml.gz} 119ms
   #################### @0138ms AsStore:store-from-file 119ms
                        #### @0164ms AsStore:app-info{/var/lib/app-info/yaml/nl.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_dep11_Components-amd64.yml.gz} 24ms
                        #### @0164ms AsStore:store-from-file 24ms
                            ################################################## @0453ms AsStore:app-info{/var/lib/app-info/yaml/nl.archive.ubuntu.com_ubuntu_dists_xenial_universe_dep11_Components-amd64.yml.gz} 289ms
                            ################################################## @0453ms AsStore:store-from-file 289ms
                                                                                  ## @0490ms FuMain:coldplug 17ms
                                                                                  # @0480ms FuMain:coldplug{Udev} 8ms
                                                                                   # @0480ms FuProviderUdev:coldplug{pci} 5ms
                                                                                    # @0490ms FuMain:coldplug{USB} 8ms
11:21:55 FuMain: acquired name: org.freedesktop.fwupd
11:21:55 devices n...

Read more...

Mario Limonciello (superm1) wrote :

@t-no,

Since you're having the failure pre-suspend per #61, can you please confirm you've actually installed the package from the proposed repository as explained in #51?

You can then please confirm your package version using this command:

# apt policy fwupd

Thanks

TinusXcentricus (t-no) wrote :

I'm sorry. Must have missed the package from #51.

$ apt policy fwupd
fwupd:
  Geïnstalleerd: 0.7.0-0ubuntu4.1
  Kandidaat: 0.7.0-0ubuntu4.1
  Versietabel:
 *** 0.7.0-0ubuntu4.1 500
        500 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.7.0-0ubuntu4 500
        500 http://nl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Will test tomorrow. Thanks so far!

TinusXcentricus (t-no) wrote :

Enabled proposed and all is well! Sorry for the confusion...

Welly Wu (wellywu) wrote :

I read this entire bug report and I added the FWUPD PPA and followed the directions. I own an Oppo Digital HA-1 desktop DAC and headphone amplifier. After unplugging it, shutting down, booting up, logging in, plugging it back in, I can not see my HA-1 in sound devices and it is stuck at DSD 12.288 MHz. I can not hear audio using it and my Sennheiser HD-800 headphones.

Mario Limonciello (superm1) wrote :

The ppa doesn't actually have the same fix that went into proposed. Can you
please make sure you enable proposed and then check again?

If you are still having problems please confirm the version of fwupd that
is installed using

# apt policy fwupd

On Sun, Jun 19, 2016, 09:35 Welly Wu <email address hidden> wrote:

> I read this entire bug report and I added the FWUPD PPA and followed the
> directions. I own an Oppo Digital HA-1 desktop DAC and headphone
> amplifier. After unplugging it, shutting down, booting up, logging in,
> plugging it back in, I can not see my HA-1 in sound devices and it is
> stuck at DSD 12.288 MHz. I can not hear audio using it and my Sennheiser
> HD-800 headphones.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1574079
>
> Title:
> USB audio device is not recognized after startup in 16.04
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079/+subscriptions
>

Welly Wu (wellywu) wrote :

I enabled xenial-proposed on my late 2015 Sager NP8657 [Clevo P650-RE3] gaming laptop with Ubuntu 16.04.0 64 bit LTS. Should I go ahead with sudo apt-get upgrade and sudo apt-get dist-upgrade? Is this going to mess up my Ubuntu? So, after I enable proposed and do the upgrade, what should I do?

Welly Wu (wellywu) wrote :

I followed the instructions carefully and it is fixed now. My Oppo Digital HA-1 and Chord Mojo just work right out of the box after enabling xenial-proposed.

Mario Limonciello (superm1) wrote :

Thanks. So everyone who has enabled proposed is fi Ed. I think it's safe to roll this out to updates now. We've waited 10 says with it in proposed and no regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwupd - 0.7.0-0ubuntu4.2

---------------
fwupd (0.7.0-0ubuntu4.2) xenial-proposed; urgency=medium

  * Fix USB audio devices not working properly (LP: #1574079)

 -- Mario Limonciello <email address hidden> Wed, 08 Jun 2016 21:31:00 -0500

Changed in fwupd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for fwupd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Chris (chrisc-k) on 2016-07-14
Changed in fwupd (Ubuntu Xenial):
assignee: nobody → Chris (chrisc-k)
assignee: Chris (chrisc-k) → nobody
Adam Wyn Roberts (adda) on 2016-12-01
affects: fwupd (Ubuntu) → fwupdate-signed (Ubuntu)
Changed in fwupdate-signed (Ubuntu):
assignee: nobody → Adam Wyn Roberts (adda)
assignee: Adam Wyn Roberts (adda) → nobody
affects: fwupdate-signed (Ubuntu) → fwupd (Ubuntu)
Aron Hendrickson (dorag) wrote :

My Usb Audio is still not working im new to ubuntu so unsure how to fix it Please can someone help me

Im using a Logitech G930 Headset - Wireless Usb Version.
Im running Ubuntu 16.10 Xenial
Im Using a Dell Optiplex 755 DT Please see specs AT THIS LINK http://pastebin.com/SEFMvJDq
Ubuntu Software Centre Says that everything is up to date

System Settings >> Sound >> Output / Imput - No sound devices found not even integrated sound card

w.w.w.p.a.s.t.e.b.i.n.c.o.m./.S.E.F.M.v.J.D.q.
REMOVE ALL THE DOTS APART FROM WWW. AND .COM

adira kolm (didbidt) wrote :

This ist still not fixed
I removed fwupd and rebooted, then it worked.

ubuntu 18.04.1 LTS
In case you are helped with infos I can provide them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers