fsprotect in karmic have unmet dependencies

Bug #397921 reported by Dimitris Diamantis on 2009-07-10
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fsprotect (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: fsprotect

The fsprotect depends on aufs-modules but this package does not exists on ubuntu repositories.
Since ubuntu 8.10 the module aufs.ko is in "linux-image-*" package, so fsprotect should depends on linux-image-generic.
The problem here is that there is no more aufs.ko in any "linux-image-*" package in ubuntu 9.10.

Jonas Pedersen (jonasped) wrote :

I can confirm this bug.

If I look at Julian's comment in bug #384987 it is suggested that both aufs-modules and aufs-sources should be removed from Karmic and AUFS2 should be used instead. It does however not look like AUFS2 is available in Karmic.

Changed in fsprotect (Ubuntu):
status: New → Confirmed
Julian Andres Klode (juliank) wrote :

AUFS2 is included in the Ubuntu kernel, and the aufs package will be removed soon, as it is broken and unusable. If you need aufs-tools, the package is broken and should be removed. Otherwise, please remove the dependency.

Another option would be uploading tools for aufs2, but as we are in feature freeze, this does not seem like a good idea.

Dimitris Diamantis (ftso) wrote :

Fsprotect needs auf-tools to mount aufs. It can't work without this.
I think that you should upload the new aufs-tools in this version of ubuntu (9.10) because fsprotect is very useful especially for public desktop pcs.

Julian Andres Klode (juliank) wrote :

I don't see you calling any command from aufs-tools. You don't need aufs-tools for mounting such a filesystem, so I guess fsprotect will also work without aufs-tools.

Stefanos Harhalakis (v13) wrote :

Hello,

The aufs-tools depedency is there because it contains mount.aufs / umount.aufs. AFAIK those are called by mount/umount (no?). Are you sure there is no need for those files to exist? They claim to properly update mtab and umount.aufs calls auplink when umounting.

Also, I'd be glad if you forwarded those bugs either to the Debian package via Debian BTS or to me directly.

Oliver Joos (oliver-joos) wrote :

With Karmic alpha it is no more possible to create a bootable USB stick with persistent data (see Gnome menu "System"). This might be caused by this bug. Such a stick is nice to demonstrate or test-drive Ubuntu! So if I am right then please give this bug some Importance.

jesbecker (jesbecker) wrote :

All,
   I decided to research a way to modify the deb as there has not been much activity on resolving this issue. I extracted the deb and change it's dependencies to look for aufs-source instead of aufs-modules. I then rebuilt it. My work has been attached.
You should be able to use fsprotect by first installing aufs:
sudo apt-get install aufs*

Next, download and install fsprotect_1.0.3_all.deb (attached) then:
sudo dpkg -i fsprotect_1.0.3_all.deb

For what ever reason, the gui package manager thinks my package is corrupt, however, it installs fine through dpkg command line.

Also, apparmor and fsprotect will not work well together. You will need to also remove apparmor (sudo apt-get remove apparmor) before utilizing fsprotect.

Jes

Julian Andres Klode (juliank) wrote :

I would like to request the removal of aufs from karmic and lucid; as it is broken. The same applies to fsprotect, although this could be fixed by dropping the dependencies on aufs*.

Stefanos Harhalakis (v13) wrote :

Version 1.0.5 fixes this problem (and some others). It is currently available for Debian unstable but it will soon enter testing. (To the Ubuntu maintainer:) Please try this version and report bugs in Debian's bugtracker or directly to me via e-mail.

Dimitris Diamantis (ftso) wrote :

I installed the version 1.0.5 from debian sid repo on my kubuntu 10.04 (2.6.32-22-generic) and it seems that works perfect.

Julian Andres Klode (juliank) wrote :

> Version 1.0.5 fixes this problem (and some others). It is currently available for Debian unstable but it will soon enter testing.
Closing this bug then, as the package has been synced ~45 hours ago.

> (To the Ubuntu maintainer:)
Well, actually there is no person maintaining it; it is synced directly from Debian without changes (thus 1.0.5 is in maverick now).

> Please try this version and report bugs in Debian's bugtracker or directly to me via e-mail.
You can subscribe to bugs in your package in Ubuntu via Launchpad (by clicking on "Subscribe to bug mail" on https://launchpad.net/ubuntu/+source/fsprotect [right side]) or using the Debian PTS. This would be helpful, since no one on the Ubuntu side actually seems to care about/take care of this package; and thus there is no one to forward those bugs to you.

Changed in fsprotect (Ubuntu):
status: Confirmed → Fix Released

In Lucid this package depends on aufs-modules again which is not in the Ubuntu repositories. I guess this is because of the lack of a Ubuntu maintainer and direct sync with the Debian as mentioned above.

Changed in fsprotect (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers