recovery mode fsck stalling

Bug #1430312 reported by Galen Thurber on 2015-03-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Undecided
Unassigned

Bug Description

happens on many x64 kernels
3.2.0-77-generic
3.2.0-76-generic
3.2.0-75-generic
3.2.0-72-generic

booting to recovery mode then using fsck
fsck will run on fstab partitions
then stall and not return to the recovery menu

RAM has been tested and passed
hard has been tested and passed (even booted to a live linux and gparted reports no errors)

what happens after fsck that is stalling ?

this question is similar to
https://bugs.launchpad.net/ubuntu/+source/friendly-recovery/+bug/1061239

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1430312/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → friendly-recovery (Ubuntu)
Galen Thurber (godfree2) wrote :

still a problem
3.2.0-79-generic

hard drive is SATA
partition is primary
partition passes all tests from external drive bootups

added "verbose debug" to recovery's kernel line
no information to report

Galen Thurber (godfree2) wrote :

has been run fsck for over 7 hours, still stalls

Galen Thurber (godfree2) wrote :

update.
I attempted an update from 12.04.5 to 14.04.2 but the upgrade was corrupted.
Then I did a clean install with Linux Lite2.4
kernels
3.13.0-49-generic
3.13.0-24-generic
and that similar distro had the same stalling.
I did many rechecks of RAM, gsmartdrive full disk check. No errors.
Then I disconnected my USB hub (located in my floppy bay)
and
commented out my swap entry in /etc/fstab
and reformatted the swap partition to ext3

My fstab was using ubuntu created UUID entries and all entries were working.

I did more recovery mode fsck checks, they did not stall.
I reconnected my USB hub to differing USB jacks on the motherboard,
all recovery fsck checks worked.

I think it is fair to assume that recovery mode fsck was stalling when checking the swap partition.
do you think this correct?
should recovery mode be checking the swap partition at all?

Galen Thurber (godfree2) wrote :

also happening on Zorin 9 lite on another machine
3.13 kernel

Galen Thurber (godfree2) wrote :

fresh install of xubuntu 14.04 LTS
3.16.0-37-generic
stalling not happening.
if it does I will update report

Galen Thurber (godfree2) wrote :

stalling is back under kernel 4.4.0-47 -45 -37 under xubuntu16.04 64bit

If I run fsck from recovery mode
it stalls after it does
started load / save RF kill switch status

The drive and partitions are ok when checked from other live boots.

Galen Thurber (godfree2) wrote :

seems ok now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions