system hangs after selecting certain menu items inRecovery Menu

Bug #1061239 reported by SteVe Cook
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Undecided
Unassigned

Bug Description

 In recovery mode - after selecting any item that requires disks to be remounted read/write, such as Enable networking, system hangs. This occurs in Ubuntu, Xubuntu & Lubuntu Quantal 12.10

SteVe Cook (yorvyk)
affects: ubuntu → friendly-recovery (Ubuntu)
Revision history for this message
SteVe Cook (yorvyk) wrote :

Discovered which package it is - friendly-recovery 0.2.25

Tried this on four different machines.

If I select Drop to root and run 'service network-manager start' I get the following error message:

Could not get the system bus. Make sure the message bus daemon is running! Message: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory.

/var/run/dbus/system_bus_socket does exist and dbus is not running. If I drop to root and start dbus then exit back to the menu and select Networking the system still hangs after agreeing to remount filesystem read/write.

Revision history for this message
Avi Greenbury (bigreds) wrote :

I'm not certain if I'm affected by the same problem or not. I do this:

1) Choose 'enable networking'
2) Say 'yes' to the prompt informing me that this will remount my / fs and everything else in fstab
3) See fsck start
4) Don't get anything else

Attached is a photo from about half an hour after saying 'yes'. On reboot I saw a pythony stack trace scroll up the screen quite quickly; not sure how to extract that data in recovery mode, though.

Revision history for this message
giorgosts (tsipoti) wrote :

Ctrl+C works by initiating the resume action.

This bug left me in an unbootable state because of a syntax error in xorg.conf. I was forced to use an external recovery live CD to recover.

The solution was to remove friendly-recovery. Now I have root prompt with read-write privileges.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in friendly-recovery (Ubuntu):
status: New → Confirmed
Revision history for this message
John (johnubuntu) wrote :

Still no progress...?

For people still encountering it, with /dev/sda1 being your /:
1. 'root Drop to root shell prompt'
2. optional, fsck -f /dev/sda1
3. mount /dev/sda1 / -o remount,rw
4. you now can write on /

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions