dogtag-pki needs porting work for tomcat 8.5

Bug #1716842 reported by Matthias Klose on 2017-09-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dogtag-pki (Debian)
Fix Released
Unknown
dogtag-pki (Ubuntu)
Undecided
Unassigned
freeipa (Ubuntu)
Undecided
Unassigned

Bug Description

dogtag-pki needs porting work for tomcat8, demoting to proposed for now, plus the freeipa dependency.

Matthias Klose (doko) on 2017-09-13
tags: added: block-proposed
Changed in dogtag-pki (Debian):
status: Unknown → New
Timo Aaltonen (tjaalton) wrote :

upstream hasn't started working on it yet, will take months

Matthias Klose (doko) wrote :

well, you could package an older tomcat version as a legacy package

Steve Langasek (vorlon) wrote :

I don't understand what this bug is about and how you have determined that porting work is required. dogtag-pki build-depends on libtomcat8-java, and has built successfully. There appears to be an autopkgtest problem on armhf, but that is not the issue you reported here.

Changed in dogtag-pki (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

It built against old tomcat 8.0.x, but tomcat 8.5 got synced and dogtag (& tomcatjss) fail to build with it. I've packaged tomcat8.0 as a separate source package and it's in the archive now. Next I'll modify tomcatjss & dogtag-pki to use it. Tomcat8.0 will be removed before 18.04 releases, which is also when it is expected upstream has finished porting these..

Matthias Klose (doko) wrote :

removed the block-proposed tag

tags: removed: block-proposed
Changed in dogtag-pki (Debian):
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2017-10-27
summary: - dogtag-pki needs porting work for tomcat8
+ dogtag-pki needs porting work for tomcat 8.5
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freeipa (Ubuntu):
status: New → Confirmed
Juan Tobon (juantobon78) wrote :
Download full text (4.2 KiB)

Please forgive my tardiness it is my first time posting on this ticketing system.

I am trying to get freeIPA to work on Ubuntu 18.04 daily build (upgraded to latest packages). This bug is a mayor blocker for our use of freeIPA on Ubuntu 18.04. My questions are brief will dogtags-pki make the release? Can the tomcat 8.0.32 packages be made available as part of the release? Or via Backports?

For completeness:

1. I am running the latest beta packages:

dpkg -l | grep pki
ii dogtag-pki 10.6.0~beta2-2 all Dogtag Public Key Infrastructure (PKI) Suite
ii dogtag-pki-console-theme 10.6.0~beta2-2 all Certificate System - PKI Console User Interface
ii dogtag-pki-server-theme 10.6.0~beta2-2 all Certificate System - PKI Server User Interface
ii pki-base 10.6.0~beta2-2 all Certificate System - PKI Framework
ii pki-base-java 10.6.0~beta2-2 all Certificate System - PKI Framework -- java client support
ii pki-ca 10.6.0~beta2-2 all Certificate System - Certificate Authority
ii pki-console 10.6.0~beta2-2 all Certificate System - PKI Console
ii pki-javadoc 10.6.0~beta2-2 all Certificate System - PKI Framework Javadocs
ii pki-kra 10.6.0~beta2-2 all Certificate System - Data Recovery Manager
ii pki-ocsp 10.6.0~beta2-2 all Certificate System - Online Certificate Status Protocol Manager
ii pki-server 10.6.0~beta2-2 amd64 Certificate System - PKI Server Framework
ii pki-tks 10.6.0~beta2-2 all Certificate System - Token Key Service
ii pki-tools 10.6.0~beta2-2 amd64 Certificate System - PKI Tools
ii pki-tps 10.6.0~beta2-2 all Certificate System - Token Processing System

1. On tomcat8.5 (openjdk 8):

sudo dpkg -l | grep tomcat
ii libtomcat8-java 8.5.29-1 all Apache Tomcat 8 - Servlet and JSP engine -- core libraries
ii libtomcatjss-java 7.3.0~git20180214-1 all JSSE implementation using JSS for Tomcat
ii tomcat8 8.5.29-1 all Apache Tomcat 8 - Servlet and JSP engine
ii tomcat8-common 8.5.29-1 all Apache Tomcat 8 - Servlet and JSP engine -- common files
ii tomcat8-user 8.5.29-1 all Apache Tomcat 8 - Servlet and JSP engine -- tools to create user instances

sudo dpkg -l | grep openjdk...

Read more...

Timo Aaltonen (tjaalton) wrote :

10.6.0~beta2 landed in bionic

Changed in freeipa (Ubuntu):
status: Confirmed → Invalid
Changed in dogtag-pki (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.