Printer setup tools list PPDs for which there are no driver executables in Ubuntu

Bug #150985 reported by Till Kamppeter on 2007-10-09
16
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
High
Unassigned
foomatic-db-engine (Ubuntu)
High
Unassigned
ghostscript (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: foomatic-db

The foomatic-db package makes several PPDs available for which the distribution does not contain the appropriate driver executables.

The fix is easy and has no risk of regressions, so no problem to apply it in Gutsy:

- Ghostscript has a bug in the Makefiles which makes some .upp files not getting installed. This can be fixed by a simple patch of a few lines. These .upp files were shipped with Feisty already and did not raise any complaints.
- Some drivers are really not included in the distro. Their XML files should be removed from the foomatic-db package

These steps are very easy to implewment and cannot break anything (keep in mind that a printer printing in a bad quality is better then a printer not printing at all, especially if the printer setup tools list the printer as supported).

Changed in foomatic-db:
importance: Undecided → High
status: New → Confirmed
Changed in ghostscript:
importance: Undecided → High
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :
Download full text (3.2 KiB)

Attached is a printer driver test utility with which all drivers or even the printing paths of all combos of supported printers and drivers can be tested. It creates for all drivers (or all printer/driver combos, for that change "driversonly=1" to "driversonly=0" near the end) a print queue (pointing into a file), sends a job, checks the results, and deletes the queue. It tracks errors in error_log, the length of the output being less than 1kB, and the execution of the job taking more than one minute. The results on Gutsy are (using the CUPS test page /usr/share/cups/data/testprint.ps as input file, "OK"s skipped):

----------
Testing Alps MD-1000 Foomatic/ppmtomd (recommended)... ...... FAILED!
Testing Apple Color StyleWriter 1500 Foomatic/lpstyl (recommended)... ..... FAILED!
Testing Avery Personal Label Printer Foomatic/pbm2lwxl (recommended)... ..... FAILED!
Testing Canon BJC-680J Foomatic/bjc800j (recommended)... ..... FAILED!
Testing Canon BJC-3000 Foomatic/bjc6000a1.upp... ..... FAILED!
Testing Canon BJC-3000 Foomatic/s400a1.upp... ..... FAILED!
Testing Compaq IJ900 Foomatic/pbm2l7k... ...... FAILED!
Testing Epson PM 760C Foomatic/PM760p.upp... ..... FAILED!
Testing Epson PM 820C Foomatic/PM820p.upp... ..... FAILED!
Testing Epson Stylus Color 670 Foomatic/Stc670p.upp... ..... FAILED!
Testing Epson Stylus Color 670 Foomatic/Stc670pl.upp... ..... OUTPUT FILE TOO SMALL!
Testing Epson Stylus Color 680 Foomatic/Stc680p.upp... ..... FAILED!
Testing Epson Stylus Color 740 Foomatic/stc740ih.upp... ..... FAILED!
Testing Epson Stylus Color 760 Foomatic/Stc760p.upp... ..... FAILED!
Testing Epson Stylus Color 777 Foomatic/Stc777p.upp... ..... FAILED!
Testing Epson Stylus Photo 720 Foomatic/Stp720p.upp... ..... FAILED!
Testing Epson Stylus Photo 870 Foomatic/Stp870p.upp... ..... FAILED!
Testing HP DeskJet 710C Foomatic/pnm2ppa (recommended)... ...... FAILED!
Testing Imagen ImPress Foomatic/imagen (recommended)... ...... FAILED!
Testing Lexmark 1000 Foomatic/lm1100 (recommended)... ..... FAILED!
Testing Lexmark 2030 Foomatic/pbm2l2030 (recommended)... ........ FAILED!
Testing Lexmark 2050 Foomatic/c2050 (recommended)... ..... FAILED!
Testing Lexmark 2070 Foomatic/c2070 (recommended)... ..... FAILED!
Testing Lexmark X125 Foomatic/drv_x125 (recommended)... ..... FAILED!
Testing Minolta PagePro 1200W Foomatic/min12xxw (recommended)... ..... FAILED!
Testing Pentax PocketJet 200 Foomatic/pentaxpj (recommended)... ..... FAILED!
Testing Samsung ML-85G Foomatic/ml85p (recommended)... ..... FAILED!
Testing Sharp AJ-1800 Foomatic/sharp.upp... ..... FAILED!
Testing SiPix Pocket Printer A6 Foomatic/sipixa6.upp (recommended)... ..... OUTPUT FILE TOO SMALL!
Testing Tektronix 3693d color printer, 8-bit mode Foomatic/t4693d8 (recommended)... ..error running lpadmin.
----------

All failures with .upp files get fixed by fixing the installation procedure in the "ghostscript" package. The other failures get fixed by removing the appropriate driver XMLs from the "foomatic-db" package. The very last with the Tektronix is a simple to fix bug in foomatic-db-engine.

Only problem are min12xxw and pnm2ppa. These are not shipped on the desktop CDs for space reasons but they ...

Read more...

Changed in foomatic-db-engine:
importance: Undecided → High
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Sorry, I was wron with "pnm2ppa" and "min12xxw". They errored here because they were broken in my installation. So this bug is indeed fixed by doing the steps described in my initial posting.

Till Kamppeter (till-kamppeter) wrote :
Changed in foomatic-db:
status: Confirmed → Fix Committed
Changed in foomatic-db-engine:
status: Confirmed → Fix Committed
Changed in ghostscript:
status: Confirmed → Fix Committed
Till Kamppeter (till-kamppeter) wrote :
Download full text (8.8 KiB)

Test redone with all 3 fixed packages:

----------
Testing Alps MD-1000 Foomatic/md2k... ....... OK
Testing Alps MD-1300 Foomatic/md1xMono... ..... OK
Testing Alps MD-5000 Foomatic/md5k... ....... OK
Testing Alps MD-5000 Foomatic/md50Eco... ..... OK
Testing Alps MD-5000 Foomatic/md50Mono... ..... OK
Testing Anitech M24 Foomatic/epson (recommended)... ..... OK
Testing Apollo P-1200 Foomatic/pcl3 (recommended)... ..... OK
Testing Apollo P-2100 Foomatic/gutenprint-ijs-simplified.5.0... ......... OK
Testing Apollo P-2100 Foomatic/gutenprint-ijs.5.0... ......... OK
Testing Apollo P-2100 Foomatic/hpijs (recommended)... ...... OK
Testing Apollo P-2200 Foomatic/cdj550... ..... OK
Testing Apple Dot Matrix Foomatic/appledmp (recommended)... ..... OK
Testing Apple ImageWriter Foomatic/iwhi (recommended)... ..... OK
Testing Apple LaserWriter 4/600 Foomatic/Postscript (recommended)... ..... OK
Testing Apple LaserWriter Select 360 Foomatic/ljet2p... ..... OK
Testing Brother DCP-1200 Foomatic/hl1250 (recommended)... ..... OK
Testing Brother DCP-8045D Foomatic/hl7x0... ..... OK
Testing Brother DCP-8045D Foomatic/lj5gray... ..... OK
Testing Brother DCP-8045D Foomatic/ljet4... ..... OK
Testing Brother DCP-8045D Foomatic/pxlmono... ..... OK
Testing Brother HJ-400 Foomatic/lq850 (recommended)... ..... OK
Testing Brother HL-4Ve Foomatic/laserjet (recommended)... ..... OK
Testing Brother HL-8 Foomatic/ljetplus (recommended)... ..... OK
Testing Brother HL-10h Foomatic/lj4dith... ...... OK
Testing Brother HL-10V Foomatic/ljet3 (recommended)... ..... OK
Testing Brother HL-1650 Foomatic/ljet4d... ..... OK
Testing Brother MFC 7150C Foomatic/epsonc (recommended)... ..... OK
Testing Canon BJ-5 Foomatic/bj10e (recommended)... ..... OK
Testing Canon BJ-10v Foomatic/bj10v... ...... OK
Testing Canon BJ-10v Foomatic/bj10vh (recommended)... ..... OK
Testing Canon BJ-30 Foomatic/bj200... ..... OK
Testing Canon BJC-50 Foomatic/bjc600... ...... OK
Testing Canon BJC-250 Foomatic/bjc250gs... ....... OK
Testing Canon BJC-250 Foomatic/bjc610a0.upp... ...... OK
Testing Canon BJC-800 Foomatic/bjc800 (recommended)... ...... OK
Testing Canon BJC-880J Foomatic/bjc880j (recommended)... ..... OK
Testing Canon BJC-3000 Foomatic/bjc6000a1.upp... ...... OK
Testing Canon BJC-3000 Foomatic/s400a1.upp... ...... OK
Testing Canon BJC-8200 Foomatic/bj8pa06n.upp (recommended)... ....... OK
Testing Canon LBP-4+ Foomatic/lbp8 (recommended)... ..... OK
Testing Canon LBP-4U Foomatic/cjet (recommended)... ..... OK
Testing Canon LBP-310 Foomatic/lbp310 (recommended)... ..... OK
Testing Canon LBP-320 Pro Foomatic/lbp320 (recommended)... ..... OK
Testing Canon LBP-470 Foomatic/lips4... ..... OK
Testing Canon LBP-470 Foomatic/lips4v (recommended)... ..... OK
Testing Canon LIPS-II+ Foomatic/lips2p (recommended)... ..... OK
Testing Canon LIPS-III Foomatic/lips3 (recommended)... ..... OK
Testing Citizen ProJet IIc Foomatic/cdj500 (recommended)... ..... OK
Testing CItoh M8510 Foomatic/m8510 (recommended)... ..... OK
Testing Compaq IJ750 Foomatic/lxm3200-tweaked (recommended)... ....... OK
Testing Compaq IJ900 Foomatic/lex5700 (recommended)... ..... OK
Testing Compaq IJ900 Foomatic/lxm5700m... ..... OK
Testing DEC...

Read more...

Martin Pitt (pitti) wrote :

foomatic-db and -engine patches look fine. I cannot verify the ghostscript change, if you tested it properly, and you are 150% sure that it does not cause regressions, this is ok for me as well.

Won't make it into RC probably, but should be uploaded now to make the final release.

Jonathan Riddell (jr) wrote :

uploaded

Till Kamppeter (till-kamppeter) wrote :

The ghostscript change does nothing more than also installing the *.upp files in contrib/uniprint/ of the source tree. They were all already in Feisty (as part of gs-esp). There no one reported bugs concerning these files. And now my all-drivers test lets Ghostscript work correctly when these files are used for a print queue. None of the already existing files is modified by this change of the Ghostscript package. And the new *.upp files get only used if an appropriate PPD is selected (and these PPDs did not work at all without the *.upp files).

Till Kamppeter (till-kamppeter) wrote :

foomatic-db-engine (3.0.2-20070719-0ubuntu4) gutsy; urgency=low

  * debian/patches/30_ppd_generator_broken_on_printer_name_with_comma.patch:
    PPD gnerator for CUPS did not list the PPDs correctly on printer names
    containing a comma (LP: #150985).

 -- Till Kamppeter <email address hidden> Tue, 9 Oct 2007 19:07:39 +0100

foomatic-db (20070919-0ubuntu3) gutsy; urgency=low

  * debian/rules: Deleted entries for drivers not shipped with Ubuntu Gutsy
    (LP: #150985).

 -- Till Kamppeter <email address hidden> Tue, 9 Oct 2007 17:26:28 +0100

Changed in foomatic-db:
status: Fix Committed → Fix Released
Changed in foomatic-db-engine:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

ghostscript (8.61.dfsg.1~svn8187-0ubuntu3) gutsy; urgency=low

  [ Till Kamppeter ]
  * debian/rules: Install missing *.upp files (usptream bug, LP: #150985).

  [ Martin Pitt ]
  * debian/rules: Clean files from package ghostscript which are moved to
    ghostscript-doc on i386 (where arch-all packages are built). On all
    non-i386 platforms the files remained in the main package, which causes
    file conflicts and unnecessary package growth. This is a quick hack for
    Gutsy. In Hardy, this horribly broken build system should be fixed
    properly.

 -- Martin Pitt <email address hidden> Tue, 09 Oct 2007 23:00:28 +0200

Changed in ghostscript:
status: Fix Committed → Fix Released
soren121 (soren121) wrote :

Umm, my DeskJet 710C still isn't working, even with the fixed packages provided. And I don't want to have to print to the LaserJet on the other side of my house all day. :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers