Cups filters are not bundled with Ubuntu altough the PPD are present

Bug #59324 reported by Jonathan Ernst on 2006-09-07
4
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Medium
Unassigned
gutenprint (Ubuntu)
Medium
Unassigned

Bug Description

This bug affects at least the intallation of the following printers :

- Lexmark X73
- Brother P-touch QL-550

These printer are correctly recognized by the printer installation Wizard in Ubuntu. The correct driver is automatically selected but then it's not possible to print anything. After activating the logs in foomatic config file you can see that the binary filters are missing (rastertoptch for the Brother and drv_z42 for the lexmark).

I had to find out about this issues for a friend, then find the required source filters, install build-essential, cups-dev and other headers then compile and install the filters. It's rather confusing and not user friendly for non-savy users.

See :
- http://linuxprinting.org/show_driver.cgi?driver=ptouch
- http://www.diku.dk/~panic/P-touch/
- http://linuxprinting.org/show_printer.cgi?recnum=Lexmark-X73
- http://www.linuxprinting.org/download/printing/drv_z42-0.4.3.tar.bz2

What version of Ubuntu are you using?

I confirm this using Edgy 20061015.

If you currently set up a printer with gnome-cups-manager, KDE Print Manager or CUPS web interface, e.g. a Minolta MagiColor 2430DL that uses foo2zjs binary driver you are able to do so without problems even if the foo2zjs package is not installed. This is also the case for printer drivers that have no Ubuntu package, e.g. drv_z42 (Lexmark X73). To avoid this I believe we should split up foomatic-db into foomatic-db-gs-builtin and foomatic-db-gs-filter. The package foomatic-db-gs-filter should depend on ALL the binary Ghostscript filter packages available in Ubuntu like foo2zjs, pnm2ppa, ...
We should remove drivers an options from foomatic-db-gs-filter that have no Ubuntu package.

Off course we should have as much drivers as possible packed for Ubuntu, if the driver license allows it. It should be no problem to pack drivers drv_z42 and ptouch for Ubuntu since both seem to have a GPL license.

Changed in foomatic-filters-ppds:
status: Unconfirmed → Confirmed

What is your opinion about this issue Till?

Note (Off Topic):
The link http://www.xs4all.nl/~pastolk/ on the linuxprinting.org Lexmark X73 page: http://www.linuxprinting.org/show_driver.cgi?driver=drv_z42&fromprinter=Lexmark-X73 seems to be broken.

Jonathan Ernst (jonathan.ernst) wrote :

>What version of Ubuntu are you using?
I have seen this problem on both Dapper and Edgy.

Till Kamppeter (till-kamppeter) wrote :

Pascal, this looks like this driver is abandoned upstream. I have the last source tarball due to having it included in Mandriva all the time. Seems that I have to upload this tarball to linuxprinting.org itself. I proceeded this way already with other drivers which were taken from the internet by their authors.

This bug in general will be addressed for all distributions by the upcoming linuxprinting.org resp. FSG OpenPrinting development. See

http://www.freestandards.org/en/OpenPrinting/SummitLexington

Changed in foomatic-db:
importance: Undecided → Medium
Till Kamppeter (till-kamppeter) wrote :

Jonathan, to get your P-Touch working with the source tarball from upstream (this is a workaround, not a fix), see the following forum thread:

http://forums.freestandards.org/read.php?24,49

Till Kamppeter (till-kamppeter) wrote :

Pascal, I have now re-hosted the drv_z42 driver as

http://www.linuxprinting.org/download/printing/drv_z42-0.4.3.tar.bz2

I will update the "drv_z42" entry on linuxprinting.org soon.

Till Kamppeter (till-kamppeter) wrote :

Jonathan, can you try out whether your Lexmark X73 works with Gutenprint? If your printer setup tool does not offer you Gutenprint as a driver choice, please choose the Lexmark Z42 or Z43 as printer model in the tool. Tell with which one (Z42 or Z43) you get the better results.

If this test is successfull I will mark the "drv_z42" as obsolete in Foomatic (and recommend to use Gutenprint instead) and we do not need to ship that driver with the distro then. Gutenprint ships with every distro.

Changed in foomatic-db:
status: Confirmed → Needs Info
Till Kamppeter (till-kamppeter) wrote :

On the linuxprinting.org forums the X73 is reported to work with the Z42 driver:

http://forums.freestandards.org/read.php?29,297

So I will mark the drv_z42 driver as obsolete soon.

Changed in foomatic-db:
status: Needs Info → In Progress
Till Kamppeter (till-kamppeter) wrote :

I have made new Gutenprint packages:

Source:
http://www.freestandards.org/~till/tmp/ubuntu/feisty/gutenprint/

Binaries:
http://www.freestandards.org/~till/tmp/ubuntu/feisty/gutenprint/binary/

which explicitly support the Lexmark X73 and Compaq IJ1200. This way the "drv_z42" can be considered obsolete. These changes I will also do on Gutenprint upstream.

Changed in gutenprint:
importance: Undecided → Medium
status: Unconfirmed → Fix Committed

Fixed issue with Lexmark X73 and Compaq IJ1200 in foomatic-db upstream, now for them Gutenprint is the recommended driver and drv_z42 is marked as obsolete. So this driver will disappear in the next Ubuntu package of foomatic-db.

I have submitted a new version of foomatic-db for inclusion in Ubuntu now:

foomatic-db (20070117-0ubuntu1) feisty; urgency=low

  * New upstream release
    o Removed execution data of drivers where this data is shipped with the
      driver package: epsonepl, foo2hp, foo2kyo, foo2zjs, lz11-V2, ptouch
    o New driver entries: foo2lava, foo2xqx, pxljr
    o Drivers marked obsolete: pbm2ppa, pbm2zjs, ppmtocpva, pxl1010
    o 17 new Ricoh family and OEM printer entries
    o 3 more new printer entries
    o More auto-detection info from Tim Waugh from Red Hat
  * New site name: linuxprinting.org --> OpenPrinting

 -- Till Kamppeter <email address hidden> Wed, 17 Jan 2007 22:21:05 +0000

This fixes many of the "missing driver" issues by marking more drivers obsolete and delivering data for generating PPDs only if the driver package does not deliver it (this will for example make the "ptouch" driver disappear in the printer setup tools until it gets actually included in the distro (or will be available for auto-download from the OpenPrinting web site). But this does not fix all these issues, as there are many drivers which are not in Ubuntu but their Foomatic data is delivered by foomatic-db.

Get the new package here to try it out:

http://www.freestandards.org/~till/tmp/ubuntu/feisty/foomatic-db/
http://www.freestandards.org/~till/tmp/ubuntu/feisty/foomatic-db/binary/

In addition, I submitted several new drivers for inclusion in Ubuntu, see and try:

http://www.freestandards.org/~till/tmp/ubuntu/feisty/

Changed in gutenprint:
status: Fix Committed → Fix Released

SpliX and pxljr made it into Main now, m2300w is in universe.

m2300w is also in Main now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers