Firmware upload to LJ 1000/1005/1008/1020 broken (fix to be proposed as Edgy update)

Bug #65618 reported by Oscar on 2006-10-12
74
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
foo2zjs (Ubuntu)
Medium
Unassigned
Edgy
Medium
Unassigned

Bug Description

The firmware files aren't loaded correctly when the printer is powered on, and it seems there _are_ no firmware files installed by the package at all.

More info: bug #6017

Till Kamppeter (till-kamppeter) wrote :

At first, firmware files cannot be shipped with the distribution due to copyright reasons. Therefore the foo2zjs author has added the "getweb" tool to the driver to get the firmware easily downloaded from the manufacturer's web site.

The bug is that links to the script for UDEV-triggered firmware loading into the printer are missing and that the UDEV rules need an update.

Till Kamppeter (till-kamppeter) wrote :

More info: bug #6017

(This should get a link automatically)

Changed in foo2zjs:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Please remove all your symlinks and try the foo2zjs package

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu1_i386.deb

and report your results here. Thanks.

Changed in foo2zjs:
status: Confirmed → Needs Info
Oscar (oscar-minioffroad) wrote :

After installing it, downloading the firmware, putting it in the right place and changing the name of it, I get:

Oct 15 10:35:37 laban kernel: [17561839.564000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 10 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
Oct 15 10:35:37 laban /usr/bin/hplj1020: loading HP LaserJet 1020 firmware /usr/share/foo2zjs/firmware/sihp1020.dl to /dev/usblp0 ...
Oct 15 10:35:38 laban /usr/bin/hplj1020: ... download successful.

But the foo2zjs driver isn't visible in gnome-print under drivers, it selects a LaserJet 1010 with hpijs that doesn't work.

Till Kamppeter (till-kamppeter) wrote :

Can you run

lpinfo -m | grep foo2zjs

Can you also update foomatic-db to the most recent version? The information about foo2zjs used by the LaserJet 1020 is in the foomatic-db package.

Oscar (oscar-minioffroad) wrote :

"lpinfo -m | grep foo2zjs" returns nothing.

foomatic-db is version 20060918-0ubuntu2

Till Kamppeter (till-kamppeter) wrote :
Download full text (3.4 KiB)

This is strange for me, probably you need to re-install foomatic-db and foomatic-db-engine on your machine.

I get (with up-to-date Edgy):

till@laptoptill:~$ lpinfo -m | grep foo2zjs
foomatic:Generic-GDI_Printer-foo2zjs.ppd Generic GDI Printer Foomatic/foo2zjs
foomatic:Generic-ZjStream_Printer-foo2zjs.ppd Generic ZjStream Printer Foomatic/foo2zjs (recommended)
foomatic:HP-LaserJet_1000-foo2zjs.ppd HP LaserJet 1000 Foomatic/foo2zjs (recommended)
foomatic:HP-LaserJet_1005-foo2zjs.ppd HP LaserJet 1005 Foomatic/foo2zjs (recommended)
foomatic:HP-LaserJet_1018-foo2zjs.ppd HP LaserJet 1018 Foomatic/foo2zjs (recommended)
foomatic:HP-LaserJet_1020-foo2zjs.ppd HP LaserJet 1020 Foomatic/foo2zjs (recommended)
foomatic:HP-LaserJet_1022-foo2zjs.ppd HP LaserJet 1022 Foomatic/foo2zjs (recommended)
foomatic:KonicaMinolta-magicolor_2300_DL-foo2zjs.ppd KonicaMinolta magicolor 2300 DL Foomatic/foo2zjs
foomatic:KonicaMinolta-magicolor_2430_DL-foo2zjs.ppd KonicaMinolta magicolor 2430 DL Foomatic/foo2zjs
foomatic:Minolta-Color_PageWorks_Pro_L-foo2zjs.ppd Minolta Color PageWorks/Pro L Foomatic/foo2zjs (recommended)
foomatic:Minolta-magicolor_2200_DL-foo2zjs.ppd Minolta magicolor 2200 DL Foomatic/foo2zjs (recommended)
foomatic:Minolta-magicolor_2300_DL-foo2zjs.ppd Minolta magicolor 2300 DL Foomatic/foo2zjs (recommended)
foomatic:Minolta-magicolor_2430_DL-foo2zjs.ppd Minolta magicolor 2430 DL Foomatic/foo2zjs (recommended)
till@laptoptill:~$ dpkg -l '*foomatic-db*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii foomatic-db 20060918-0ubun linuxprinting.org printer support - database
ii foomatic-db-en 3.0.2-20060925 linuxprinting.org printer support - programs
un foomatic-db-gu <none> (no description available)
ri foomatic-db-hp 20060925-0ubun linuxprinting.org printer support - database
till@laptoptill:~$ dpkg -L foomatic-db | grep foo2zjs
/usr/share/foomatic/db/source/driver/foo2zjs.xml
/usr/share/foomatic/db/source/opt/foo2zjs-ColorMode.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Copies.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Duplex.xml
/usr/share/foomatic/db/source/opt/foo2zjs-ICM.xml
/usr/share/foomatic/db/source/opt/foo2zjs-InputSlot.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Intent.xml
/usr/share/foomatic/db/source/opt/foo2zjs-MediaType.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Nup.xml
/usr/share/foomatic/db/source/opt/foo2zjs-NupOrient.xml
/usr/share/foomatic/db/source/opt/foo2zjs-PageSize.xml
/usr/share/foomatic/db/source/opt/foo2zjs-PrinterType.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Quality.xml
/usr/share/foomatic/db/source/opt/foo2zjs-Resolution.xml
till@laptoptill:~$ dpkg -L foomatic-db | grep HP-LaserJet_1020.xml
/usr/share/foomatic/db/source/printer/HP-LaserJet_1020.xml
till@laptoptill:~$

So all files are there and they all are provided by the foomatic-db package.

Do you have the following link:

till@laptoptill:~$ dpkg -L foomatic-db-engine | g...

Read more...

Oscar (oscar-minioffroad) wrote :

After reinstall of foomatic-db and foomatic-db-engine I get the same results as you above. Still no go though. Here's the output (turning off the printer, on again they trying to print a testpage from the gnome printer settings)

Oct 20 18:35:01 laban kernel: [17426268.764000] usb 5-7: USB disconnect, address 9
Oct 20 18:35:03 laban kernel: [17426270.768000] usb 5-7: new high speed USB device using ehci_hcd and address 10
Oct 20 18:35:03 laban kernel: [17426270.920000] usb 5-7: configuration #1 chosen from 1 choice
Oct 20 18:35:03 laban kernel: [17426270.920000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 10 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
Oct 20 18:35:04 laban /usr/bin/hplj1020: loading HP LaserJet 1020 firmware /usr/share/foo2zjs/firmware/sihp1020.dl to /dev/usblp0 ...
Oct 20 18:35:04 laban /usr/bin/hplj1020: ... download successful.
Oct 20 18:35:14 laban kernel: [17426281.360000] usb 5-4: reset high speed USB device using ehci_hcd and address 8
Oct 20 18:35:26 laban hpiod: removing usblp driver interface=0 for hp:/usb/HP_LaserJet_1020?serial=JL04V75 io/hpiod/device.cpp 490
Oct 20 18:35:26 laban kernel: [17426294.068000] drivers/usb/class/usblp.c: usblp0: removed
Oct 20 18:35:27 laban foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600 -p9 -s7 -m1 -n1
Oct 20 18:35:29 laban foo2zjs-wrapper: gs -sPAPERSIZE=a4 -g9920x7016 -r1200x600 -sDEVICE=pbmraw
Oct 20 18:35:29 laban foo2zjs-wrapper: foo2zjs -r1200x600 -g9920x7016 -p9 -m1 -n1 -d1 -s7 -z1 -u 192x96 -l 192x96 -L 0 -P

Till Kamppeter (till-kamppeter) wrote :

This printer is not supported by HPLIP even if CUPS offers you an "hp:/..." URI. If there is also a "usb:/..." URI, select that. If not, do

sudo /etc/init.d/hplip stop

then turn off and turn on the printer again, wait until it stops blinking (automatic firmware upload) and create a queue with the "usb:/..." URI which CUPS will offer you now.

Does it work now?

Will tell to the HPLIP developers that HPLIP should not offer URIs for the HP LaserJet 1000/1005/1018/1020 or it should really support it (printing and toner level check).

Don, can you look into HPLIP whether you could either

- let the "hp" CUPS backend not show URIs for the HP LaserJet 1000/1005/1018/1020, as they do not work with HPLIP

OR

- make HPLIP supporting these printers (printing and toner level check)

Thanks.

Oscar (oscar-minioffroad) wrote :

"then turn off and turn on the printer again, wait until it stops blinking (automatic firmware upload)"

It doesn't start to blink when turning it on. And it doesn't sound the same way as when I have manually installed the driver, I still don't think the firmware gets uploaded like it should.

Stopping hplip doesn't help.

Till,

I will forward this request to Dave Suffield who owns the hp: backend.

Do you have a URL for this bug? Is it in Mandriva or Ubuntu or ?

Thanks,

-Don

On 10/20/06, Till Kamppeter <email address hidden> wrote:
>
> Don, can you look into HPLIP whether you could either
>
> - let the "hp" CUPS backend not show URIs for the HP LaserJet
> 1000/1005/1018/1020, as they do not work with HPLIP
>
> OR
>
> - make HPLIP supporting these printers (printing and toner level check)
>
> Thanks.
>
> --
> Package broken/incomplete, missing firmware files
> https://launchpad.net/bugs/65618
>

I am currently on IRC with the original poster, and we have found the cause of the problem. The firmware file was not in the correct format. It has to be converted first. The right way to do it is:

getweb 1020
sudo arm2hpdl sihp1020.img > /usr/share/foo2zjs/firmware/sihp1020.dl

(replace "1020" by "1000", "1005", "1018", or "1020" depending on your printer model).

Once the printer has a correct firmware file loaded, you will find the firmware version number in its ID string:

sudo usb_printerid /dev/usblp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;FWVER:20050401;

(firmware date may vary, replace /dev/usblp0, by /dev/usblp1, ... if needed)

Now the printer works, and not only with the "usb:/..." URI, but also with the "hp:/..." URI, Don, you do not need to search for a bug in HPLIP any more and you do not need to suppress the URIs for the LJ 1000/1005/1018/1020.

In terms of automatization of this non-trivial process, this exists already in printerdrake in Mandriva 2007, see the following feature request for solving it in Ubuntu 7.04:

https://features.launchpad.net/distros/ubuntu/+spec/printerdrake

Closing this bug for all packages, as it is not a bug but simply a usability problem.

Changed in hplip:
status: Unconfirmed → Rejected
Changed in foo2zjs:
status: Needs Info → Fix Released
Changed in foo2zjs:
status: Fix Released → In Progress
Changed in foo2zjs:
importance: Low → Medium

Update of the state of this bug report:

The HP LaserJet 1000, 1005, 1018, and 1020 are cheapo lasers, which need their firmware loaded whenever they are turned on.

Remaining problem with the current Ubuntu foo2zjs package (20060625dfsg-2) is that the automatic firmware upload via UDEV does not work.

I have made a new package

debdiff:
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu1.debdiff

Sources:
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/

Binary (i386):
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/

which solves the problem. The changes are only on the UDEV rules (to avoid conflicts with other UDEV rules and to work with the newest UDEV) and on the installation (in debian/rules file, some links were missing). See debdiff.

So my package needs to be put into Edgy (freeze exception) so that the firmware upload works automatically whenever the printer is turned on and once the firmware file is placed in /usr/share/foo2zjs/firmware/. The foo2zjs driver itself is not modified, so support for other printers cannot break by this change.

Therefore I have reopened the foo2zjs case ("in progress").

Freeze exception request for Edgy is on the way.

Changed in foo2zjs:
status: In Progress → Fix Committed

I is too late to go in Edgy, I will propose this as an official update.

Otherwise I will propose it upstream. I will send out the proposal in two week, during the Ubuntu Summit.

Changed in foo2zjs:
status: Fix Committed → In Progress
description: updated
Changed in foo2zjs:
importance: Undecided → Medium
status: Unconfirmed → In Progress

Stable Release Update (SRU) Request -- for EDGY

Impact of the bug

The HP LaserJet 1000, 1005, 1018, and 1020 are cheap laser printers from HP. In contrary to other printers, they need their firmware to be loaded into the printer whenever the printer is turned on. The driver for these printers "foo2zjs" comes with everything needed for the automatic loading of the firmware: UDEV rules, a script for the loading itself, and another script to download the firmware file from the manufacturer's web site (as distros cannot ship these copyrighted files).

Unfortunately, the UDEV rules coming with foo2zjs are broken and some symlinks are missing and therefore the upload does not work. This prevents any user from using the HP LaserJet 1000, 1005, 1018, and 1020.

Fix of the bug

The fixed package referenced in one of my comments above has once a fixed UDEV rule file (taken from Mandriva 2007 and tested by me there) and also all missing symlinks.

The debdiff

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu1.debdiff

shows the changes which only affect the file with the UDEV rules and the debian/rules file (for the links). The driver itself is not modified, so regressions on the other printers supported by foo2zjs are not possible.

The original reporter of the bug has confirmed that the fix works on his Edgy machine.

Patch on the current stable release:

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu1.debdiff

All discussion about this problem happened in this bug report. See the previous postings

Changed in foo2zjs:
status: In Progress → Fix Released
Matt Zimmerman (mdz) wrote :

Why does this patch modify the script using perl from debian/rules? it should be patched using a standard patch mechanism instead.

Please have Scott review the udev rules.

I have used the Perl line becayse the change is very simple, not more than a search and replace and so I avoided adding another file (the patch file).

For everyone who does not want to wait for the fix going into the official updates for Edgy, here instructions for applying it already now:

1. Download the fixed version:

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu1_i386.deb

2. Install it:

sudo dpkg -i foo2zjs_20060625dfsg-2ubuntu1_i386.deb

3. Download the firmware file

getweb 1000

(or 1005, 1018, 1020 depending on your printer model, the LaserJet 1022 does not need a firmware file, so skip this and the next step for this model)

4. Convert and install the firmware file:

sudo arm2hpdl sihp1000.img > /usr/share/foo2zjs/firmware/sihp1000.dl

(replace "1000" by "1005", "1018", or "1020" depending on your printer model)

5. Connect your printer to the USB of your computer and turn it on, its LEDs should blink. Do not connect your printer to a network print box or to a router.

6. If you did not do so yet, create a print queue for your printer, either via the gnome-cups-manager (Menu "System" -> "Administration" -> "Printing") or with the web interface of CUPS (http://localhost:631/, when asked for login and password, enter your user name and password).

In Feisty (release in April 2007) all this will get done automatically:

https://features.launchpad.net/distros/ubuntu/+spec/printerdrake

Following Scott James Remnant I have fixed the UDEV rules:

- Corrected number of UDEV rules file from 11 to 85, according to /etc/udev/rules.d/README (debian/11-hplj10xx.rules -> debian/85-hplj10xx.rules)
- 'BUS=="usb"' is deprecated, replaced with 'SUBSYSTEMS=="usb"'

This should not have any influence on the functionality in Edgy.

The new files are the following:

debdiff relative to current Edgy package (foo2zjs_20060625dfsg-2):

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.debdiff

Edgy i386 binary package for testing (works probably also on Feisty):

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu2_i386.deb

Source package for upload/build for Edgy and Feisty:

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg.orig.tar.gz
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.dsc
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.diff.gz

This version should replace the 2ubuntu1 version for the SRU Request and it should also be uploaded into the Feisty repository (can please someone with upload access do, thanks).

I have uploaded all files of the previous comment again. The UDEV rules contained deprecated "%e" tags, which I have removed now.

Please download all files again before proceeding.

!!!!!! DO NOT UPLOAD THIS TO EDGY !!!!!!!!

The "SUBSYSTEMS" key is not supported by the edgy udev, whereas the "BUS" key is not supported by the feisty udev.

The different distributions need different udev rules.

Everything is fixed now, all broken package files are replaced on my web space:

So upload the following files (all files have the date 23-Nov-2006 on my web space):

EDGY UPDATES

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.debdiff
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg.orig.tar.gz
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.dsc
http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.diff.gz

FEISTY

http://www.freestandards.org/~till/tmp/ubuntu/feisty/foo2zjs/foo2zjs_20060625dfsg.orig.tar.gz
http://www.freestandards.org/~till/tmp/ubuntu/feisty/foo2zjs/foo2zjs_20060625dfsg-4ubuntu1.dsc
http://www.freestandards.org/~till/tmp/ubuntu/feisty/foo2zjs/foo2zjs_20060625dfsg-4ubuntu1.diff.gz

The difference between the Edgy and Feisty version is that in the UDEV rules for Edgy the old "BUS" key is used, and for Feisty the new "SUBSYSTEMS" key. In addition, the Feisty version is built based on the latest Debian version (but this does not change anything in the installed binary package).

Here is also an Edgy binary:

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu2_i386.deb

Changed in foo2zjs:
status: Fix Released → Fix Committed
status: In Progress → Fix Committed
Changed in foo2zjs:
status: Fix Committed → Fix Released

Stable Release Update (SRU) Request -- for EDGY

Impact of the bug

The HP LaserJet 1000, 1005, 1018, and 1020 are cheap laser printers from HP. In contrary to other printers, they need their firmware to be loaded into the printer whenever the printer is turned on. The driver for these printers "foo2zjs" comes with everything needed for the automatic loading of the firmware: UDEV rules, a script for the loading itself, and another script to download the firmware file from the manufacturer's web site (as distros cannot ship these copyrighted files).

Unfortunately, the UDEV rules coming with foo2zjs are broken and some symlinks are missing and therefore the upload does not work. This prevents any user from using the HP LaserJet 1000, 1005, 1018, and 1020.

Fix of the bug

The fixed package referenced below has once a fixed UDEV rule file and also all missing symlinks. These changes were tested by the original poster of this bug report (Oscar). Scott James Remnant has reviewed the new UDEV rules and they are fully compatible with the UDEV version coming with Edgy now.

The debdiff

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.debdiff

shows the changes which only affect the file with the UDEV rules and the debian/rules file (for the links and adding a Perl search&replace line to fix a broken path in the firmware upload script). The driver itself is not modified, so regressions on the other printers supported by foo2zjs are not possible.

The original reporter of the bug (Oscar) has confirmed that the fix works on his Edgy machine.

Patch on the current stable release:

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/foo2zjs_20060625dfsg-2ubuntu2.debdiff

Source package files in

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/

All discussion about this problem happened in this bug report. See the previous postings.

UPDATE: Stable Release Update (SRU) Request -- for EDGY

All the files mentioned in the previous posting are updated by equally-named files at the same place now, please re-download them.

Changes are (proposed by cjwatson on IRC):

- Added foo2zjs.postinst to delete UDEV rules of older versions of the foo2zjs package (/etc/udev/rules.d/11-hplj10xx.rules)
- Let debian/changelog to direct the upload at edgy-proposed and not to edgy

Colin Watson (cjwatson) wrote :

Current version of Till's patch (attached here for the record) approved for upload to edgy-proposed. I'm setting the status back to "In Progress" until it's accepted into the archive.

Changed in foo2zjs:
status: Fix Committed → In Progress
Colin Watson (cjwatson) wrote :

No, really, attaching.

UPDATE for Feisty users

I have added the postinst script to delete old UDEV rules (see SRU update) also for the Feisty version:

Source:
http://www.freestandards.org/~till/tmp/ubuntu/feisty/foo2zjs/

Binary:
http://www.freestandards.org/~till/tmp/ubuntu/feisty/foo2zjs/binary/

So everything should work out-of-the-box now.

Mitja Pagon (sect2k) wrote :

The latest Edgy binary package from Till doesn't install, because it depends on libc6 2.5.0, while 2.4-1 is available in Edgy.

Sorry, seems that I have accidentally built the binary under Feisty. Now I have rebuilt from the same source files under Edgy. Download this file

http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu2_i386.deb

and install it. This one should work.

There are no changes on the source files. If they get uploaded onto the severs of Ubuntu they will correctky build under Edgy.

Martin Pitt (pitti) wrote :

Accepted into edgy-proposed, please go ahead with QA testing.

Changed in foo2zjs:
status: In Progress → Fix Committed
Jani Monoses (jani) wrote :

A friend confirmed this working on her LJ 1020 and I have successfully tested it on a LJ 1000 both using the .deb Till prepared.

How far is the QA testing? When will the Edgy update be released?

Note that I cannot test further that I already did when creating the update package, as I do not have a printer of HP's LaserJet 10xx series.

Weiers Coetser (coetserw) wrote :

I had to re-install ubuntu recently and decided to install Feisty Beta. My printer did not work automatically.

I followed the instructions to download the firmware (getweb 1020) and to change the downloaded .img file into a .dl file (sudo arm2hpdl sihp1020.img > sihp1020.dl).
I copied this firmware file into /usr/share/foo2zjs/firmware/

Only then did my printer print out a test page.

Did I understand correctly that this problem will only be fixed in Feisty +1?

In that case, I think it would be important to write a descent how to somewhere to install the printer. I think this printer is very popular because it is cheap. I would be quite prepared to write a how-to like this if somebody else can confirm that this is still a problem in feisty.

Michael Vogt (mvo) wrote :

The StableReleaseUpdates policy requires that two users report positive results from the test. I can't do the sru verification myself as I do not have the required hardware. When we have two positive reports the package can go into edgy-updates.

Oscar (oscar-minioffroad) wrote :

How should I do the testing?

Oscar, you need an Edgy system.

If this system is a 32-bit PC you download the binary .deb packages from

http://www.linux-foundation.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/

and install them with the "dpkg -i *.deb" command. After that make sure your printer's firmware is on your system (see earlier comment in this bug report). Now remove and re-add your print queue. After that everytime if you connect/turn on your printer its lights will blink for some seconds telling that the printer is receiving its firmware from the PC and you will be able to print.

On a 64-bit, PowerPC, ... Edgy download the files from

http://www.linux-foundation.org/~till/tmp/ubuntu/edgy/foo2zjs/

and do

sudo apt-get install build-essential
sudo apt-get build-dep foo2zjs
dpkg-source -x foo2zjs*.dsc
cd foo2zjs-*
dpkg-buildpackage -rfakeroot
cd ..
sudo dpkg -i foo2zjs*.deb

and otherwise proceed as in the beginning of this comment.

On Wed, May 23, 2007 at 09:21:38AM -0000, Till Kamppeter wrote:
> Oscar, you need an Edgy system.
>
> If this system is a 32-bit PC you download the binary .deb packages from
>
> http://www.linux-foundation.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/

If they are in the queue for an update, they should be in edgy-proposed.

--
 - mdz

Street_guy (admin-slaider) wrote :

nice work !

Martin Pitt (pitti) wrote :

Nobody tested the -proposed upload and gave feedback here for more than half a year, and I guess nobody cares about edgy desktop any more, so I removed the -proposed package.

Changed in foo2zjs:
status: Fix Committed → Won't Fix
Matthew East (mdke) wrote :

I have a friend using Edgy who is suffering from this bug. Till - the link http://www.freestandards.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/foo2zjs_20060625dfsg-2ubuntu2_i386.deb does not appear to work: is this package still around?

Matthew East (mdke) wrote :

Till - the package doesn't seem to be there either. The "binary" folder is empty and I don't see a source package for a version 2ubuntu2.

Katsudon (katsudon) wrote :

Wishlist 1.

It would be nice if (K)ubuntu did not say after plugging in the printer something like "Your printer is ready to use" (which is not true), but instead something like "you need to download the firmware manually, instructions are availeble here...".

Wishlist 2.

It would be even nicer if (K)ubuntu after plugging in the printer would launch automatically "getweb...."

Pablo Antonio (crazy2k) wrote :

Totally agreed with Katsudon. Is it possible to make that process of getting and installing the firmware automatic?

Pablo Antonio (crazy2k) wrote :

BTW, http://dev.linuxfoundation.org/~till/tmp/ubuntu/edgy/foo2zjs/binary/ is empty. Should I listen to foo2zjs' developers (http://foo2zjs.rkkda.com/) who say:
"*** DON'T USE the foo2zjs package from:
      Ubuntu, SUSE, Mandrake/Manrivia, Debian, RedHat, Fedora, Gentoo, Xandros, EEE PC, MacOSX, or BSD!
*** Download it here and follow the directions below. "?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers