Roboto fonts make printer crash (fonts-android)

Bug #1441210 reported by Jean-Sebastien Gosselin on 2015-04-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fonts-android (Debian)
Fix Released
Unknown
fonts-android (Ubuntu)
Medium
Gunnar Hjalmarsson
Trusty
High
Unassigned

Bug Description

trusty SRU request
==================

[Impact]

When using Roboto fonts (the fonts-roboto package), printing fails with some printers. This has been fixed in later versions, so this proposed upload installs Roboto fonts from fonts-android 4.4.4r2 instead of 4.3. Unlike fonts-droid, fonts-roboto is not a seeded package, so while it's an annoying bug for those affected, this fix only affects those who explicitly install and use fonts-roboto.

[Test Case]

* Package: fonts-roboto 1:4.3-3ubuntu1.1

* Expected Results: When using Roboto fonts in a document (pdf, odf,
  etc.), I should be able to print the document.

* Current Results: Roboto fonts make the printer crash instead of
  printing. The printer I am using is a HP-Laser Jet P2055.

[Regression Potential]

Low.

[Original Description]

As per https://code.google.com/p/android/issues/detail?id=38383, there has been issues with the Roboto font family regarding printing. These issues seem to have been resolved in the new version of the fonts made available by Google in 2014 here http://developer.android.com/design/style/typography.html.

My setup:

1) Release: Ubuntu 14.04 LTS
2) Package: fonts-roboto 1:4.3-3ubuntu1.1
3) Expected Results: When using Roboto fonts in a document (pdf, odf, etc.), I should be able to print the document.
4) Current Results: Roboto fonts make the printer crash instead of printing. The printer I am using is a HP-Laser Jet P2055.

Steps to reproduce:

Install "fonts-roboto" package from Ubuntu Software Center. Produce a document in Libre Office with Roboto font and send to printer. Printer is crashing, need hard reboot.

Workaround:

(1) Remove "fonts-roboto" package from Ubuntu Software Center.
(2) Download new version of the fonts made available by Google and save them in the ".fonts" folder in "home" directory.
(3) Produce a new document with Roboto font and send to printer.
(4) Document is printing.

Basically, I think this package just need to be updated to use the latest fonts issued by Google.

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Jean-Sebastien, and thanks for your report. We are using the Debian version of fonts-roboto (which is built from the fonts-android source package), so it would be great if you also could file a bug report against fonts-android in Debian's bug tracker, and post a link to that bug here.

https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=fonts-android

I have filed a bug report in Debian here:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782116

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks!

It just struck me... Possibly we already have the working fonts in the archive, since there was a new upstream version in vivid. Can you please install the vivid version of fonts-droid and let us know if it fixes the problem:

https://launchpad.net/ubuntu/+archive/primary/+files/fonts-droid_4.4.4r2-6_all.deb

Changed in fonts-android (Ubuntu):
status: New → Incomplete

Using fonts-roboto 1:4.4.4r2-6 in Ubuntu 14.04 LTS solved the issue.

I am able to print my document.

Is this package likely to be pushed to the 14.04 LTS version?

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for testing. Well, it will backported to trusty if someone does it. ;) I'll propose something.

Changed in fonts-android (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in fonts-android (Debian):
status: Unknown → New
Gunnar Hjalmarsson (gunnarhj) wrote :

I have built a trusty version of fonts-android in my PPA with the newer versions of the Roboto fonts:

https://launchpad.net/~gunnarhj/+archive/ubuntu/roboto-test

So, Jean-Sebastien, before I propose it for the 14.04 archive, it would be great if you could install fonts-roboto 1:4.3-3ubuntu1.2~ppa and let us know if it fixes the issue.

Changed in fonts-android (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

@Jean-Sebastien: Any chance that you can test fonts-roboto in my PPA? I'm disinclined to propose a change to 14.04 without knowing that it fixes the issue.

Changed in fonts-android (Ubuntu):
status: In Progress → Incomplete

@Gunnar Unfortunately, I won't have access to the HP-Laser Jet P2055 on which I had the issue until next week. I've been unable to reproduce the bug with a Brother-HL-2270DW-series that is more recent than the HP one.

I will test your package as soon as I have access to the HP-Laser Jet P2055 again, that is next week. I apologize for the delay.

Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, no problem. I just wanted to make sure that you hadn't forgotten. ;) Thanks in advance!

I've been able to test your fonts-android PPA with the HP-Laser Jet P2055 sooner than I expected.

I was able to reproduce the issue using fonts-roboto 1:4.3-3ubuntu1.1

After installing the version from your ppa (fonts-roboto 1:4.3-3ubuntu1.2~ppa), it solved the problem and I was able to successfully print a Roboto test page with the HP-Laser Jet P2055.

I've join two pdf documents to this bug report. One produced with the fonts-roboto 1:4.3-3ubuntu1.1 and the other one with the fonts-roboto 1:4.3-3ubuntu1.2~ppa.

description: updated
Changed in fonts-android (Ubuntu):
status: Incomplete → In Progress
Changed in fonts-android (Ubuntu):
status: In Progress → Fix Released
Changed in fonts-android (Ubuntu Trusty):
importance: Undecided → High
status: New → Triaged

Hello Jean-Sebastien, or anyone else affected,

Accepted fonts-android into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fonts-android/1:4.3-3ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fonts-android (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I have successfully installed fonts-roboto 1:4.3-3ubuntu1.2 (and fonts-droid 1:4.3-3ubuntu1.2) from trusty-proposed. A more recent set of Roboto fonts was installed, and fontconfig behaved as expected. The bug reporter has previously (comment #12) confirmed that the change actually addresses the reported issue.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-android - 1:4.3-3ubuntu1.2

---------------
fonts-android (1:4.3-3ubuntu1.2) trusty-proposed; urgency=medium

  * debian/new-roboto-fonts/*, debian/fonts-roboto.install:
    - Install Roboto fonts from upstream version 4.4.4r2 (LP: #1441210).

 -- Gunnar Hjalmarsson <email address hidden> Thu, 09 Apr 2015 15:44:00 +0200

Changed in fonts-android (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for fonts-android has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in fonts-android (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.