Comment 6 for bug 1334495

I only have the problem since updating to 14.04, so it really might be connected to the font change.

It is the standard font setting dialog in the KDE control center. I could try to change the font with a different tool to see if it would change anything. Do you know what package I would have to install to get the Gnome font settings? Or is there a more low level way to change the default font? KDE also has a dialog to choose a specific font for Gnome applications, but there the font is set to Ubuntu, too.

I played a bit with the KDE font settings and tried different fonts. With some of them, Chinese text is displayed normally:
*Serif
*AR PL UKai CN
*WenQuanYi Micro Hei
The with the last two somehow make sense, as they are genue Chinese fonts. I am not sure about "Serif"?

I also tried various standard fonts, they all displayed the problem:

*Sans Serif
*Arial
*Courier
*Droid Sans Mono
*Droid Serif

Also, I noticed that I have three different Droid Mono fonts in my system font settings. Is that supposed to be this way or might it be connected to the problem? The listed Droid fonts are:

*Droid Sans [monotype]
*Droid Sans [unknown]
*Droid Sans Mono
*Droid Serif

In KDE's font manager however, Droid Sans is only displayed once. I attached screenshots for both dialogs.

Anything else I could/should try?