flint ftbfs on armel (assembler errors)

Bug #860882 reported by Matthias Klose on 2011-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flint (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

see https://launchpadlibrarian.net/81224524/buildlog_ubuntu-oneiric-armel.flint_1.011-2_FAILEDTOBUILD.txt.gz

gcc -fPIC -std=c99 -g -O2 -g -O2 -Wall -funroll-loops -I/usr/include -I/usr/include/NTL -c ZmodF.c -o ZmodF.o
ZmodF.c: In function 'ZmodF_divby3':
ZmodF.c:556:18: warning: unused variable 'rem' [-Wunused-variable]
/tmp/ccuSSTb5.s: Assembler messages:
/tmp/ccuSSTb5.s:4611: Error: selected processor does not support Thumb mode `rsc lr,lr,lr'
make[1]: *** [ZmodF.o] Error 1

Related branches

Matthias Klose (doko) on 2011-09-27
Changed in flint (Ubuntu Oneiric):
importance: Undecided → Medium
status: New → Confirmed
Michael Hope (michaelh1) wrote :

Thank you for the bug report. I've confirmed this with gcc-linaro-4.6-2011.09-1 on ARM:

michaelh@leo2:~/linaro/packages/flint-1.011$ /tools/toolchains/arch/armv7l/gcc-linaro-4.6-2011.09-armv7l-natty-cbuild181-ursa4-cortexa9r1/bin/gcc -fPIC -std=c99 -g -O1 -c ZmodF.i
/tmp/cc9K1v0U.s: Assembler messages:
/tmp/cc9K1v0U.s:2087: Error: selected processor does not support Thumb mode `rsc ip,r2,r2'

The assembler is correct - the rsc instruction is only available in ARM mode.

The fault is caused by the inline assembly in longlong.h. It should be updated for Thumb-2 or disabled.

Marcin Juszkiewicz (hrw) on 2011-10-12
tags: added: thumb2
Jani Monoses (jani) wrote :

The package has not been updated in over 3 years in Debian, and upstream has since had many releases.
http://www.flintlib.org/
Does not look like people care much about it in Ubuntu/Debian and I see no packages depending on it in the archive.
Would it not make more sense to replace it with a 2.x version or just remove it from the archive?

Adam Conrad (adconrad) on 2012-06-26
Changed in flint (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flint - 1.011-2ubuntu1

---------------
flint (1.011-2ubuntu1) quantal; urgency=low

  * Fix the inline ASM for ARM to specify .arm mode, so it works
    correctly when compiling with -mthumb-interwork (LP: #860882)
 -- Adam Conrad <email address hidden> Mon, 25 Jun 2012 18:43:41 -0600

Changed in flint (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers