package flashplugin-downloader failed to install/upgrade: wget: unable to resolve host address `archive.canonical.com'

Bug #870643 reported by jeeribaldi on 2011-10-08
648
This bug affects 89 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
High
Unassigned

Bug Description

Doing an full update on 11.10, Beta 2 (from around 9/25/11), in a VB Guest, w/ an Ubuntu 11.04 host. All 32 bit installation media.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: flashplugin-downloader 11.0.1.152ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sat Oct 8 04:29:07 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110922)
SourcePackage: flashplugin-nonfree
Title: package flashplugin-downloader 11.0.1.152ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

jeeribaldi (jeeribaldi) wrote :
tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Here is what causes the error:
Setting up flashplugin-downloader (11.0.1.152ubuntu1) ...
Downloading...
--2011-10-08 04:28:56-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.0.1.152.orig.tar.gz
Resolving archive.canonical.com... failed: Name or service not known.
wget: unable to resolve host address `archive.canonical.com'
download failed
The Flash plugin is NOT installed.
dpkg: error processing flashplugin-downloader (--configure):
 subprocess installed post-installation script returned error exit status 1

summary: package flashplugin-downloader 11.0.1.152ubuntu1 failed to
- install/upgrade: subprocess installed post-installation script returned
- error exit status 1
+ install/upgrade: wget: unable to resolve host address
+ `archive.canonical.com'
Changed in flashplugin-nonfree (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
importance: Medium → High
tags: added: iso-testing

Could one affected by this bug attach the file /etc/apt/apt.conf and the output of the command
$ apt-config shell http_proxy Acquire::http::Proxy https_proxy Acquire::https::Proxy

Thanks in advance.

Changed in flashplugin-nonfree (Ubuntu):
status: Triaged → Incomplete
jeeribaldi (jeeribaldi) wrote :

Output of $ apt-config shell http_proxy Acquire::http::Proxy https_proxy Acquire::https::Proxy
There is no output from the above command

apt.conf is not in the location described /etc/apt.conf, But I found a copy located at /usr/share/doc/apt/examples. The text is as follows:

// $Id: apt.conf,v 1.43 1999/12/06 02:19:38 jgg Exp $
/* This file is a sample configuration file with a few harmless sample
   options.
*/

APT
{
  // Options for apt-get
  Get
  {
     Download-Only "false";
  };

};

// Options for the downloading routines
Acquire
{
  Retries "0";
};

// Things that effect the APT dselect method
DSelect
{
  Clean "auto"; // always|auto|prompt|never
};

DPkg
{
  // Probably don't want to use force-downgrade..
  Options {"--force-overwrite";}
}

I am assuming that this copy of apt.conf is not in use.

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

This may be related to bug 859373.

Jared Tarter (jaredtarter) wrote :

I was just doing a clean install of Ubuntu 11.10 in Virtual Box with a Windows 7 64-bit host and the installer crashed and sent me to this page saying it had already been reported. It looks like this one is for an upgrade and with an Ubuntu 11.04 host though. I'm not sure if it helps anyone knowing that it happens with a clean install and on a Windows 7 host.

Chan Ju Ping (rewarp) wrote :

My clean installation of the 64bit 11.10 failed and sent me to this page.

Frungi (frungi) wrote :

While installing from a disk image, I lost internet access when installation was nearly complete, so the installer "crashed" and sent me here.

Charlie Ogier (cogier) wrote :

While installing Kubuntu 11.10 on a Dell 5150 alongside XP and Ubuntu 10.04 the installer crashed and sent me here

Charlie Ogier (cogier) wrote :

Work around.

Having seen the comment by Jean-Baptiste Lallement (jibel) regarding Flash. I removed the partitions etc, and reinstalled this time without selecting the "Install 3rd party software...." and all seems well.

J Richard Miller (jrmiller2) wrote :

my installer crashes and reports this bug as well...

In my case, and hopefully it's useful as an informative anecdote, I was changing wifi access point horses in mid-install stream. I believed I had timed it after a period of package downloading as I moved from the house wifi SSID to the mobile-tether wifi AP so I could continue the install on the little netbook while kids were being shuttled to dentist, practice, what-have-you.

I suspect the flash downloader balked at this sort of tweaked-out multitasking and promptly brought the whole shebang crumbling to its knees.

At least I like to think I did it and didn't just fumble across a rather banal little bug that your average joe finds on a regular basis.

Hope it's helpful!

Richie (jrmiller2 at g dot c)

sam-c (cohensam) wrote :

this is on asus 904hd to upgrade ubuntu or repair
Uncle Sam
Thanks

NaneNare (nanenare) wrote :

Hello

I have this problem too but I can't understand how fixed it.
And that link about Flash Plugin is not sport.

Regards,
NN

Whorehay (whorehay) wrote :

I can confirm this is affecting me on Kubuntu 12.04 (64-bit edition). I have downloaded the past 2 daily builds and it has caused the installer to crash when it is almost done.

Erick Brunzell (lbsolost) wrote :

Also effecting the Alpha 2 i386 iso testing image. I will follow up.

Erick Brunzell (lbsolost) wrote :

Please see bug 912031. In this case installation failed very late in the process, after all selections had been made.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/870643

Erick Brunzell (lbsolost) wrote :

Fails with both Lubuntu i386 20120131 & Ubuntu i386 20120131.3.

tags: added: alpha-2 amd64 precise
Chris Brody (chris-brody) wrote :

To Janne Jokitalo, thank you for your attention to tag this problem for amd64 and precise (12.04) alpha-2. I am subscribed to this problem, I am happy to retest on my amd64 laptop once I get notification that a fix has been made.

tags: added: rls-mgr-p-tracking
MinSik CHO (mscho527) wrote :

same thing happens to 12.04 Precise alpha-2 when installing under vbox.

anewguy (anewguy) wrote :

Tried an upgrade from 11.10 to 12.04 using the daily 12.04 bleeding edge. That upgrade hung at the point where it was removing existing files. After that, kept getting errors whenever I tried to use the install the re-do the partitions. Finally had to boot the CD and "Try Ubuntu" so I could get to disk utility and mark the old Ubuntu partitions for formatting (the Windows 7 partitions were never touched). Then tried to boot and do normal install - got the same type of error in the partitioner. Went back to live mode, reran disk utility and just made a single large free space out of the old partitions, then went into install and manually did the partitioning (for Ubuntu - the Windows 7 partitions were never touched). Now after all this work on the install, it was in the middle of downloading updates from the net (in the installation process) when it went belly up with this error.

The problem is in the 64 bit as well. I've recently tried installing Ubuntu Precise 12.04 Alpha 2 on a clean formatted ext4 partition and experienced the same issue. Please fix it asap.

Eddie Kane (eddiekane150) wrote :

Same here 12,04 alpha 2 upgrade from 1 on ext4 HDD.

tags: added: bugpattern-written
summary: - package flashplugin-downloader 11.0.1.152ubuntu1 failed to
- install/upgrade: wget: unable to resolve host address
- `archive.canonical.com'
+ package flashplugin-downloader failed to install/upgrade: wget: unable
+ to resolve host address `archive.canonical.com'

On Fri, February 3, 2012 9:02 am, Brian Murray wrote:
> ** Summary changed:
>
> - package flashplugin-downloader 11.0.1.152ubuntu1 failed to
> install/upgrade: wget: unable to resolve host address
> `archive.canonical.com'
> + package flashplugin-downloader failed to install/upgrade: wget: unable
> to resolve host address `archive.canonical.com'

Hmm, ubuntustudio, 12.04 feb 3 2012 build installed ok and flash works.
Has this bug been fixed?

--
Len Ovens
www.OvenWerks.net

tags: added: rls-p-tracking
tags: removed: rls-p-tracking
Martin Pitt (pitti) wrote :

Removing rls-p tags. This is essentially a duplicate of bug 876298, but I don't want to mark it so, to avoid 876298 getting too many.

tags: removed: rls-mgr-p-tracking

Martin, while looking through recent Ubuntu bugs, I saw how many dupes there are of this, basically generated by network failures of one kind or another. So far, I've seen piles and piles of unconfirmed reports, with one user listed affected. They really look like they need duping. I don't know anything about when a bug has too many dupes, as you're talking about. I'm duping them to here. Let me know if there's something else you think ought to be done. Thanks.

Oops, Martin's not subscribed here. Someone else may certainly know, but I'll try to mail him.

I just found out that with today's upgrades, bug 876298 is fixed. As Martin said, this bug is a duplicate of that, but is not marked so, for technical limits, or whatever we shall call them.

So I'm marking this bug 'Fix Released'.

Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions