Flashplugin-nonfree post-installation script failing

Bug #61562 reported by Bulldog on 2006-09-21
8
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

The Macromedia Flash Plug-in will not initialize and I am finding it is heavily used on most of the Packages, I am sure I am not the first person to report this bug, will there be a fix in the near future eh?

Thanks and KEEP UP THE GREAT work

William Grant (wgrant) wrote :

What do you mean it won't initialise? And heavily used on what Packages?

Chung-Yen Chang (candyz) wrote :

Setting up flashplugin-nonfree (7.0.68~ubuntu1~dapper1) ...
Downloading... done.
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
                -n: not really
                -f: force
dpkg: error processing flashplugin-nonfree (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

The flash-plugin doesn't auto install with most of the packages that install
it as part of their framework, almost all audio related one's (faad, oggenc,
oggdec, normalize) as well as (Hotkeys, and RealPlayer, lib files, Firefox
think that covers most of it) each install of a new package it asks to
download and install the plug-in then reports this error below in quotes

" E: flashplugin-nonfree: subprocess post-installation script returned error
exit status 1
E: clvm: subprocess post-installation script returned error exit status 3
E: redhat-cluster-suite: dependency problems - leaving unconfigured
E: system-config-cluster: dependency problems - leaving unconfigured "

On 9/20/06, William Grant <email address hidden> wrote:
>
> What do you mean it won't initialise? And heavily used on what Packages?
>
> ** Changed in: Ubuntu
> Sourcepackagename: None => flashplugin-nonfree
> Status: Unconfirmed => Needs Info
>
> --
> Flashplugin-nonfree
> https://launchpad.net/bugs/61562
>

This is the latest backports package's bug.
It was backported to solve Malone bug #38904 and #48620. (Request for backports is #61216)

This problem is due to that, the init system of edgy and dapper are different.

How to fix:
Edit flashplugin-nonfree's postinst, and find this line:
update-rc.d flashplugin-nonfree multiuser >/dev/null
replace "multiuser" with "defaults" will do.

I tried this method in dapper, and it works smoothly.

Changed in flashplugin-nonfree:
status: Needs Info → Confirmed

Where do I locate the postinst? or are you referring to this as a terminal
string command? I get the following message:

update-rc.d: symlink: Permission denied

Sorry I am day 2 on Linux :)

On 9/20/06, Wen-Yen Chuang <email address hidden> wrote:
>
> This is the latest backports package's bug.
> It was backported to solve Malone bug #38904 and #48620. (Request for
> backports is #61216)
>
> This problem is due to that, the init system of edgy and dapper are
> different.
>
> How to fix:
> Edit flashplugin-nonfree's postinst, and find this line:
> update-rc.d flashplugin-nonfree multiuser >/dev/null
> replace "multiuser" with "defaults" will do.
>
> I tried this method in dapper, and it works smoothly.
>
> ** Changed in: flashplugin-nonfree (Ubuntu)
> Status: Needs Info => Confirmed
>
> --
> Flashplugin-nonfree
> https://launchpad.net/bugs/61562
>

edit /var/lib/dpkg/info/flashplugin-nonfree.postinst
and replace "multiuser" with "defaults".
(You have to use sudo, e.g. sudo gedit /var/lib/dpkg/info/flashplugin-nonfree.postinst)

Then execute:
sudo apt-get install flashplugin-nonfree

Then it is done.

This is what the file cotains, but no "multiuser" to change to defaults

#!/bin/sh

set -e

. /usr/share/debconf/confmodule

case "$1" in
    configure*)
    db_get flashplugin-nonfree/local
    if [ -d "$RET" -a -f "$RET"/install_flash_player_7_linux.tar.gz ]; then
    LOCALFILE="-l $RET"
    INSTALL="true"
    fi
    if [ -z "$LOCALFILE" ]; then
    db_get flashplugin-nonfree/httpget
    if [ "$RET" = "true" ]; then
        INSTALL=$RET
    fi
    fi
    if [ "$INSTALL" = "true" ]; then
    /usr/sbin/update-flashplugin -u > /dev/null 2>&1 || true
        FAILED="false"
    /usr/sbin/update-flashplugin $LOCALFILE > /dev/null 2>&1 ||
FAILED="true"
    if [ $FAILED = "true" ]; then
        /usr/sbin/update-flashplugin -u > /dev/null 2>&1 || true
        db_text medium flashplugin-nonfree/failed || true
        db_go
    fi
    fi
    db_fset flashplugin-nonfree/local seen false
    db_fset flashplugin-nonfree/httpget seen false
    db_fset flashplugin-nonfree/failed seen false
    ;;
esac

On 9/20/06, Wen-Yen Chuang <email address hidden> wrote:
>
> edit /var/lib/dpkg/info/flashplugin-nonfree.postinst
> and replace "multiuser" with "defaults".
> (You have to use sudo, e.g. sudo gedit /var/lib/dpkg/info/flashplugin-
> nonfree.postinst)
>
> Then execute:
> sudo apt-get install flashplugin-nonfree
>
> Then it is done.
>
> --
> Flashplugin-nonfree
> https://launchpad.net/bugs/61562
>

Bulldog, add this in the end of file, and try again:

# Automatically added by dh_installinit
if [ -x "/etc/init.d/flashplugin-nonfree" ]; then
 update-rc.d flashplugin-nonfree defaults >/dev/null
 if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
  invoke-rc.d flashplugin-nonfree start || exit $?
 else
  /etc/init.d/flashplugin-nonfree start || exit $?
 fi
fi
# End automatically added section

But the Mozzila Firefox (version 1.5.0.5) is not correctly working with some files flash still, this after upgrade.

This last bit going to affect it as well?

Setting up clvm (2.02.02-1ubuntu1) ...
Starting Cluster LVM Daemon clvmd could not connect to cluster manager
Consult syslog for more information
invoke-rc.d: initscript clvm, action "start" failed.
dpkg: error processing clvm (--configure):
 subprocess post-installation script returned error exit status 3
dpkg: dependency problems prevent configuration of redhat-cluster-suite:
 redhat-cluster-suite depends on clvm; however:
  Package clvm is not configured yet.
dpkg: error processing redhat-cluster-suite (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of system-config-cluster:
 system-config-cluster depends on redhat-cluster-suite; however:
  Package redhat-cluster-suite is not configured yet.
dpkg: error processing system-config-cluster (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 clvm
 redhat-cluster-suite
 system-config-cluster
E: Sub-process /usr/bin/dpkg returned an error code (1)

The redhat-cluster-suite is installed under synaptic though

On 9/20/06, Alex Rocha <email address hidden> wrote:
>
> Bulldog, add this in the end of file, and try again:
>
> # Automatically added by dh_installinit
> if [ -x "/etc/init.d/flashplugin-nonfree" ]; then
> update-rc.d flashplugin-nonfree defaults >/dev/null
> if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
> invoke-rc.d flashplugin-nonfree start || exit $?
> else
> /etc/init.d/flashplugin-nonfree start || exit $?
> fi
> fi
> # End automatically added section
>
> But the Mozzila Firefox (version 1.5.0.5) is not correctly working with
> some files flash still, this after upgrade.
>
> --
> Flashplugin-nonfree
> https://launchpad.net/bugs/61562
>

The fix from Wen-Yen Chuang works for me.

Alex Rocha (alexrocha) wrote :

The fix from Wen-Yen Chuang works for me too. But the Firefox (version 1.5.0.5) is not correctly working with some files flash.
See: http://img214.imageshack.us/img214/7708/capturadatelaigoseuprovedordeinternetmozillafirefoxhc7.png

Kurt (e-mail-elmar-boos) wrote :

I can confirm the bug and the comment from Alex Rocha, that the fix works but firefox does not play flash movies.

Seems to finally be working with Firefox 1.5 for me on sites and youtube but
not sure about package installs. Thank you :)

On 9/21/06, Kurt <email address hidden> wrote:
>
> I can confirm the bug and the comment from Alex Rocha, that the fix
> works but firefox does not play flash movies.
>
> --
> Flashplugin-nonfree post-installation script failing
> https://launchpad.net/bugs/61562
>

Stefan Bethge (kjyv) wrote :

The package still has the problem, won't install if you don't fix manually.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers